Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

webp images wont display in firefox

  • 16 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 72 views
  • Last reply by TyDraniu

My website runs NGINX with PageSpeed module. It's fronted by a CDN. When I visit the homepage on Edge and Chrome, most of the images are webp and yet on Firefox they are jpg.

My Firefox version is 88.0 64 bit for Windows 10.

Does anyone know why this is happening as visitors to my site in Firefox are getting a slower response

Thanks

All Replies (16)

Did you make sure the WebP is enabled and also not blocked by an extension ?

  • about:config => image.webp.enabled = true

Firefox should send an image accept header that includes "image/webp" as a supported image format. You can possibly check this in the Network Monitor or Web Console.


Can you post a link to a publicly accessible page (i.e. no authentication or signing on required), so we can possibly check this ?

Helpful?

Hi - thanks for the information. The following are set to true:

image.webp.enabled browser.download.viewableInternally.typeWasRegistered.webp

The page with the issue is as follows:

https://www.visitfyldecoast.info/

Many Thanks

Kevin

Helpful?

Hi Kevin, could you clear your cache in Edge and Chrome to re-test on those browsers, or try an incognito window?

Unless you disable webp completely, Firefox include image/webp in the "Accept" request header. I assume the CDN looks for that when deciding to apply WebP compression "on the fly," but I don't know what else it might be looking for.

Helpful?

I'm not getting WebP images on the page you posted above despite that Firefox includes image/webp in the request header.

Helpful?

I really appreciate your responses here.

Just to be clear I DO want Firefox to display .webp images.

I just can't understand why Chrome and Edge are behaving as they should and displays .webp but Firefox doesn't and displays the .jpg version.

Please allow me some time to revisit the server because as per jscher2000's suggestion a new private window is displaying the jpg version on all 3 browsers.

Please bear with me while I investigate

Thanks Again

Helpful?

Bear in mind, domains can recognize your browser and so provide you with a website thats optimised for the best experience.

Helpful?

Quick update.

I can see errors in the PageSpeed module that were'nt there when I created this question. I have reported to the server team. This may explain why I presented the error to you all as a problem just with Firefox, but when you all looked - the problem was in all of them.

Please bear with me. The problem is present in one of my other sites, but let's not muddy the waters and stick with investigating this site. We can reconvene when I have an answer from support.

Thanks All

Helpful?

Hi all,

Can you please check again - webp images are once again displaying in Edge and Chrome but not Firefox.

Thanks

Kevin

Helpful?

I'm still not seeing WebP images in Firefox as well, so it could be that the server thinks that Firefox doesn't support WebP.

Can you open a webp image link in Firefox and actually get WebP (image/webp) and not JPG (image/jpeg) ?

Helpful?

I get JPEG images in Firefox and Chrome.

Do you get WebP for this image in both browsers?

https://i2.wp.com/radical-mag.com/wp-content/uploads/2019/08/@Test-BMW-320d-8.jpg

Helpful?

Hi thanks for the replies.

So... in Chrome I see the attached image as:

https://www.visitfyldecoast.info/wp-content/uploads/2021/04/x2021-storytelling-event-2-400x300.jpg.pagespeed.ic.CIdU40Frn-.webp

Which I can also display in Firefox. The trouble is that when I look at the source code in Chrome - the image is .webp, but in Firefox it's .jpg

Strange that you are seeing the jpg in all browsers which confuses me yet more

Thanks

Kevin

Helpful?

After changing the user agent to Chrome I can see some webp images.

Helpful?

TyDraniu,

Thanks for the reply, but are you able to explain why Edge / Chrome display .webp but Firefox doesn't?

Did you make the change to Firefox to be able to see the .webp images? I was hoping it was something that needed doing at the server side (or a bug) so that everyone would benefit from the performance improvements

Let me know - thanks

Kevin

Helpful?

Helpful?

TyDraniu,

That sounds promising. Is that a bug with NGINX or do I need to get my hosting company to make some kind of change on the sever.

If it needs a change on the server - what do I need to tell them.

Thank a million

Kevin

Helpful?

Let them check the version. They should update pagespeed to something recent (latest stable should contain this pull request from July 2020). Older one won't work with Firefox.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.