Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop firefox from ever going to full screen?

  • 3 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 36 views
  • Last reply by jscher2000

Quite often I accidentally double click on a video or a picture and Firefox decides it means I want to go to full screen. In my case it never does. I have never wanted to use full screen for anything in a browser and yet several times a month it decides by itself to go full screen. There is after all a reason I am using a computer and not a tablet(multiple windows).

So how do I stop Firefox from ever going to full screen mode regardless of what happens in Windows?

I have tried doing searches both on search engines, extensions and Firefox help site but all results seem to just point at the opposite solutions of always being full screen.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I can't think of an example where double-clicking an image or video causes it to go full-screen. On the other hand, I am very familiar with full-screen buttons on video player toolbars. If you don't want that kind of full-screen -- the kind that webpage scripts can invoke -- try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste full and pause while the list is filtered

(3) Double-click the full-screen-api.enabled preference to switch the value from true to false

Did that do what you need?

More info on about:config: Configuration Editor for Firefox.

Read this answer in context 👍 1

All Replies (3)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I can't think of an example where double-clicking an image or video causes it to go full-screen. On the other hand, I am very familiar with full-screen buttons on video player toolbars. If you don't want that kind of full-screen -- the kind that webpage scripts can invoke -- try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste full and pause while the list is filtered

(3) Double-click the full-screen-api.enabled preference to switch the value from true to false

Did that do what you need?

More info on about:config: Configuration Editor for Firefox.

Helpful?

Thank you. Seems to help. So it was just a large number of misbehaving web sites then.

Helpful?

I'm sure they thought they were doing you a favor. ;-)

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.