Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

loading Images

  • 14 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 107 views
  • Last reply by phred211

I am not getting images on Firefox with Mac.It says to go to tools...But I don't see tools, other things mentioned, such as content.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 👍 1

All Replies (14)

Well, Tools is one of the menus on the menu bar, but if the instructions next mentioned Options, those would be steps for Windows. On Mac, you access Preferences through Firefox > Preferences.

Which images are affected? For example:

  • Regular old photos
  • Background images (maybe also background colors?)
  • Button images/Icons

Does it vary by site?

Do you use any content blocking add-ons?

Helpful?

PDFs,videos.I go to preferences, but I do not see anything about image loading.I have followed various instructions from Firefox, but nothing solves the problem.For example it says to go to permissions, but there is not anything there about loading images.Thank you.

Helpful?

Yes, there used to be site-specific image permissions, but those went away in recent months.

Let's start with PDFs. Firefox usually can show a PDF in a tab in Firefox using its built-in viewer. What happens when you try to open a PDF? Does Firefox just save it, or ask you what to do, or open a blank tab, etc.

Videos are a bit different. Does YouTube work? How about other sites? If they don't work, is there any error message about the format, or just a continuous spinner, etc.?

Helpful?

There aren't any messages.It just won't go to the site in case of PDF .In video, the video came up, but it didn't play.I went to Chrome, and everything appeared.No error messages, or spinning.To repeat when I go to preferences,I do not see anything about loading images.

Helpful?

I don't want a site specific image feature.I want to allow all images.

Helpful?

Okay, but I haven't heard you mention a problem with images. You mentioned problems opening PDFs and playing videos. What is the problem with images -- do you get blank squares? Any particular sites?

You could try changing your PDF settings. This is the most relevant article: View PDF files in Firefox or choose another viewer.

Firefox blocks video autoplay. If a video seems like it should be playing -- for example, it shows a pause button even though you didn't start it yourself -- try clicking twice (pause, play). Any improvement?

Helpful?

I considered PDFs and videos as images.I give up.Firefox has forever reading instructions.

Helpful?

I don't get squares or anything.It Just doesn't go to the site.

Helpful?

I'm hesitant to add more instructions. Did you try my earlier suggestions already for PDFs and videos?

Helpful?

I have spent hours on this.Mozilla is a poor Co., if one has to spend hours trying to allow images.

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Helpful?

Hi phred211,

Would you do this please :

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type in the search bar and look for the preference :

permissions.default.image

And change its value to 2

Then close and restart Firefox, in order for the change to take effect.

Also see :

http://www.tech-recipes.com/rx/64881/how-to-disable-images-in-firefox/

'Hope that works for you  !

Helpful?

Thanks for the advice, but someone else solved the problem.I refreshed Firefox.

Helpful?

To: Corel : Refreshing solved the problem.Thank you. What changes did refreshing make, and what should I do to prevent recurrence?

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.