X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Debian system locale was changed but Thunderbird prevents its previous time format

  • 8 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by Brabella
பதிவிடப்பட்டது

Recently I've changed my Debian system locale from "en_US.UTF-8" to "C". Unfortunately, Thunderbird seems to not recognize this change and preserves its previous settings.

Any idea on how to update Thunderbirds locale to see the changed time format?

Recently I've changed my Debian system locale from "en_US.UTF-8" to "C". Unfortunately, Thunderbird seems to not recognize this change and preserves its previous settings. Any idea on how to update Thunderbirds locale to see the changed time format?

Brabella மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Okay, the solution to the problem was quite simple.

In Linux:

I had to edit the file "/etc/local.conf" and afterwards run "dpkd-reconfigure locales" and set the new desired locale as default.

Afterwards, all programmes incl. Thunderbird had the new locale format. Thank you very much guys!

Read this answer in context 0
மேற்கோள்

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

கூடுதல் தகவல்

День сумо
  • Top 25 Contributor
12 தீர்வுகள் 396 பதில்கள்
பதிவிடப்பட்டது

Hello there Brabella.

We have read your mail

we try to help you.

greetings Firefox Volunteer.

Thunderbird has not had a clock itself since 2006, not now 2018 or 2019 either.

Thunderbird has no clock or it's own and just takes the setting from your OS. Double check your OS's time zone settings and date settings. (the format set to use : HH:mm:ss in Regional and Language section? where the hours are capital H).

regards Thunderbird Volunteer. Happy Holidays.


https://addons.thunderbird.net/en-US/thunderbird/addon/super-date-format/

we had an add-on for recognizable problems of this kind, also for Linux users.It is unfortunately outdated.We have not seen any newer ones.Beware of installing outdated add-ons that will take a little bit with them.

https://wiki.debian.org/DateTime (Scanned with Totalvirus).

Hello there Brabella. We have read your mail we try to help you. greetings Firefox Volunteer. Thunderbird has not had a clock itself since 2006, not now 2018 or 2019 either. Thunderbird has no clock or it's own and just takes the setting from your OS. Double check your OS's time zone settings and date settings. (the format set to use : HH:mm:ss in Regional and Language section? where the hours are capital H). regards Thunderbird Volunteer. Happy Holidays. https://addons.thunderbird.net/en-US/thunderbird/addon/super-date-format/ we had an add-on for recognizable problems of this kind, also for Linux users.It is unfortunately outdated.We have not seen any newer ones.Beware of installing outdated add-ons that will take a little bit with them. https://wiki.debian.org/DateTime (Scanned with Totalvirus).

День сумо மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks for your answer!

День сумо said

Double check your OS's time zone settings and date settings.

Executing locale in command line interface brings up:

user@pc:~$ locale LANG=C LANGUAGE=en_US:en LC_CTYPE="C" LC_NUMERIC="C" LC_TIME="C" LC_COLLATE="C" LC_MONETARY="C" LC_MESSAGES="C" LC_PAPER="C" LC_NAME="C" LC_ADDRESS="C" LC_TELEPHONE="C" LC_MEASUREMENT="C" LC_IDENTIFICATION="C" LC_ALL=

I think everything looks fine here, no? In the past I have used the setting LC_TIME="en_US.UTF-8" what could have been the reason that Thunderbird is still using the American time formats up to now.

Well, the current (= updated) locale-config looks fine. How can I change Thunderbirds behavior or reload its time format settings?

Thanks for your answer! ''День сумо [[#answer-1266568|said]]'' <blockquote> Double check your OS's time zone settings and date settings. </blockquote> Executing ''locale'' in command line interface brings up: user@pc:~$ locale LANG=C LANGUAGE=en_US:en LC_CTYPE="C" LC_NUMERIC="C" LC_TIME="C" LC_COLLATE="C" LC_MONETARY="C" LC_MESSAGES="C" LC_PAPER="C" LC_NAME="C" LC_ADDRESS="C" LC_TELEPHONE="C" LC_MEASUREMENT="C" LC_IDENTIFICATION="C" LC_ALL= I think everything looks fine here, no? In the past I have used the setting ''LC_TIME="en_US.UTF-8"'' what could have been the reason that Thunderbird is still using the American time formats up to now. Well, the current (= updated) ''locale''-config looks fine. How can I change Thunderbirds behavior or reload its time format settings?

Brabella மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
День сумо
  • Top 25 Contributor
12 தீர்வுகள் 396 பதில்கள்
பதிவிடப்பட்டது

Hello there again. Brabella .


Thunderbird uses whatever you have set up on your computer.

Control Panel > Date and Time to set time to 24 hour.

Control Panel > Regional and Language Options This allows you to choose the format of various things.

Click on 'Customise this format' button Select 'Time' tab Capitals are used for a 24 hour clock. eg: HH:mm:ss Click on 'Apply' Click on OK

Click on 'Apply' Click on OK


Greetings Firefox.

Hello there again. Brabella . Thunderbird uses whatever you have set up on your computer. Control Panel > Date and Time to set time to 24 hour. Control Panel > Regional and Language Options This allows you to choose the format of various things. Click on 'Customise this format' button Select 'Time' tab Capitals are used for a 24 hour clock. eg: HH:mm:ss Click on 'Apply' Click on OK Click on 'Apply' Click on OK Greetings Firefox.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
sfhowes
  • Top 10 Contributor
1695 தீர்வுகள் 8239 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

In TB 68, look in the Date and Time Formatting section of Edit/Preferences/Advanced/General to choose the application locale or the regional settings locale.

http://kb.mozillazine.org/Date_display_format#Changing_the_information_displayed

In TB 68, look in the Date and Time Formatting section of Edit/Preferences/Advanced/General to choose the application locale or the regional settings locale. http://kb.mozillazine.org/Date_display_format#Changing_the_information_displayed
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 2
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Currently, locale via CLI responds a

user@pc:~$ locale LANG=C.UTF-8 LANGUAGE=en_US:en LC_CTYPE="C.UTF-8" LC_NUMERIC=C.UTF-8 LC_TIME=C.UTF-8 LC_COLLATE=C.UTF-8 LC_MONETARY=C.UTF-8 LC_MESSAGES="C.UTF-8" LC_PAPER="C.UTF-8" LC_NAME="C.UTF-8" LC_ADDRESS="C.UTF-8" LC_TELEPHONE="C.UTF-8" LC_MEASUREMENT=C.UTF-8 LC_IDENTIFICATION="C.UTF-8" LC_ALL=

sfhowes said

In TB 68, look in the Date and Time Formatting section of Edit/Preferences/Advanced/General to choose the application locale or the regional settings locale.

Unfortunately, Thunderbird does only provide English (United States) in the mentioned settings? :-(

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-11-14-12-33-54-098f6b.png

Currently, ''locale'' via CLI responds a user@pc:~$ locale LANG=C.UTF-8 LANGUAGE=en_US:en LC_CTYPE="C.UTF-8" LC_NUMERIC=C.UTF-8 LC_TIME=C.UTF-8 LC_COLLATE=C.UTF-8 LC_MONETARY=C.UTF-8 LC_MESSAGES="C.UTF-8" LC_PAPER="C.UTF-8" LC_NAME="C.UTF-8" LC_ADDRESS="C.UTF-8" LC_TELEPHONE="C.UTF-8" LC_MEASUREMENT=C.UTF-8 LC_IDENTIFICATION="C.UTF-8" LC_ALL= ''sfhowes [[#answer-1266635|said]]'' <blockquote> In TB 68, look in the Date and Time Formatting section of Edit/Preferences/Advanced/General to choose the application locale or the regional settings locale. </blockquote> Unfortunately, Thunderbird does only provide ''English (United States)'' in the mentioned settings? :-( https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-11-14-12-33-54-098f6b.png
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
sfhowes
  • Top 10 Contributor
1695 தீர்வுகள் 8239 பதில்கள்
பதிவிடப்பட்டது

Is the app locale EN-US even if you install TB for another language?

https://www.thunderbird.net/en-US/thunderbird/all/

If you're getting TB from your distro, it may be limited to the US version. TB 68 has an extra section to define the Language (see picture).

Is the app locale EN-US even if you install TB for another language? https://www.thunderbird.net/en-US/thunderbird/all/ If you're getting TB from your distro, it may be limited to the US version. TB 68 has an extra section to define the Language (see picture).
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
День сумо
  • Top 25 Contributor
12 தீர்வுகள் 396 பதில்கள்
பதிவிடப்பட்டது
Hello there Brabella. https://support.mozilla.org/en-US/kb/how-install-and-use-another-language-dictionary-th https://addons.thunderbird.net/en-us/thunderbird/addon/configdate/ Greetings Firefox Volunteer.

День сумо மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Okay, the solution to the problem was quite simple.

In Linux:

I had to edit the file "/etc/local.conf" and afterwards run "dpkd-reconfigure locales" and set the new desired locale as default.

Afterwards, all programmes incl. Thunderbird had the new locale format. Thank you very much guys!

Okay, the solution to the problem was quite simple. In Linux: I had to edit the file "/etc/local.conf" and afterwards run "dpkd-reconfigure locales" and set the new desired locale as default. Afterwards, all programmes incl. Thunderbird had the new locale format. Thank you very much guys!

Brabella மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.