X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Firefox not displaying fonts correctly

  • 25 replies
  • 33 இந்த பிரச்னைகள் உள்ளது
  • Last reply by dhnyny
பதிவிடப்பட்டது

Just started this past Friday, fonts not loading correctly. I get gibberish. See attached. Any help/advice is welcomed. Thanks. I am on a Mac. Firefox: 56.0

Just started this past Friday, fonts not loading correctly. I get gibberish. See attached. Any help/advice is welcomed. Thanks. I am on a Mac. Firefox: 56.0

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 27.0 r0

பயன்பாடு

  • Firefox 56.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:56.0) Gecko/20100101 Firefox/56.0
  • Support URL: https://support.mozilla.org/1/firefox/56.0/Darwin/en-US/

நீட்சிகள்

  • Adobe Acrobat DC - Create PDF 15.01.04 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • New Tab by Yahoo 1.3.0 (jid1-G80Ec8LLEbK5fQ@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x0fe9
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'TileHeight': 512, u'TileWidth': 512, u'ApzDragInput': 1, u'AzureFallbackCanvasBackend': u'none', u'ApzWheelInput': 1, u'AzureCanvasAccelerated': 1, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl1DriverExtensions: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_point_sprite GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: NVIDIA Corporation -- NVIDIA GeForce GT 750M OpenGL Engine
  • webgl1Version: 2.1 NVIDIA-10.4.2 310.41.35f01
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
  • webgl2Renderer: NVIDIA Corporation -- NVIDIA GeForce GT 750M OpenGL Engine
  • webgl2Version: 4.1 NVIDIA-10.4.2 310.41.35f01
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
dhnyny 0 தீர்வுகள் 15 பதில்கள்
பதிவிடப்பட்டது

I just began having this problem. I am running macOS 10.12.6 and Firefox 57.0.1.

One site where it occurs is daringfireball.net (see screenshot). That website displays without problems in Google Chrome.

You'll see that there are two sections where text isn't displaying properly. For the first section (h1), where the type is larger, the rule is font-family: "Gill Sans MT", "Gill Sans", "Gill Sans Std", Georgia, serif; and .LastResort is being substituted. For the second section (h2), the rule is font-family: "Gill Sans MT", "Gill Sans", "Gill Sans Std", Verdana, "Bitstream Vera Sans", sans-serif; and, again, .LastResort is being substituted. When I toggle off those rules, the text appears correctly (in Verdana, which is the font specified in a higher-level (body) rule).

Georgia, Verdana, and Gill Sans MT are all installed. I have tested them and they are not broken.

I tried changing security.sandbox.content.level from 3 to 1 and that had no effect.

From this thread I got the suggestion to try adding a rule. I added font-family: Verdana !important; and the text switched from .LastResort to Verdana and displayed correctly.

I've also consulted this thread and this thread which seem to be about the identical problem but found nothing that made a difference in them.

Something must have changed or gotten broken, because I previously had no such problem with the same browser and OS (unless, for some reason, I just never went to a site that displayed the problem before).

One final piece of conceivably relevant info: I manage fonts on my computer with Suitcase Fusion, which seems to be true (but not all) of the other users who are having this problem.

Any suggestions?

I just began having this problem. I am running macOS 10.12.6 and Firefox 57.0.1. One site where it occurs is daringfireball.net (see screenshot). That website displays without problems in Google Chrome. You'll see that there are two sections where text isn't displaying properly. For the first section '''(h1)''', where the type is larger, the rule is '''font-family: "Gill Sans MT", "Gill Sans", "Gill Sans Std", Georgia, serif;''' and .LastResort is being substituted. For the second section '''(h2)''', the rule is font-family: '''"Gill Sans MT", "Gill Sans", "Gill Sans Std", Verdana, "Bitstream Vera Sans", sans-serif; '''and, again, .LastResort is being substituted. When I toggle off those rules, the text appears correctly (in Verdana, which is the font specified in a higher-level '''(body)''' rule). Georgia, Verdana, and Gill Sans MT are all installed. I have tested them and they are not broken. I tried changing '''security.sandbox.content.level''' from 3 to 1 and that had no effect. From [https://support.mozilla.org/en-US/questions/1177565 this thread] I got the suggestion to try adding a rule. I added '''font-family: Verdana !important;''' and the text switched from .LastResort to Verdana and displayed correctly. I've also consulted [https://support.mozilla.org/en-US/questions/1179529 this thread] and [https://support.mozilla.org/en-US/questions/1177664 this thread] which seem to be about the identical problem but found nothing that made a difference in them. Something must have changed or gotten broken, because I previously had no such problem with the same browser and OS (unless, for some reason, I just never went to a site that displayed the problem before). One final piece of conceivably relevant info: I manage fonts on my computer with Suitcase Fusion, which seems to be true (but not all) of the other users who are having this problem. Any suggestions?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I believe my issue was a font problem. I use Font Agent Pro. Although, I was able to use Google Chrome with no issues what so ever (Firefox and Safari had this same font problem). I finally ended up taking font book back to "Restore Standard Fonts." I uninstalled/reinstalled Font Agent Pro. So far this has fixed this problem, but I haven't been using it this way for very long. Fingers are crossed this fixed the problem for good.

I believe my issue was a font problem. I use Font Agent Pro. Although, I was able to use Google Chrome with no issues what so ever (Firefox and Safari had this same font problem). I finally ended up taking font book back to "Restore Standard Fonts." I uninstalled/reinstalled Font Agent Pro. So far this has fixed this problem, but I haven't been using it this way for very long. Fingers are crossed this fixed the problem for good.
petruta.rasa 0 தீர்வுகள் 2 பதில்கள்
பதிவிடப்பட்டது

@dhnyny, @mrquig: Font Agent Pro issues from 57.0.1 were fixed in Firefox 57.0.2 in bug 1417420. Could you please update and let us know if your problem is now resolved?

Thank you!

@dhnyny, @mrquig: Font Agent Pro issues from 57.0.1 were fixed in Firefox 57.0.2 in bug 1417420. Could you please update and let us know if your problem is now resolved? Thank you!
dhnyny 0 தீர்வுகள் 15 பதில்கள்
பதிவிடப்பட்டது

I just updated to 57.0.2. The problem is not fixed. I'm using Suitcase Fusion 6, not Font Agent Pro, so perhaps the bug 1417420 fix doesn't address Suitcase Fusion users?

I just updated to 57.0.2. The problem is not fixed. I'm using Suitcase Fusion 6, not Font Agent Pro, so perhaps the bug 1417420 fix doesn't address Suitcase Fusion users?
dhnyny 0 தீர்வுகள் 15 பதில்கள்
பதிவிடப்பட்டது

I reported earlier today that 57.0.2 didn't seem to fix the problem I was having. But I just rebooted and now it seems the problem is gone. Yippee.

I reported earlier today that 57.0.2 didn't seem to fix the problem I was having. But I just rebooted and now it seems the problem is gone. Yippee.