Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Displays weird text

  • 9 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 221 views
  • Last reply by NuclearCommando

Whenever I try to access Facebook via Firefox on my laptop, the screen fills with jumbled, nonsensical text. I've provided an image of a portion of it. The problem is it only happens on my laptop's Firefox. Facebook works perfectly fine on my laptop's internet explorer and on my family computer's Firefox, yet does this on my laptop.

Sometimes, if I stay off of it for about 24+ hours, I can access it for about two minutes, before it immediately fails and jumps back to that wall of gibberish.

Also, it's ONLY Facebook. Every other website works perfectly fine.

I apologize if this question has been asked before, I don't know what a problem like this is called.

Thank you in advance!

Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

A possible workaround is to modify the involved pref and remove the trailing ", br"

  • network.http.accept-encoding.secure = "gzip, deflate, br" => "gzip, deflate" (without quotes)

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Read this answer in context 👍 1

All Replies (9)

re: the-edmeister Firefox 44+ accepts a new kind of encoding (compression) called Brotli for secure connections and Facebook turned on Brotli encoding last night. Kapsersky doesn't know about this encoding and strips it from the HTTP response headers if you have "Inject script" checked in Kapsersky Settings -> Additional -> Network -> Traffic Processing https://forum.kaspersky.com/index.php?s=bbdfcf797a91bc90230472c52c4b103e&showtopic=351027

Unless it was automatically installed without my knowledge, I don't have anything called Kaspersky security, only AVG.

Check and make sure. Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.


As a test, disable your protection programs.

I've searched my Program Files (x86), even doing a full search of it, and came across nothing.

I'm kinda skeptical of disabling my AVG as well... if I have to put my computer at risk just to access facebook, it's not really worth it

தீர்வு தேர்ந்தெடுக்கப்பட்டது

A possible workaround is to modify the involved pref and remove the trailing ", br"

  • network.http.accept-encoding.secure = "gzip, deflate, br" => "gzip, deflate" (without quotes)

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

So far, it's working, but I'm wanna give it 24 hours to be sure, since I could get it to run for brief periods by chance even before editing.

Are there any risks to editing out that ", br" though?

Normally not. This will only prevent a server to send files with Brotli compression that was added in the Firefox 44 release.

Hi NuclearCommando, the br refers to Botli compression, a more compact way to send data from websites to browsers which should speed up downloads by some microseconds. Turning off Brotli will just undo a very recent change by Facebook (that you haven't benefitted from due to the intermediary program messing up the headers).

Sorry it took so long, been terribly busy and everytime I got on here I instantly got called away. Your solution of removing the br worked, I've had no issues at all for a week! Thank you so much!