X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

I want to hide the icons in the bookmarks toolbar.

Pridané

In Version 29 of FireFox the "folder" or "link" icons of the bookmark toolbar are stuck VISIBLE.

I simply wish to hide/delete the icon, showing only the text as I had before. The icons are basically meaningless and I don't need them to be visible.

Please suggest the correct path for adjusting this.

Thx.

--Bry.

In Version 29 of FireFox the "folder" or "link" icons of the bookmark toolbar are stuck VISIBLE. I simply wish to hide/delete the icon, showing only the text as I had before. The icons are basically meaningless and I don't need them to be visible. Please suggest the correct path for adjusting this. Thx. --Bry.

Vybrané riešenie

You're welcome and glad to see that the code works for you.

Čítať túto odpoveď v kontexte 3

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • Shockwave Flash 12.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.

Aplikácie

  • Firefox 29.0
  • Identifikácia prehliadača: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
  • URL adresa podpory: https://support.mozilla.org/1/firefox/29.0/Darwin/en-US/

Rozšírenia

  • Adblock Plus 2.5.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Hide Tab Bar With One Tab 1.3 ({e5bbc237-c99b-4ced-a061-0be27703295f})
  • NoSquint 2.1.9 (nosquint@urandom.ca)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

JavaScript

  • incrementalGCEnabled: True

Grafika

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 6770M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Upravené nastavenia

  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow: 2
  • browser.places.smartBookmarksVersion: 6
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140318013849
  • browser.startup.homepage_override.buildID: 20140318013849
  • browser.startup.homepage_override.mstone: 29.0
  • browser.tabs.autoHide: True
  • browser.tabs.loadInBackground: False
  • browser.zoom.siteSpecific: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 29.0
  • font.internaluseonly.changed: False
  • font.language.group: x-western
  • mousewheel.withcontrolkey.action: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1395371663
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1394036394

Ostatné

  • User JS: Nie
  • Prístupnosť: Nie
amphioxus 0 riešení 2 odpovedí

Clearly Foul-up-Fox intended to let people turn off buttons in the 'Customize Screen.' At: https://support.mozilla.org/en-US/kb/how-to-make-new-firefox-look-like-old-firefox They include instructions and a screenshot for how to pick button style. It's under, "Use the customize screen..." It says: "Mode: Here you can choose to show text labels under the toolbar buttons or to have just text button (no icons)." The picture shows: "Buttons: Normal, Small" and "Mode: Icon, Icons + Text, Text. But this feature just isn't there. It's badly needed. And who wants to do all that text-edit garbage?

Clearly Foul-up-Fox intended to let people turn off buttons in the 'Customize Screen.' At: https://support.mozilla.org/en-US/kb/how-to-make-new-firefox-look-like-old-firefox They include instructions and a screenshot for how to pick button style. It's under, "Use the customize screen..." It says: "Mode: Here you can choose to show text labels under the toolbar buttons or to have just text button (no icons)." The picture shows: "Buttons: Normal, Small" and "Mode: Icon, Icons + Text, Text. But this feature just isn't there. It's badly needed. And who wants to do all that text-edit garbage?

Autor otázky

I did solve the problem with that awful "text-edit garbage". It did remove the useless folder icons, leaving my terse text, so I have a lot of places to keep my bookmarks.

Your solution sounds really good. Seems to me that it would be best on a new install of FireFox, where all other dabbling is removed. I have FireFox 30.0, btw, and Mavericks 10.9.2. While not an intrinsic part of a FireFox distribution (which it ought to be!!!), as an add-on, it should safely be able to make these changes.

I am going to hang with what I have so far, but I have marked the add-on for the future.

Thanks!

--B.

I did solve the problem with that awful "text-edit garbage". It did remove the useless folder icons, leaving my terse text, so I have a lot of places to keep my bookmarks. Your solution sounds really good. Seems to me that it would be best on a new install of FireFox, where all other dabbling is removed. I have FireFox 30.0, btw, and Mavericks 10.9.2. While not an intrinsic part of a FireFox distribution (which it ought to be!!!), as an add-on, it should safely be able to make these changes. I am going to hang with what I have so far, but I have marked the add-on for the future. Thanks! --B.
lsanders99 0 riešení 5 odpovedí

I have followed these instructions (Bry's and Cor-el's) to the letter and still have the icons in the bookmark toolbar. Anybody else have a proven solution or suggestions? Firefox 29.0.1

Thanks

Leigh

I have followed these instructions (Bry's and Cor-el's) to the letter and still have the icons in the bookmark toolbar. Anybody else have a proven solution or suggestions? Firefox 29.0.1 Thanks Leigh
Talvez 0 riešení 1 odpovedí

My solution was simple. Lacking the advanced technical skills to modify Firefox 29, I uninstalled 29 and installed Firefox 28. Problem solved.

For some reason, I was terribly annoyed at not being able to select text only for the bookmarks toolbar.

My solution was simple. Lacking the advanced technical skills to modify Firefox 29, I uninstalled 29 and installed Firefox 28. Problem solved. For some reason, I was terribly annoyed at not being able to select text only for the bookmarks toolbar.
lsanders99 0 riešení 5 odpovedí

Talvez,

That's what I did also. Mozilla must have anticipated this, because when you install 28 you must click an "Update" button to install it. That results in another "update" to 29. After I saw what happened, I went through the 28 install again and this time I interrupted the process, preventing the update. Now I have 28 back, no icons on the toolbar, and I changed my settings to prevent any more automatic updates to either Firefox or Thunderbird. Not all change is progress, Mozilla...

Talvez, That's what I did also. Mozilla must have anticipated this, because when you install 28 you must click an "Update" button to install it. That results in another "update" to 29. After I saw what happened, I went through the 28 install again and this time I interrupted the process, preventing the update. Now I have 28 back, no icons on the toolbar, and I changed my settings to prevent any more automatic updates to either Firefox or Thunderbird. Not all change is progress, Mozilla...
cor-el
  • Top 10 Contributor
  • Moderator
17876 riešení 161758 odpovedí
  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist.
  • Use a plain text editor like Notepad to create a (new) userChrome.css or userContent.css file in this folder (the names are case sensitive).
  • Paste the code in the userChrome.css or userContent.css file in the editor window and make sure that the userChrome.css file starts with the default @namespace line.
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.

Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt or userContent.css.txt file.
In case of problems you can check the file type in the Properties of the file via the right-click context menu.


You can use the Stylish extension to have easier access to the customization files.

* Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist. * Use a plain text editor like Notepad to create a (new) userChrome.css or userContent.css file in this folder (the names are case sensitive). * Paste the code in the userChrome.css or userContent.css file in the editor window and make sure that the userChrome.css file starts with the default @namespace line. * Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css. Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt or userContent.css.txt file.<br /> In case of problems you can check the file type in the Properties of the file via the right-click context menu. ----- You can use the Stylish extension to have easier access to the customization files. *Stylish: https://addons.mozilla.org/firefox/addon/stylish/
lsanders99 0 riešení 5 odpovedí

Thanks cor-el,

I'm reasonably sure I did this correctly. I tried to attach three screenshots, but they failed to attach for some reason (too big?). I do now have a chrome folder in my profile. It contains a folder called userChrome.css which contains the code I copied and pasted from your earlier reply. It still does not work.

Thanks cor-el, I'm reasonably sure I did this correctly. I tried to attach three screenshots, but they failed to attach for some reason (too big?). I do now have a chrome folder in my profile. It contains a folder called userChrome.css which contains the code I copied and pasted from your earlier reply. It still does not work.