Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Script appears to be not working on some sites

  • 9 odpovedí
  • 0 má tento problém
  • 11 zobrazení
  • Posledná odpoveď od cor-el

more options

Some of the scripts are not loading or working properly, like clicking boxes and notifications on some sites. Most recently this happened on the New Statesman website, I doubt they haven't optimized their site for Firefox. Previously I encountered this on Gerogetown University's Management System platform, which according to IT should be fine with Firefox. I removed all the extensions, cleared the cache and cookies, tried troubleshooting mode, even reinstalled Firefox to no avail. I accept all cookies. Settings are default. The issue is specific to Firefox, Edge works fine. Please help, I don't want to migrate back to Edge.

Some of the scripts are not loading or working properly, like clicking boxes and notifications on some sites. Most recently this happened on the New Statesman website, I doubt they haven't optimized their site for Firefox. Previously I encountered this on Gerogetown University's Management System platform, which according to IT should be fine with Firefox. I removed all the extensions, cleared the cache and cookies, tried troubleshooting mode, even reinstalled Firefox to no avail. I accept all cookies. Settings are default. The issue is specific to Firefox, Edge works fine. Please help, I don't want to migrate back to Edge.
Priložené obrázky

Vybrané riešenie

It seems to be a website issue, if you click the "Enter your email address" text box at the bottom, you get a popup list of the same three newsletter choices with working checkboxes.

The site is using -moz-appearance to hide the default checkboxes (so only Firefox is affected) but the custom appearance is only applied when in a popup.

Čítať túto odpoveď v kontexte 👍 2

Všetky odpovede (9)

more options

Steps to replicate the issue please. How about showing what it should look like in another browser.

more options

I found the page, but let me boot to windows and test. https://www.newstatesman.com/all-newsletters

more options

Thanks for taking a look. Here is a screenshot of the same page on Edge. You can see the check boxes. Good that you found the site, https://www.newstatesman.com/all-newsletters I also had the same issue on one of Georgetown's internal platforms (running on https://www.workday.com/) which I can't reproduce, right now it works, but I could not click on notifications and some other buttons.

more options

Make sure you haven't enabled High Contrast mode in the OS settings.

Make sure you allow pages to choose their own colors.

  • Settings -> General -> Language and Appearance -> Colors -> Manage Colors
    "Override the colors specified by the page with your selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Vybrané riešenie

It seems to be a website issue, if you click the "Enter your email address" text box at the bottom, you get a popup list of the same three newsletter choices with working checkboxes.

The site is using -moz-appearance to hide the default checkboxes (so only Firefox is affected) but the custom appearance is only applied when in a popup.

more options

Zero, Nice catch!!!

more options

Mark this non-issue as resolved and have a nice day.  ;-))

more options

Thanks, zeroknight, that's a weird choice for the website - checkboxes for each browswer except for Firefox. But they are there when I enter the email address.

more options

In the pop-up there are ::before and ::after rules to set the height and width of the checkbox. The checkboxes on the main side show height and width 0/0 and thus do not show. They work if I disable the appearance: initial; rule and set a width and height.