Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

How to stop search suggestions based on history?

  • 3 odpovede
  • 1 má tento problém
  • 15 zobrazení
  • Posledná odpoveď od billynoah

more options

In the screenshot I've provided you can plainly see that "Provide search suggestions" is unchecked, yes the browser continues to provide search suggestions based on my search history.

How to make this stop?

Firefox 78.5.0esr OS X 10.11.6

In the screenshot I've provided you can plainly see that "Provide search suggestions" is unchecked, yes the browser continues to provide search suggestions based on my search history. How to make this stop? Firefox 78.5.0esr OS X 10.11.6
Priložené obrázky

Vybrané riešenie

Hi, the clock icon indicates that you are seeing a suggestion from your search history. Search history and Form history are stored together, so in order to prevent Firefox from saving and show Search history, you also need to disable Form history. (Unless there is a secret solution I don't know about.)

To give it a try, see: Control whether Firefox automatically fills in forms ("Turn off Auto form fill and prevent Firefox from storing more form entries" section)

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (3)

more options

"yet the browser continues" ... not "yes the browser continues"

how stupid that I can't edit my question. can a mod please fix this?

more options

Vybrané riešenie

Hi, the clock icon indicates that you are seeing a suggestion from your search history. Search history and Form history are stored together, so in order to prevent Firefox from saving and show Search history, you also need to disable Form history. (Unless there is a secret solution I don't know about.)

To give it a try, see: Control whether Firefox automatically fills in forms ("Turn off Auto form fill and prevent Firefox from storing more form entries" section)

more options

Thanks for the solution. I'd say there's room for improvement here in the UI.