Unable to install add-ons (extensions or themes) in Thunderbird

Tento článok zatiaľ nikto nepreložil. Ak máte s prekladmi na SUMO skúsenosti, môžete ho teraz preložiť. Ak by ste sa chceli dozvedieť, ako sa články na SUMO prekladajú, začnite prosím tu.
Beginning with Thunderbird version 60, add-ons that have not been updated by their authors may stop working. Likewise, in Thunderbird beta version 63, add-ons that have not been updated for the beta by their authors may stop working.

An inability to install an extension can be the result of problems with the extension or the version of Thunderbird you are using. This article describes various causes of install problems and what you can do to address them.

Add-on is not compatible

A file in each add-on indicates the range of Thunderbird versions with which it is compatible. At Thunderbird Add-ons you can find and review the version compatibility information for each add-on. If your installed version of Thunderbird does not fit within the specified range, then installing the add-on or starting Thunderbird will fail or indicate the add-on is not compatible.

A published add-on is the responsibility of its respective add-on author. If an add-on does not work or is not compatible, you have these choices:

  • Update to the latest version of Thunderbird. For more information, see Updating Thunderbird.
  • Find a version of the add-on that is compatible with your version of Thunderbird. The Thunderbird Add-ons website usually has the most up to date version.
  • Use a different add-on. You can often find other add-ons with similar functionality at Thunderbird Add-ons.
  • Contact the author of the add-on at the support site listed on its add-on page. (Note: posting a review is not effective and will not reach the author.)

Lightning is missing or installation fails

If Lightning (the calendar add-on) is missing, failed to update or installation fails, see Calendar updates issues with Thunderbird.

Trouble installing Themes

Starting with beta version 61, Thunderbird supports only lightweight themes, and you can therefore no longer install "complete themes". Install themes to change the look of Thunderbird describes the purpose and installation process.

You are asked to download the add-on, rather than allowed to install it

Some websites serve add-ons as downloads, requiring you to download the file to your computer, before installing it.

  • These files are usually .xpi or .jar files.
  1. Download the file to your local computer.
  2. Click the menu button Fx57menu New Fx Menu and choose Add-ons. The Add-ons Manager tab will open.
  3. In the Add-ons Manager tab, select the Extensions panel.
  4. To add the downloaded add-on to the list of available add-ons, drag and drop the file into the Add-ons window. The add-on is added to the list.
  5. The installation process should begin.

An add-on will not work if incompatible.

Corrupt extension files

Corrupt extension configuration files can cause problems when trying to install an add-on. Deleting these files will make Thunderbird recreate them the next time it starts. You won't lose your extensions or their settings by deleting these files.

  1. Open your profile folder:
    • Click the menu button New Fx Menu fx57menu , click Help and select Troubleshooting Information.From the Help menu, choose Troubleshooting Information. The Troubleshooting Information tab will open.

      • Under the Application Basics section, click on Show FolderOpen FolderShow in FinderOpen Directory. A window will open that contains your profile folder.Your profile folder will open.
  2. Delete the following files:
    • extensions.sqlite
    • extensions.sqlite-journal (if found)
    • extensions.ini
    • extensions.json
  3. Restart Thunderbird.

Conflict with another add-on

An already installed add-on may interfere with the installation of a new one. Install the new extension in Thunderbird Safe Mode as a workaround.

Add-on has a high risk of causing stability or security problems and can't be installed

Certain add-ons have been blocklisted for being unsafe. For more information, see Add-ons that cause stability or security issues are put on a blocklist.



Based on information from

// Títo skvelí ľudia pomohli s písaním tohto článku: Tonnes, Michele Rodaro, Wayne Mery, Ryan Sipes, DJKing101. Vy môžete pomôcť tiež - prečítajte si ako.

Pomohol vám tento článok? Čakajte prosím...

Prispievateľ podpory Mozilla