Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

When composing emails, all address books are not searched

  • 8 ответов
  • 1 имеет эту проблему
  • 25 просмотров
  • Последний ответ от chris285

more options

This seems to have been broken in the recent flurry of 78.x releases.

I am currently using 78.2.2.

I have verified that "Personal Address Book" is searched but several others I have are not, even when selected as the defaults for the Global Composing Preferences (Default startup directory in the address book window is the only option really).

Overall impression of 78.x is pretty poor, for a long time it was locking up regularly during composition. Now it performs well, but doesn't search my long standing address books.

Thanks for any suggestions.

Выбранное решение

The repair is mentioned above: export to LDIF, delete the address book, import the LDIF. This works with the non-default address books, but for Personal Address Book and Collected Addresses, export to LDIF, close TB, open the profile folder, rename abook.sqlite and history.sqlite, restart TB, which will show empty PAB and CA, import the LDIF, drag contacts from the imported books back to PAB and CA.

I set up contact sync with Google Address Book using TbSync and Provider for CalDAV and CardDAV, and it seems to work.

Прочитайте этот ответ в контексте 👍 0

Все ответы (8)

more options

I have 'Local Address Books' checked in Options/Composition/Addressing, and address autocomplete finds entries in address books other than Personal Address Book. Does the contact that doesn't appear have the email address in the Email field in its Properties? Does it appear after it's moved to Personal Address Book?

Полезно?

more options

Thank you for the quick response.

- Yes, it shows up correctly when moved to the PAB. 
- Therefore, I think the core entry properties are correct. 

I wonder if it has something to do with the way the address books were imported long ago and some property is not set correctly.

Полезно?

more options

You could try exporting the address book to an LDIF file, deleting it from Address Book, then importing the LDIF, and see if that corrects the problem.

Полезно?

more options

I could try that, I have several AB's with thousands of entries (20 years worth of collection) which have not been well deduplicated by any of the tools, so that could be interesting.

Are there any of the config files that might be missing an entry that would trigger an AB to not be searched?

Thanks!

Полезно?

more options

I'm not aware of any preference that lists the address books for autocomplete; it's either all local books or none.

If an address book is corrupted, which is usually demonstrated by it not being able to delete or edit contacts, that could also make it not work with autocomplete. Try creating a new test address book, add a unique contacts, and see if it appears in autocomplete. That would at least indicate the search isn't restricted to Personal Address Book.

Полезно?

more options

I created a new AB and entry and auto-complete seemed to work.

What do you recommend to uncorrupt the address book? I've been trying to consolidate and sync w/ Google Contacts with mixed results.

Полезно?

more options

Выбранное решение

The repair is mentioned above: export to LDIF, delete the address book, import the LDIF. This works with the non-default address books, but for Personal Address Book and Collected Addresses, export to LDIF, close TB, open the profile folder, rename abook.sqlite and history.sqlite, restart TB, which will show empty PAB and CA, import the LDIF, drag contacts from the imported books back to PAB and CA.

I set up contact sync with Google Address Book using TbSync and Provider for CalDAV and CardDAV, and it seems to work.

Полезно?

more options

Thanks, export and import seems to have cleaned it all up. BR, Chris

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.