X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Times in Received, Sent, and Date Columns are all one hour off (behind)

Размещено

I recently upgraded my Dell XPS 8700 64-bit desktop computer from Windows 7 (where I used Windows Live Mail with POP3) to Windows 10, on which I installed Thunderbird 60.9.0 32-bit (with POP3), connected as before to AOL servers. In the e-mail panes, the times shown in the Received, Sent, and Date columns are all consistently incorrect (behind) by one hour, although the times displayed in the messages themselves are correct. My computer's time settings are correct:

(UTC-05:00) Eastern Time (US and Canada) Adjust for daylight saving time automatically: On

The "Official NIST US Time" website in effect confirms that my computer's time settings are correct, since its time agrees to the second to my computer's time.

Windows Live Mail remained on my computer after the upgrade to Windows 10, and I downloaded recent messages into it: the times are shown correctly for the very same messages for which the Thunderbird columns show incorrect times. This argues that the problem lies with Thunderbird itself, not with my computer or the servers.

Can anyone suggest what is causing this consistent one-hour error, and what the remedy might be?

I recently upgraded my Dell XPS 8700 64-bit desktop computer from Windows 7 (where I used Windows Live Mail with POP3) to Windows 10, on which I installed Thunderbird 60.9.0 32-bit (with POP3), connected as before to AOL servers. In the e-mail panes, the times shown in the Received, Sent, and Date columns are all consistently incorrect (behind) by one hour, although the times displayed in the messages themselves are correct. My computer's time settings are correct: (UTC-05:00) Eastern Time (US and Canada) Adjust for daylight saving time automatically: On The "Official NIST US Time" website in effect confirms that my computer's time settings are correct, since its time agrees to the second to my computer's time. Windows Live Mail remained on my computer after the upgrade to Windows 10, and I downloaded recent messages into it: the times are shown correctly for the very same messages for which the Thunderbird columns show incorrect times. This argues that the problem lies with Thunderbird itself, not with my computer or the servers. Can anyone suggest what is causing this consistent one-hour error, and what the remedy might be?

Выбранное решение

Just in case the Windows OS stores things in more than one place in registry. Let's check the old method via Control Panel.

Exit Thunderbird.

On computer 'Control Panel' > 'Date & Time' click on 'Change time Zone' select anything and then reselect: (UTC-05:00) Eastern Time (US and Canada) select checkbox for auto adjust clock for DST click on OK

Start thunderbird.

Прочитайте этот ответ в контексте 2
Цитата

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36

Дополнительная информация

Toad-Hall
  • Top 10 Contributor
1792 решений 12058 ответов
Размещено

I use DELL XPS 8930 Windows 10 64 bit OS I'm in UK I have Adjust for daylight saving time automatically: On So a similar situation.

Test: When I switch it off: Time is one hour less on computer bottom right of screen. 15:52 the time in the message header area shows one hour less : Date: Sat, 12 Oct 2019 15:52:07

compared to date/time shown in Message List. Date: Sat, 12 Oct 2019 16:52:07 But same as Date shown in the source of message which on this occasion does not allow for 1 hour BST. eg:Date: Sat, 12 Oct 2019 15:52:07 +0000

When I switch it on: Time is correct on computer bottom right of screen. 16:52 the time in the message header area shows same as compared to date/time shown in Message List. 12 Oct 2019 16:52:07 But one hour ahead of date/time in the source of message if source says Date: Sat, 12 Oct 2019 15:52:07 +0000 OR same if message source says: Date: Sat, 12 Oct 2019 16:52:07 +0100

Note I did have to exit and restart Thunderbird after making changes in Date/Time computer settings for Thunderbird to hook up to the changes.

Have you restarted Thunderbird?

Thunderbird takes it's time from the computer settings.

As you are seeing correct time in Message header and computer bottom right of screen, that part is ok. Message List seems to be thinking you are in a time zone one hour ahead and the daylight saving is not adding time but removing it.

What is your location?

I use DELL XPS 8930 Windows 10 64 bit OS I'm in UK I have Adjust for daylight saving time automatically: On So a similar situation. Test: When I switch it off: Time is one hour less on computer bottom right of screen. 15:52 the time in the message header area shows one hour less : Date: Sat, 12 Oct 2019 15:52:07 compared to date/time shown in Message List. Date: Sat, 12 Oct 2019 16:52:07 But same as Date shown in the source of message which on this occasion does not allow for 1 hour BST. eg:Date: Sat, 12 Oct 2019 15:52:07 +0000 When I switch it on: Time is correct on computer bottom right of screen. 16:52 the time in the message header area shows same as compared to date/time shown in Message List. 12 Oct 2019 16:52:07 But one hour ahead of date/time in the source of message if source says Date: Sat, 12 Oct 2019 15:52:07 +0000 OR same if message source says: Date: Sat, 12 Oct 2019 16:52:07 +0100 Note I did have to exit and restart Thunderbird after making changes in Date/Time computer settings for Thunderbird to hook up to the changes. Have you restarted Thunderbird? Thunderbird takes it's time from the computer settings. As you are seeing correct time in Message header and computer bottom right of screen, that part is ok. Message List seems to be thinking you are in a time zone one hour ahead and the daylight saving is not adding time but removing it. What is your location?
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1792 решений 12058 ответов
Размещено

EST (Eastern Standard Time) is one of the well-known names of UTC-5 time zone which is 5h. behind of UTC (Coordinated Universal Time).The time offset from UTC can be written as -05:00.

It's used during the winter. During the summer EDT - Eastern Daylight Time (UTC-4) is in use

So it would reduce the time by one hour. Hence why Computer in lower bottom right of screen is one hour less and so is time in Message Header.

This means your Message List is currently displaying as if Daylight saving is not selected.

Select email. In Message header area click on 'More' and select 'View Source' Ignore time at the top. Scroll down to section that says FROM, TO, DATE Please copy and paste the date into this forum question and label it as 'Source'. Then tell me the time in the 'Message List' Followed by time shown in 'Message Header'. Please label each clearly, so I know which time is shown where for the same email.

EST (Eastern Standard Time) is one of the well-known names of UTC-5 time zone which is 5h. behind of UTC (Coordinated Universal Time).The time offset from UTC can be written as -05:00. It's used during the winter. During the summer EDT - Eastern Daylight Time (UTC-4) is in use So it would reduce the time by one hour. Hence why Computer in lower bottom right of screen is one hour less and so is time in Message Header. This means your Message List is currently displaying as if Daylight saving is not selected. Select email. In Message header area click on 'More' and select 'View Source' Ignore time at the top. Scroll down to section that says FROM, TO, DATE Please copy and paste the date into this forum question and label it as 'Source'. Then tell me the time in the 'Message List' Followed by time shown in 'Message Header'. Please label each clearly, so I know which time is shown where for the same email.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Thank you so much for your two responses!

In answer to your questions:

My location is near New York City, and shares its time zone.

I have restarted Thunderbird (and also restarted the computer) many times since installing it some days ago, with no effect on the incorrectly displayed times in the Message Lists.

Requested information from a typical e-mail (I'm using the e-mail from no-reply@support.mozilla.org that corresponds to your second response):

Source: Date: Sat, 12 Oct 2019 16:49:14 +0000

Time displayed in Message List: 11:49 AM (in both the Received and Date columns)

Time displayed in Message Header (i.e., immediately below the "More" button): 12:49 PM

Just to be certain there is no misunderstanding:

The Official U.S. Time website (at https://www.time.gov/) recognizes my computer (correctly) as set for "Eastern Time (DST)." The time shown in the clock in the lower right corner of my Desktop has always been correct. :)

(I've been wondering whether a change in one of the multitudinous settings in "Config Editor..." might conceivably remedy this problem....)

Thank you so much for your two responses! In answer to your questions: My location is near New York City, and shares its time zone. I have restarted Thunderbird (and also restarted the computer) many times since installing it some days ago, with no effect on the incorrectly displayed times in the Message Lists. Requested information from a typical e-mail (I'm using the e-mail from no-reply@support.mozilla.org that corresponds to your second response): Source: Date: Sat, 12 Oct 2019 16:49:14 +0000 Time displayed in Message List: 11:49 AM (in both the Received and Date columns) Time displayed in Message Header (i.e., immediately below the "More" button): 12:49 PM Just to be certain there is no misunderstanding: The Official U.S. Time website (at https://www.time.gov/) recognizes my computer (correctly) as set for "Eastern Time (DST)." The time shown in the clock in the lower right corner of my Desktop has always been correct. :) (I've been wondering whether a change in one of the multitudinous settings in "Config Editor..." might conceivably remedy this problem....)
Помогла ли вам это?
Цитата
Matt
  • Top 10 Contributor
  • Moderator
3275 решений 22575 ответов
Размещено

Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is most likely an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the one causing the issue

Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is most likely an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the one causing the issue
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Matt, thanks for your excellent suggestion. I restarted Thunderbird in Safe Mode (and confirmed that it was in effect) and sent myself a message, but unfortunately the problem remained, unchanged--a one hour difference between the time in the Message List and the time in the Message Header.

Matt, thanks for your excellent suggestion. I restarted Thunderbird in Safe Mode (and confirmed that it was in effect) and sent myself a message, but unfortunately the problem remained, unchanged--a one hour difference between the time in the Message List and the time in the Message Header.
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1642 решений 7886 ответов
Размещено
Maybe this add-on will display the correct received time: https://addons.thunderbird.net/en-US/thunderbird/addon/imap-received-date/ https://support.mozilla.org/en-US/questions/1158818
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1792 решений 12058 ответов
Размещено

Could you do a test, I recall coming across a similar situation before where the computer auto setting for time zone was set to ON and it seemed to effect results. Mine is switched off.

Exit Thunderbird. In computer 'Date & Time settings' 1. Set the time automatically - ON 2. Set the time zone automatically - OFF 3. Time Zone - (UTC-05:00) Eastern Time (US and Canada) 4. Adjust for daylight saving time automatically - ON

Start Thunderbird. Report back on results.

Could you do a test, I recall coming across a similar situation before where the computer auto setting for time zone was set to ON and it seemed to effect results. Mine is switched off. Exit Thunderbird. In computer 'Date & Time settings' 1. Set the time automatically - ON 2. Set the time zone automatically - '''OFF''' 3. Time Zone - (UTC-05:00) Eastern Time (US and Canada) 4. Adjust for daylight saving time automatically - ON Start Thunderbird. Report back on results.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

sfhowes said

Maybe this add-on will display the correct received time: https://addons.thunderbird.net/en-US/thunderbird/addon/imap-received-date/ https://support.mozilla.org/en-US/questions/1158818

Thanks very much for the suggestion. (I'd noticed this add-on previously, but passed over it because I'm using POP3, not IMAP.) I tried it, installing version 2.0.1, which corresponds to my version of Thunderbird. I confirmed the installation. Then restarted computer, opened Thunderbird, and sent myself a test message. Unfortunately, this didn't fix the problem--the times displayed in the Sent folder's Date column and the Inbox folder's Received and Date columns are all one hour off (behind), as before.

''sfhowes [[#answer-1258569|said]]'' <blockquote> Maybe this add-on will display the correct received time: https://addons.thunderbird.net/en-US/thunderbird/addon/imap-received-date/ https://support.mozilla.org/en-US/questions/1158818 </blockquote> Thanks very much for the suggestion. (I'd noticed this add-on previously, but passed over it because I'm using POP3, not IMAP.) I tried it, installing version 2.0.1, which corresponds to my version of Thunderbird. I confirmed the installation. Then restarted computer, opened Thunderbird, and sent myself a test message. Unfortunately, this didn't fix the problem--the times displayed in the Sent folder's Date column and the Inbox folder's Received and Date columns are all one hour off (behind), as before.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Toad-Hall said

Could you do a test, I recall coming across a similar situation before where the computer auto setting for time zone was set to ON and it seemed to effect results. Mine is switched off. Exit Thunderbird. In computer 'Date & Time settings' 1. Set the time automatically - ON 2. Set the time zone automatically - OFF 3. Time Zone - (UTC-05:00) Eastern Time (US and Canada) 4. Adjust for daylight saving time automatically - ON Start Thunderbird. Report back on results.

Thanks for your suggestion. However, "Set time zone automatically" has already been "Off" ever since I recently upgraded to Windows 10, so that all of my Date & Time settings have always corresponded precisely to the four settings you recommend above.

''Toad-Hall [[#answer-1258671|said]]'' <blockquote> Could you do a test, I recall coming across a similar situation before where the computer auto setting for time zone was set to ON and it seemed to effect results. Mine is switched off. Exit Thunderbird. In computer 'Date & Time settings' 1. Set the time automatically - ON 2. Set the time zone automatically - '''OFF''' 3. Time Zone - (UTC-05:00) Eastern Time (US and Canada) 4. Adjust for daylight saving time automatically - ON Start Thunderbird. Report back on results. </blockquote> Thanks for your suggestion. However, "Set time zone automatically" has already been "Off" ever since I recently upgraded to Windows 10, so that all of my Date & Time settings have always corresponded precisely to the four settings you recommend above.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1792 решений 12058 ответов
Размещено

Please try this and report back on results: In thunderbird On far right of column headers, there is an icon you can use to select which column headers you want to display. Click on that icon and from the drop down selection click on 'Restore column order' or it might be called 'Rest columns to default' depending upon what version of Thunderbird you are using.

Please try this and report back on results: In thunderbird On far right of column headers, there is an icon you can use to select which column headers you want to display. Click on that icon and from the drop down selection click on 'Restore column order' or it might be called 'Rest columns to default' depending upon what version of Thunderbird you are using.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1792 решений 12058 ответов
Размещено

If you enable the 'Recieved' column header, is there a difference in the date/time ? Is 'Received' time correct or still showing 1hour wrong?

If you enable the 'Recieved' column header, is there a difference in the date/time ? Is 'Received' time correct or still showing 1hour wrong?
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1792 решений 12058 ответов
Размещено

Test if index needs resetting:

  • Right click on folder and select 'Properties'
  • click on 'Repair Folder'
  • click on OK

Refresh view by selecting another folder and selecting 'repaired' folder.

Test if index needs resetting: * Right click on folder and select 'Properties' * click on 'Repair Folder' * click on OK Refresh view by selecting another folder and selecting 'repaired' folder.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1792 решений 12058 ответов
Размещено

Please run this test and post results: Menu icon > Tools > Developer Tools > Error Console

clear console by clicking on the bin icon top left.

Copy the following: Date() paste into the error console next to >> press enter on keyboard. Note the results, copy and paste results into this forum

Copy the following: (new Date).toUTCString() paste into the error console next to >> press enter on keyboard. Note the results, copy and paste results into this forum

Please run this test and post results: Menu icon > Tools > Developer Tools > Error Console clear console by clicking on the bin icon top left. Copy the following: '''Date()''' paste into the error console next to >> press enter on keyboard. Note the results, copy and paste results into this forum Copy the following: '''(new Date).toUTCString()''' paste into the error console next to >> press enter on keyboard. Note the results, copy and paste results into this forum
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Toad-Hall, I appreciate your continued attention to my problem--thank you!  :)

Below, respectively numbered (1), (2), and (3), are the results of the three procedures you requested in your four latest posts (alas, the problem remains uncorrected). Items (4) and (5) describe some additional observations I have made, just in case they might conceivably provide any new clues.

(1) In the Inbox message pane, I selected "Reset columns to default," enabled the "Received" column, restarted Thunderbird, and sent myself a message. Result: The "Received" column still showed a 1-hour error in the time (as did the Date column).

(2) I repaired the Inbox folder as directed (repair took just an instant, and no informational message of any kind was displayed), restarted Thunderbird, and sent myself a message. Result: The Received and Date columns still showed a 1-hour error in the time.

(3) I went to Tools > Developer Tools > Error Console, clicked on the garbage bin to clear the console (although it was already empty), pasted the character string Date() into the console next to the >> characters, and pressed Enter key. Result:

Date() "Thu Oct 17 2019 02:44:03 GMT-0400 (Eastern Daylight Time)"

[I can confirm that 2:44AM was the correct local time.]

After clearing the Error Console, I then similarly pasted the character string (new Date).toUTCString() into the console next to the >> characters, and pressed Enter key. Result:

(new Date).toUTCString() "Thu, 17 Oct 2019 06:51:40 GMT"

(4) New observation: I have noticed that in the Sent folder, if I was *replying* to a message--which is accordingly quoted beneath my own text--the time displayed in that quoted message is incorrect, being one hour too early (its time is therefore identical to the incorrect times shown for it in the Received and Date columns of the Inbox's message list, even though within that message itself in the Inbox, the time in its header *is* correct).

In contrast, messages quoted beneath the text of *Inbox* messages *do* show their correct times.

(5) New Observation: All my previous comments in this Forum have pertained to messages in my currently active account, created at the time I installed Thunderbird. However, in addition to messages in the Inbox and Sent folders of this new account, I also have messages that, before creating my currently active account, had been imported (using the ImportExportTools add-on) from Windows Live Mail into several *Local Folders*. I see that the same 1-hour error in displayed time is present in the message lists of the Inbox and Sent folders in the "Local Folders" hierarchy, despite the fact that these messages were never received or sent using Thunderbird.

Toad-Hall, I appreciate your continued attention to my problem--thank you! :) Below, respectively numbered (1), (2), and (3), are the results of the three procedures you requested in your four latest posts (alas, the problem remains uncorrected). Items (4) and (5) describe some additional observations I have made, just in case they might conceivably provide any new clues. (1) In the Inbox message pane, I selected "Reset columns to default," enabled the "Received" column, restarted Thunderbird, and sent myself a message. Result: The "Received" column still showed a 1-hour error in the time (as did the Date column). (2) I repaired the Inbox folder as directed (repair took just an instant, and no informational message of any kind was displayed), restarted Thunderbird, and sent myself a message. Result: The Received and Date columns still showed a 1-hour error in the time. (3) I went to Tools > Developer Tools > Error Console, clicked on the garbage bin to clear the console (although it was already empty), pasted the character string Date() into the console next to the >> characters, and pressed Enter key. Result: Date() "Thu Oct 17 2019 02:44:03 GMT-0400 (Eastern Daylight Time)" [I can confirm that 2:44AM was the correct local time.] After clearing the Error Console, I then similarly pasted the character string (new Date).toUTCString() into the console next to the >> characters, and pressed Enter key. Result: (new Date).toUTCString() "Thu, 17 Oct 2019 06:51:40 GMT" (4) New observation: I have noticed that in the Sent folder, if I was *replying* to a message--which is accordingly quoted beneath my own text--the time displayed in that quoted message is incorrect, being one hour too early (its time is therefore identical to the incorrect times shown for it in the Received and Date columns of the Inbox's message list, even though within that message itself in the Inbox, the time in its header *is* correct). In contrast, messages quoted beneath the text of *Inbox* messages *do* show their correct times. (5) New Observation: All my previous comments in this Forum have pertained to messages in my currently active account, created at the time I installed Thunderbird. However, in addition to messages in the Inbox and Sent folders of this new account, I also have messages that, before creating my currently active account, had been imported (using the ImportExportTools add-on) from Windows Live Mail into several *Local Folders*. I see that the same 1-hour error in displayed time is present in the message lists of the Inbox and Sent folders in the "Local Folders" hierarchy, despite the fact that these messages were never received or sent using Thunderbird.

Изменено Mitch

Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

ADDENDUM:

I have an additional observation to add to those described in items (4) and (5) of my previous post: I'll number it consecutively, as (6):

(6) While creating a new message as a "Reply" to an earlier message, the date shown for the quoted earlier message is incorrect (1 hour early)--i.e., this error is present even before the new message has actually been sent. Once the new message has been sent, the error in the date of the quoted earlier message remains in the copy present in the Sent folder.

ADDENDUM: I have an additional observation to add to those described in items (4) and (5) of my previous post: I'll number it consecutively, as (6): (6) While creating a new message as a "Reply" to an earlier message, the date shown for the quoted earlier message is incorrect (1 hour early)--i.e., this error is present even before the new message has actually been sent. Once the new message has been sent, the error in the date of the quoted earlier message remains in the copy present in the Sent folder.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1792 решений 12058 ответов
Размещено

The date info collected via error console is correct.

Something has changed since the Windows OS update, so let's see if there is an older reference still lurking in some profile files.

Menu icon > Tools > click on 'Clear recent history'

In Thunderbird

  • Help > Troubleshooting Information
  • Click on 'Open folder' button

a new window opens showing the contents of your 'profile name' folder.

  • Exit Thunderbird now.

In profile name folder delete the following files.

  • global-messages-db.sqlite
  • panacea.dat
  • session.json
  • Click on 'Mail' folder
  • If you see a 'smart mailboxes' folder - delete it.

Start Thunderbird.

The date info collected via error console is correct. Something has changed since the Windows OS update, so let's see if there is an older reference still lurking in some profile files. Menu icon > Tools > click on 'Clear recent history' In Thunderbird * Help > Troubleshooting Information * Click on 'Open folder' button a new window opens showing the contents of your 'profile name' folder. * Exit Thunderbird now. In profile name folder delete the following files. * global-messages-db.sqlite * panacea.dat * session.json * Click on 'Mail' folder * If you see a 'smart mailboxes' folder - delete it. Start Thunderbird.
Помогла ли вам это?
Цитата
Matt
  • Top 10 Contributor
  • Moderator
3275 решений 22575 ответов
Размещено

Drive by comment.

Are you using a VPN, perhaps with your internet security suite?

Drive by comment. Are you using a VPN, perhaps with your internet security suite?
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

No, Matt, I'm not using a VPN, but thanks for the drive-by thought.  :)

No, Matt, I'm not using a VPN, but thanks for the drive-by thought. :)
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Toad-Hall said

The date info collected via error console is correct. Something has changed since the Windows OS update, so let's see if there is an older reference still lurking in some profile files. Menu icon > Tools > click on 'Clear recent history' In Thunderbird
  • Help > Troubleshooting Information
  • Click on 'Open folder' button
a new window opens showing the contents of your 'profile name' folder.
  • Exit Thunderbird now.
In profile name folder delete the following files.
  • global-messages-db.sqlite
  • panacea.dat
  • session.json
  • Click on 'Mail' folder
  • If you see a 'smart mailboxes' folder - delete it.
Start Thunderbird.

Toad-Hall said

The date info collected via error console is correct. Something has changed since the Windows OS update, so let's see if there is an older reference still lurking in some profile files. Menu icon > Tools > click on 'Clear recent history' In Thunderbird
  • Help > Troubleshooting Information
  • Click on 'Open folder' button
a new window opens showing the contents of your 'profile name' folder.
  • Exit Thunderbird now.
In profile name folder delete the following files.
  • global-messages-db.sqlite
  • panacea.dat
  • session.json
  • Click on 'Mail' folder
  • If you see a 'smart mailboxes' folder - delete it.
Start Thunderbird.

Toad-Hall, I have carefully followed your directions, but neither procedure solved the problem.

First, in going to Tools > Clear Recent History, under Time range to clear, I selected "Everything," and under Details, kept the default check marks next to Browsing History, Cookies, and Cache. Then closed and reopened Thunderbird, and sent myself a test message. Result: In the Inbox message list's Received and Date columns, the displayed time was still one hour early.

Second, after displaying my Thunderbird profile and closing Thunderbird, I deleted:

global-messages-db.sqlite panacea.dat session.json

I then opened the Mail folder. It contained only these three subfolders: Feeds, Local Folders, and pop.verizon.net. I saw no "smart mailboxes" folder either in the parent Mail folder or one level down in any of those three subfolders. I then started Thunderbird and sent myself a test message. Result: In the Inbox message list's Received and Date columns, the displayed time was still one hour early.

''Toad-Hall [[#answer-1259598|said]]'' <blockquote> The date info collected via error console is correct. Something has changed since the Windows OS update, so let's see if there is an older reference still lurking in some profile files. Menu icon > Tools > click on 'Clear recent history' In Thunderbird * Help > Troubleshooting Information * Click on 'Open folder' button a new window opens showing the contents of your 'profile name' folder. * Exit Thunderbird now. In profile name folder delete the following files. * global-messages-db.sqlite * panacea.dat * session.json * Click on 'Mail' folder * If you see a 'smart mailboxes' folder - delete it. Start Thunderbird. </blockquote> ''Toad-Hall [[#answer-1259598|said]]'' <blockquote> The date info collected via error console is correct. Something has changed since the Windows OS update, so let's see if there is an older reference still lurking in some profile files. Menu icon > Tools > click on 'Clear recent history' In Thunderbird * Help > Troubleshooting Information * Click on 'Open folder' button a new window opens showing the contents of your 'profile name' folder. * Exit Thunderbird now. In profile name folder delete the following files. * global-messages-db.sqlite * panacea.dat * session.json * Click on 'Mail' folder * If you see a 'smart mailboxes' folder - delete it. Start Thunderbird. </blockquote> Toad-Hall, I have carefully followed your directions, but neither procedure solved the problem. First, in going to Tools > Clear Recent History, under Time range to clear, I selected "Everything," and under Details, kept the default check marks next to Browsing History, Cookies, and Cache. Then closed and reopened Thunderbird, and sent myself a test message. Result: In the Inbox message list's Received and Date columns, the displayed time was still one hour early. Second, after displaying my Thunderbird profile and closing Thunderbird, I deleted: global-messages-db.sqlite panacea.dat session.json I then opened the Mail folder. It contained only these three subfolders: Feeds, Local Folders, and pop.verizon.net. I saw no "smart mailboxes" folder either in the parent Mail folder or one level down in any of those three subfolders. I then started Thunderbird and sent myself a test message. Result: In the Inbox message list's Received and Date columns, the displayed time was still one hour early.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1792 решений 12058 ответов
Размещено

Выбранное решение

Just in case the Windows OS stores things in more than one place in registry. Let's check the old method via Control Panel.

Exit Thunderbird.

On computer 'Control Panel' > 'Date & Time' click on 'Change time Zone' select anything and then reselect: (UTC-05:00) Eastern Time (US and Canada) select checkbox for auto adjust clock for DST click on OK

Start thunderbird.

Just in case the Windows OS stores things in more than one place in registry. Let's check the old method via Control Panel. Exit Thunderbird. On computer 'Control Panel' > 'Date & Time' click on 'Change time Zone' select anything and then reselect: (UTC-05:00) Eastern Time (US and Canada) select checkbox for auto adjust clock for DST click on OK Start thunderbird.
Помогла ли вам это? 2
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.