Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Why won't JavaScript work?

  • 10 ответов
  • 7 имеют эту проблему
  • 673 просмотра
  • Последний ответ от Happy112

more options

I am running Firefox 54.0.1 on a Mac Pro tower with OS X 10.10.5. Why doesn't JavaScript show up? Here's an example: http://www3.vectorworks.net/webinar_3DSiteModeling?utm_campaign=newslettertraining&utm_source=button&utm_medium=email&utm_content=3dsitemodeling082417#li=MA1-fb9693d08a61a16c&cs=MA1-57b6a4e0bb882c5433bb4f8a4031cf1b As you can see, the screen is blank where the form should be. I looked at your support forums and tried the config business. The log shows that JavaScript is enabled and "True." Now what? Thanks.

Выбранное решение

"Firefox will: Never remember history" sets automatic private browsing. Cookies are retained as long as at least one window is open in your session, then dumped when you close the last window. However, you might still not be allowing third party cookies. If you change to "Firefox will: Use custom settings for history" can you change that setting or is it grayed?

Прочитайте этот ответ в контексте 👍 2

Все ответы (10)

more options

Hi   !

Do you by any chance have an extension installed, like NoScript or Ghostery  ?

If so : would you disable it and see if that will make a difference   ?

If that's not it : If you have security software installed : try and disable it and see if that will do the trick.

more options

Also:

If you are using a Private Window for that page, do you see the shield icon toward the left end of the address bar? That icon indicates that the Tracking Protection feature is being applied, and in my test, that will block the form from appearing. More info: What happened to Tracking Protection?.

more options

Thanks to both of you for responding so quickly. Nope, I don't have NoScript or Ghostery installed. I do have Webroot Secure Anywhere installed. I disabled it and restarted my Mac, but still no luck. As for Private Window -- I'm not using that, either. I've used Firefox for years. This started an upgrade or two ago. Any other ideas?

more options

In order for the form to appear, it seems both that files from both of the following servers must be allowed. Can you load these files using their direct links?

http://c.cdnma.com/apps/capture.js

http://dlut3lsiqvb0g.cloudfront.net/apps/assets/form.js

If not, do you get a specific error message?

more options

When I click on each of the files, I see many, many lines of code. The first file starts with: var $__MA = (function () { var MA = { d: document, dt: new Date(), and ends with: if (typeof(w.MAdoWistia)==u||w.MAdoWistia){$__MA.attachWistiaVideos()} if (typeof(w.MAdoYouTube)==u||w.MAdoYouTube){$__MA.checkForYouTubeVideos()} if (typeof(w.MAdoVimeo)==u||w.MAdoVimeo){$__MA.checkForVimeoVideos()} } })(); The second file starts with: (function() { function g(a){var b=typeof a;if("object"==b)if(a){if(a instanceof Array)return"array";if(a instanceof Object)return b;var c=Object.prototype.toString.call(a);if("[object Window]"==c)return"object"; and ends with: }

var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(e, s); } There's no error message with either of the files.

more options

Hmm, they load directly, but either they don't load or don't run within the context of the other page. Strange.

Do you recall ever making any changes to how Firefox handles "third party" cookies or other privacy-related settings?

more options

In the Privacy pane... Tracking - I've checked "Use Tracking Protection in Private Windows." History - I've selected "Never remember history." (Maybe that's it? With the never remember, it appears that there's no option to do anything with cookies. In previous versions, I seem to remember that dealing with cookies was an option separate from whether the browser history was retained.) for Location Bar, I have nothing checked.

more options

Выбранное решение

"Firefox will: Never remember history" sets automatic private browsing. Cookies are retained as long as at least one window is open in your session, then dumped when you close the last window. However, you might still not be allowing third party cookies. If you change to "Firefox will: Use custom settings for history" can you change that setting or is it grayed?

more options

Yay! That's it! I changed History to "Use custom settings for history" and the form showed up. Thanks so much for your persistence in helping me solve this!

more options

Glad your problem is solved   !

Would you be a dear and mark jscher2000's last post as  'Chosen Solution'   ? That way others, with the same problem, will know and might benefit from it.

Thank you in advance   !