X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

i have an issue with the search bar features

Размещено

so the search bar changed recently and it's crap.. basically, it pops up way more information than needed as i'm typing in my search, and if my mouse happened to move over a random button when i hit "enter" it searches a different engine or goes to "change search settings".. these buttons do not need to be engaged with the enter button, it's really annoying.. in the screenshot picture i took it removed my cursor but you'll notice that "change search settings" is highlighted, if i were to press enter it wouldn't search, it would open settings

so the search bar changed recently and it's crap.. basically, it pops up way more information than needed as i'm typing in my search, and if my mouse happened to move over a random button when i hit "enter" it searches a different engine or goes to "change search settings".. these buttons do not need to be engaged with the enter button, it's really annoying.. in the screenshot picture i took it removed my cursor but you'll notice that "change search settings" is highlighted, if i were to press enter it wouldn't search, it would open settings

Выбранное решение

If you want to revert changes made to the search bar and have the standalone window to manage search engines then you can toggle this pref to false with a middle-click on the about:config page.

  • browser.search.showOneOffButtons = false

Close and restart Firefox to make the change effective.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Прочитайте этот ответ в контексте 4

Дополнительные сведения о системе

Установленные плагины

  • Adobe PDF Plug-In For Firefox and Netscape 15.7.20033
  • Shockwave Flash 17.0 r0

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

Дополнительная информация

cor-el
  • Top 10 Contributor
  • Moderator
17482 решений 157978 ответов
Размещено

Выбранное решение

If you want to revert changes made to the search bar and have the standalone window to manage search engines then you can toggle this pref to false with a middle-click on the about:config page.

  • browser.search.showOneOffButtons = false

Close and restart Firefox to make the change effective.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

If you want to revert changes made to the search bar and have the standalone window to manage search engines then you can toggle this pref to false with a middle-click on the <b>about:config</b> page. *<b>browser.search.showOneOffButtons</b> = false Close and restart Firefox to make the change effective. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Изменено cor-el