Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor. wants javascript enabled but it already is

  • 6 răspunsuri
  • 1 are această problemă
  • 50 de vizualizări
  • Ultimul răspuns de cor-el

more options

Trying to request a demo from It complains javascript is not enabled. ("Please enable javascript and try again" about:config shows javascript.enabled = true.

What I've tried: 1. Disabled all addons / extensions 1 by 1 until they were all disabled. 2. Turned off tracking protection 3. Turned off content blocking. 4. Set all group policies to "not configured" (Had only disabled off telemetry and update any way). 5. Set network settings to "no proxy". 6. Cleared cache 7. Removed all cookies. 8. Reset all permissions (location, camera, notifications etc).

If I restart with add ons disabled it works fine, yet I'd disabled all add ons. The only preferences I had disabled were related to telemetry (in about:config).

Toate răspunsurile (6)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

What Firefox version do you have since your user agent shows rv:78.3, but Firefox/73.0

  • Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:78.3) Gecko/20100101 Firefox/73.0


more options

Sorry, this website doesn't allow me to edit my original post and I've found that if I reply to my own posts, I tend not to get many if any other replies.

So had to wait for someone else to reply.

ok, so I had also created a new profile from scratch and uninstalled and reinstalled Firefox. I also tried a couple of different versions.

When I did my testing I disabled the add ons one by one and that process is flawed. Disable add on one.. problem solved? No, re-enable, then disable add on 2.. repeat for all add ons.

I eventually found a solution. If I use 68.12ESR I can fix it. On 78.5ESR I still cannot get it to work, and 78.5 won't load my intranet home page either.

Even though content blocking was enabled there was no shield on the top left. To get it to work I had to unblock the site in Disconnect, refresh the page then the shield showed, then turn off blocking for this site. The site doesn't work for me if tracking cookies are blocked.

What threw me is the error message was misleading, saying that Javascript was not enabled, so I spent hours trying to solve that and it was a wild goose chase.

This was not on my PC - It was on my sons PC.

In the original post I said "I restarted with add ons disabled" which is safe mode, so yes, I had already tried that, and as I said in the OP, it works in that situation.

I really should be getting all the PCs here up to date on v78.5, but at present, it won't load my intranet homepage so until I can figure out what is causing that, we're stuck on 68.12

Modificat în de TanyaC

more options

Note that you can find "Edit this question" under the Question Tools menu in the sidebar. For a reply it is in the three dot menu next to a reply.

If you have content blocking extensions then they take prevalence over Firefox Enhanced Tracking Protection, so you won't see the shield. Only if you disable these extensions then Firefox ETP can get active and shows the highlighted shield.

more options

Sorry, the three dots only allows me to quote the original post, not to edit it. I didn't see the edit in top right corner.

Anyway, yes, I've now learned that the add ons take precedence over the internal FF options in this scenario.

Modificat în de TanyaC

more options

You should have a sidebar with the Questions Tools item. If the window is below a specific width then this menu appears at the top of the page. If you expand the question tools menu then you find edit this question.