Nowości w Thunderbirdzie 60

Na tej stronie opisano główne zmiany widoczne dla użytkowników w programie Thunderbird w wersji 60.0. Szczegółowe informacje na temat wszystkich zmian można znaleźć w informacjach o wydaniu Thunderbirda 60.

Niektóre dodatki mogą nie działać

Ze względu na znaczące zmiany wprowadzone do Thunderbirda, wersja 60 nie załaduje automatycznie dodatku, o ile nie zostanie oznaczony jako zgodny przez autora. Do tej pory ponad 130 dodatków zostało dostosowanych przez ich autorów, a kolejne są dodawane co tydzień. Jeśli twój dodatek nie jest zgodny, skontaktuj się z autorem na jego stronie pomocy lub w wiadomości e-mail, które można znaleźć na stronie dodatków.

(Decyzja o wyłączeniu automatycznej zgodności nie była łatwa, ale wygoda użytkowania jest większa, ponieważ niedziałające dodatki nie mają możliwości zawieszenia Thunderbirda. Aby pomóc autorom w aktualizacji dodatków, w Thunderbirdzie wprowadzono znaczące usprawnienia planowania i kodu, aby ograniczyć wpływ zmian odziedziczonych po Firefoksie.)

Nowa lokalizacja menu opcji dodatku

Opcje dodatków nie są już zarządzane z poziomu karty Menedżer dodatków. Nowy element menu "Opcje dodatku" jest dostępny w menu Narzędzia.

MainMenuBarOptions

Lub jeśli korzystasz z menu aplikacji na pasku narzędzi, najeżdżanie kursorem na pozycję dodatku lub klikanie > spowoduje wyświetlenie dodatków z opcjami do ustawienia.

AppmenuShowingADDOnOptions

Zmiany w ustawieniach daty i czasu

Thunderbird ma teraz opcję określenia, czy formaty daty i godziny używane w programie powinny być zgodne z systemem operacyjnym, czy też z ustawieniami lokalnymi zainstalowanej wersji Thunderbirda. Innymi słowy, angielski Thunderbird może używać na przykład polskich formatów.

  1. Na górze okna Thunderbirda kliknij menu Narzędzia (można użyć skrótu Alt+N) i wybierz Opcje Na pasku menu kliknij Thunderbird i wybierz Preferencje…Na górze okna Thunderbirda kliknij menu Edycja i wybierz Preferencje lub kliknij przycisk menu New Fx Menu fx57menu i wybierz OpcjePreferencje.
    Thunderbird Menu Options
  2. Wybierz panel Zaawansowane, a następnie kartę Ogólne.
  3. W sekcji Format daty i czasu wybierz Język programu lub Język ustawień regionalnych.
  4. Kliknij OK by zamknąć okno Opcji.Kliknij Zamknij by zamknąć okno Preferencji.Zamknij okno Preferencji.

Date and Time

Zmiany w oknie tworzenia wiadomości

Podczas pisania wiadomości przycisk usuwania umożliwia teraz usunięcie odbiorcy

Po najechaniu myszą na etykiety adresowe (Odpowiedź do, Do, Kopia, Kopia ukryta, Grupa dyskusyjna) jest teraz wyświetlany przycisk X, aby umożliwić usunięcie tego wpisu.

Demonstration of the delete button

Wiele ulepszeń w obsłudze załączników podczas tworzenia wiadomości

Załączniki można teraz porządkować za pomocą okna dialogowego, skrótów klawiaturowych lub przeciągania i upuszczania. Przycisk "Dołącz" przesunął się w prawo, aby znaleźć się nad panelem załącznika. Klucz dostępu do panelu załącznika (np. Alt + M, może się różnić w zależności od lokalizacji, Ctrl + M na komputerze Mac) teraz działa również w celu wyświetlenia lub ukrycia panelu. Okienko załącznika można również pokazać początkowo podczas tworzenia nowej wiadomości. Kliknij nagłówek prawym przyciskiem myszy, aby włączyć tę opcję. Ukrywanie niepustego panelu załącznika będzie teraz pokazywać zastępczy spinacz do papieru, wskazujący obecność załączników i unikanie ich przypadkowego wysłania.

AttachmentReordering

Podczas wprowadzania adresu pasująca część adresu jest teraz pogrubiona

Aby wyjaśnić, dlaczego dany adres został umieszczony na liście automatycznego uzupełniania, część adresu zgodna z tekstem wpisanym jest teraz pogrubiona. Ustawienie preferencji mail.autoComplete.commentColumn na 1 pozwala wyświetlić książkę adresową, w której zapisany jest adres.

Książka adresowa

Teraz można ustawić domyślną książkę adresową, która zostanie wybrana po otwarciu książek adresowych. Aby ustawić książkę domyślną, kliknij ją prawym przyciskiem myszy i wybierz Domyślnie uruchamiany katalog z wyświetlonego menu.

Set Default address book Windows

Motywy statyczne

Motywy statyczne wykorzystujące technologię WebExtensions API są teraz obsługiwane [1]. Są one porównywalne do lekkich motywów. Pełne motywy i lekkie motywy są nadal obsługiwane. (Dodatki oparte na interfejsach API rozszerzeń przeglądarki WebExtensions i interfejsach API specyficznych dla poczty są planowane w przyszłym wydaniu Thunderbirda 60.)

[1] https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/Themes/Theme_concepts

Kalendarz

Możliwość wpisania lokalizacji zdarzeń

Zdarzenia kalendarza będą teraz pokazywać lokalizację, a także nazwę wydarzenia. Calendar:Location Display

Opcja kontrolująca to znajduje się na karcie Kalendarz > Widoki. Location of Display location option

Kopiowanie, wycinanie i wklejanie powtarzających się zdarzeń i zadań

Tak jak poprzednio dla usuwania lub modyfikacji, teraz pojawia się monit o wybór, czy zastosować kopiowanie lub wycinanie tylko do wybranego zdarzenia, czy też całej serii powtarzającego się wydarzenia lub zadania.

Lightning Copy Occurrence Prompt

Jeśli dostępnych jest więcej niż jeden kalendarz lokalny lub subskrypcja kalendarza, docelowy kalendarz do wklejania pozycji kalendarza może być teraz wybrany bezpośrednio z listy wszystkich zapisywalnych kalendarzy.

Lightning Paste Target Selection

Możliwość wysyłania / nie wysyłania powiadomień o spotkaniach bezpośrednio

Podczas obsługi spotkań, oprócz operacji przeciągania i upuszczania, nie ma już okien dialogowych z pytaniem, czy powiadomić pozostałych uczestników o swoich zmianach. Zamiast tego jest to kontrolowane bezpośrednio w odpowiednich oknach dialogowych lub menu kontekstowych.

Wraz z tą zmianą usunięto obsługę tworzenia zaproszeń e-mail zgodnych z programem Outlook 2002.

Możliwość wymuszenia korzystania z e-maili z zaproszeniami na spotkania dla użytkowników kalendarzy CalDAV

Niektóre serwery CalDAV są skonfigurowane tak, aby zająć się zapraszaniem innych użytkowników na tym samym serwerze kalendarza podczas konfigurowania spotkania. Zapobiegnie to wysyłaniu zaproszeń e-mail do innych uczestników z Thunderbirda podczas konfigurowania spotkania. W przypadku tych kalendarzy korzystanie z zaproszeń e-mailowych może być teraz egzekwowane bez względu na konfigurację serwera.

Przypomnienia można odrzucić nawet dla kalendarza tylko do odczytu

Jeśli pojawi się przypomnienie o wydarzeniu lub zadaniu zapisanym w kalendarzu tylko do odczytu, można je teraz odrzucić. W przeciwieństwie do zapisywalnych kalendarzy, odroczenie przypomnień wciąż nie jest możliwe dla tych pozycji kalendarza.

Lightning Reminder Dialog RO

Wraz z tą zmianą zakres opcji wyświetlania pominiętych przypomnień został ograniczony do zapisywalnych kalendarzy.

Show Missed Reminders Options

Eksperymentalna funkcja Maildir

Konwersja folderów z mbox na format maildir i odwrotnie

Zgodnie z długofalowym celem wdrożenia w Thunderbirdzie takiego systemu pamięci masowej jak maildir, narzędzia do konwersji istniejących folderów do formatu maildir są zawarte w tej wersji. Więcej informacji na temat implementacji maildir można znaleźć tutaj. Każdy, kto używa maildir musi mieć świadomość, że jest to nadal funkcja eksperymentalna, a jej użycie może ujawnić nieznane błędy, które powodują utratę danych.

Koniec wsparcia systemów Windows XP i Vista

Jednocześnie z wycofaniem wsparcia dla systemu Windows XP i Vista w przeglądarce Firefox 60, Thunderbird nie obsługuje już tych dwóch starszych systemów operacyjnych. Thunderbird 52 to ostatnia wersja Thunderbirda dostępna dla tych dwóch systemów operacyjnych.

// Osoby, które pomogły w tworzeniu tego artykułu:TyDraniu. Ty też możesz pomóc — dowiedz się jak.

Czy ten artykuł okazał się pomocny? Proszę czekać…

Zostań wolontariuszem Mozilla Support