Często zadawane pytania - Modernizacja technologii dodatków Firefoksa

Przestarzałe rozszerzenia

Rozszerzenia stworzone za pomocą technologii niezgodnych z programem Firefox w wersji 57 i późniejszych (takich jak SDK lub XUL) są określane jako “przestarzałe”.

Jak mogę zidentyfikować zainstalowane przestarzałe rozszerzenia?

Aby sprawdzić, czy masz zainstalowane jakieś niekompatybilne rozszerzenia dla programu Firefox, przejdź do menedżera dodatków. Kliknij przycisk menu Fx57Menu i wybierz Dodatki lub wpisz about:addons w pasku adresu. Jeżeli masz przestarzałe rozszerzenie, będzie ono na liście w panelu Rozszerzenia jako Wyłączone bez dostępnej opcji włączenia w menu z trzema kropkami.

Fx68Addons-OldLegacyNowDisabled

Jak mogę zidentyfikować zainstalowane przestarzałe rozszerzenia?

Aby sprawdzić, czy masz zainstalowane jakieś niekompatybilne rozszerzenia dla programu Firefox, przejdź do menedżera dodatków. Kliknij przycisk menu Fx57Menu i wybierz Dodatki lub wpisz about:addons w pasku adresu. Dla przestarzałych rozszerzeń zobaczysz u góry ekranu następujący komunikat:

Legacy extension warning

Kliknij odnośnik "Wyświetl przestarzałe rozszerzenia" aby zobaczyć listę zainstalowanych przestarzałych rozszerzeń. Kliknij opcję "Znajdź zamiennik" obok każdego przestarzałego rozszerzenia, by wyświetlić rekomendowane alternatywy. Więcej o tej funkcji możesz przeczytać na oficjalnym blogu.

Jeśli widoczna jest etykieta "przestarzałe", czy oznacza to że rozszerzenie nie działa?

Tak, rozszerzenia oznaczone jako "przestarzałe" nie są kompatybilne z programem Firefox w wersji 57 i nowszych. W niektórych przypadkach ich twórcy będą musieli wprowadzić zmiany w ich kodzie aby ich rozszerzenia były kompatybilne. W takim przypadku, poprawione rozszerzenie zostanie automatycznie zaktualizowane po opublikowaniu jego wersji zgodnej z nową wersją programu Firefox.

Czy dostępne są zamienniki dla starszych rozszerzeń?

Tak! Przejdź do menedżera dodatków (kliknij przycisk menu Fx57Menu i wybierz Dodatki lub wpisz about:addons w pasku adresu) i wybierz Przestarzałe rozszerzenia. Kliknij "Znajdź zamiennik" obok każdego przestarzałego rozszerzenia, by sprawdzić rekomendowane alternatywy. Więcej o tej funkcji możesz przeczytać na oficjalnym blogu.

Zalecamy znalezienie kompatybilnych rozszerzeń za pomocą strony addons.mozilla.org (AMO) lub przejrzenie kolekcji polecanych rozszerzeń.

Możesz również skorzystać z narzędzia do wyszukiwania rozszerzeń by znaleźć rozszerzenie, które chcesz zastąpić i odkryć istniejące i działające alternatywy.

Brak zamienników dla jednego z moich ulubionych starszych rozszerzeń. I co teraz?

Jeżeli brak pasującego zamiennika, odwiedź nasze forum by spytać społeczność o dodatkowe sugestie.

Kiedy wersja ESR przestała obsługiwać przestarzałe rozszerzenia?

Firefox Extended Support Release (ESR) wersja 52 to ostatnia wersja programu Firefox obsługująca przestarzałe rozszerzenia. Wersja ESR 52 nie jest już aktywnie wspierana od 5 września 2018.

W październiku 2018 wszystkie przestarzałe dodatki w serwisie addons.mozilla.org (AMO) zostały usunięte i nie można ich pobrać.

Jeśli chcesz używać przestarzałych wersji programu Firefox by móc korzystać z przestarzałych dodatków, narażasz się na bycie ofiarą złośliwego oprogramowania wykorzystującego luki bezpieczeństwa. Zdecydowanie odradzamy korzystanie z przestarzałych wersji jakiegokolwiek oprogramowania.

Co się stało z używanym przez mnie kompletnym motywem?

Kompletne motywy nie działają począwszy od wersji 57 programu Firefox. Jeżeli korzystasz z ciemnego motywu, opcja Ciemny Motyw w menedżerze dodatków może być dobrą alternatywą. Przejdź do panelu Motywy na stronie about:addons i wypróbuj jak działa. Wkrótce udostępnimy więcej możliwości dla twórców motywów, więc wypatruj motywów z dodatkową funkcjonalnością (poza alternatywną szatą graficzną) w przyszłych wersjach programu Firefox.

Co się stało z dodatkiem zarządzającym wtyczką formatu Flash?

Począwszy od wersji 55 programu Firefox, Adobe Flash nie jest domyślnie uruchamiany, a kliknięcie w celu uruchomienia formatu Flash jest wbudowane w przeglądarkę. Możesz określić sposób działania formatu Flash na określonych witrynach lub na wszystkich otwieranych stronach.

Niektóre z najpopularniejszych rozszerzeń formatu Flash udostępniały tę funkcję, zanim stała się częścią przeglądarki. Ponieważ te rozszerzenia są w tym momencie przestarzałe, prawdopodobnie nie będą one już dalej rozwijane przez twórców i przestaną poprawnie działać.

W niektórych przypadkach oferujemy API WebExtension dla dodatkowych opcji formatu Flash (takich jak usuwanie Flash LSO) i spodziewamy się, że dodatki będą wykorzystywać więcej możliwości Flasha z biegiem czasu. W międzyczasie oczekujemy na współpracę w poszukiwaniu możliwości odtworzenia dotychczasowo wykorzystywanych funkcjonalności formatu Flash.

// Osoby, które pomogły w tworzeniu tego artykułu:TyDraniu, vesper. Ty też możesz pomóc — dowiedz się jak.

Czy ten artykuł okazał się pomocny? Proszę czekać…

Zostań wolontariuszem Mozilla Support