X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

How to make google default search engine in address bar.

Geplaatst

How do I make it so that when I search with my address bar it ALWAYS uses Google, regardless of what search engine is selected in the search bar? It used to be like this, but a recent Firefox update altered it. Now, when I search with my address bar it uses the search engine selected in the search bar...if I wanted to do that, I would just use the search bar! Any suggestions?

How do I make it so that when I search with my address bar it ALWAYS uses Google, regardless of what search engine is selected in the search bar? It used to be like this, but a recent Firefox update altered it. Now, when I search with my address bar it uses the search engine selected in the search bar...if I wanted to do that, I would just use the search bar! Any suggestions?

Gekozen oplossing

see: https://addons.mozilla.org/en-US/firefox/addon/keywordurl-hack/

It was removed from firefox because search hijackers could "lock aka require lots of things to be done to remove it" the search preference.

Dit antwoord in context lezen 70

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Version 4.4.2.14502
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 11.7 r700
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.20513.0

Toepassing

  • Firefox 23.0.1
  • Useragent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0
  • Ondersteunings-URL: http://support.mozilla.org/1/firefox/23.0.1/Darwin/en-US/

Extensies

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • All-in-One Gestures 0.26 ({8b86149f-01fb-4842-9dd8-4d7eb02fd055})
  • All-in-One Sidebar 0.7.20 ({097d3191-e6fa-4728-9826-b533d755359d})
  • AutoPager 0.8.0.8 (autopager@mozilla.org)
  • Cleanest Addon Manager 7.0 (cam@sdrocking.com)
  • Clearly 9.3369.854.431 (readable@evernote.com)
  • Click&Clean 4.1 (clickclean@hotcleaner.com)
  • Desktop 1.4.11 (desktop@telega.phpnet.us)
  • Disconnect 2.0.0 (2.0@disconnect.me)
  • DoNotTrackMe 2.2.9.618 (donottrackplus@abine.com)
  • FastestFox 5.1.9 (smarterwiki@wikiatic.com)
  • FEBE 7.3.0.1 ({4BBDD651-70CF-4821-84F8-2B918CF89CA3})
  • feedly 16.0.528 (feedly@devhd)
  • FlashGot 1.5.5.5 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Ghostery 5.0.0 (firefox@ghostery.com)
  • Greasemonkey 1.11 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • HTTPS-Everywhere 3.3.1 (https-everywhere@eff.org)
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • Priv3 0.2 (priv3@icsi.berkeley.edu)
  • QuickWiki 1.1.3 ({EE223D7A-F30F-11DD-8F0A-D2AD55D89593})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Zotero 4.0.12 (zotero@chnm.gmu.edu)

Javascript

  • incrementalGCEnabled: True

Grafisch

  • adapterDescription:
  • adapterDeviceID: 0x 166
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • windowLayerManagerType: OpenGL

Aangepaste voorkeuren

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 0
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.newtab.url: chrome://desktop/content/desktop.html
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.search.useDBForOrder: True
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage: https://accounts.google.com/ServiceLogin?service=mail&passive=true&rm=false&continue=https://mail.google.com/mail/&ss=1&scc=1&ltmpl=default&ltmplcache=2|https://www.facebook.com/|http://mlb.mlb.com/home|http://www.feedly.com/home#latest|http://www.cnn.com/|https://webmail.illinois.edu/CookieAuth.dll?GetLogon?curl=Z2FowaZ2F&reason=0&formdir=1|http://www.cracked.com/|http://www.pitchforkmedia.com
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • browser.urlbar.autocomplete.enabled: False
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • general.autoScroll: False
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1376681229
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1376439594

Div

  • User JS: nee
  • Toegankelijkheid: nee
kobe 441 oplossingen 5048 antwoorden

Gekozen oplossing

see: https://addons.mozilla.org/en-US/firefox/addon/keywordurl-hack/

It was removed from firefox because search hijackers could "lock aka require lots of things to be done to remove it" the search preference.

see: https://addons.mozilla.org/en-US/firefox/addon/keywordurl-hack/ It was removed from firefox because search hijackers could "lock aka require lots of things to be done to remove it" the search preference.

Vraageigenaar

Amazing, thank you!

Amazing, thank you!
mschubb 0 oplossingen 6 antwoorden

Understand, but I never had that problem. And now I no longer have an extremely useful function that I typically use dozens of times a day and have been using for many years.

Isn't there anyway to work around this? I need to the main address bar to search google (or some other default I select) and the search bar set to a different, but changeable search engine.

Understand, but I never had that problem. And now I no longer have '''an extremely useful function''' that I typically use dozens of times a day and have been using for many years. Isn't there anyway to work around this? I need to the main address bar to search google (or some other default I select) and the search bar set to a different, but changeable search engine.
BaneFalcon 0 oplossingen 1 antwoorden

Nuttig antwoord

I'm also having this same problem... it's the first thing that Firefox has ever done that's made me contemplate getting a different browser. The "update" seems like a step back, and a removal of a very good feature. I'm in the same boat of wondering if there's any work-arounds or add-ons to restore the old usage, even if it comes at the risk of having my address bar's search engine occasionally hijacked.

I'm also having this same problem... it's the first thing that Firefox has ever done that's made me contemplate getting a different browser. The "update" seems like a step back, and a removal of a very good feature. I'm in the same boat of wondering if there's any work-arounds or add-ons to restore the old usage, even if it comes at the risk of having my address bar's search engine occasionally hijacked.

Nuttig antwoord

So I used the add-on, but there were some problems. My solution was to:

1. Type the following into your address bar: about:config

2. Say you understand about the "voiding of the warranty"

3. Search for the string "keyword.URL" (now I'm trying to remember if that string already existed or not...if it doesn't show up for you, right-click and go to New, and then select String...name it "keyword.URL").

4. Set the value to: https://www.google.com/#safe=active&output=search&sclient=psy-ab&q=

This should fix it.

So I used the add-on, but there were some problems. My solution was to: 1. Type the following into your address bar: about:config 2. Say you understand about the "voiding of the warranty" 3. Search for the string "keyword.URL" (now I'm trying to remember if that string already existed or not...if it doesn't show up for you, right-click and go to New, and then select String...name it "keyword.URL"). 4. Set the value to: https://www.google.com/#safe=active&output=search&sclient=psy-ab&q= This should fix it.
kobe 441 oplossingen 5048 antwoorden

keyword.URL is not in fx 23 +

keyword.URL is not in fx 23 +
cor-el
  • Top 10 Contributor
  • Moderator
17539 oplossingen 158588 antwoorden

Starting with Firefox 23 the keyword.URL pref is no longer supported and it is no longer possible to specify the search engine for the location bar that way.
The search engine that is used on the location bar and on the about:home page is the search engine that is selected in the search Bar on the Navigation Toolbar.
You can install the Keyword Search extension to specify with search engine to use for the location bar and which search engine to use for the about:home page via the Options/Preferences windows of this extension, accessible via the about:addons page.

Starting with Firefox 23 the keyword.URL pref is no longer supported and it is no longer possible to specify the search engine for the location bar that way.<br /> The search engine that is used on the location bar and on the about:home page is the search engine that is selected in the search Bar on the Navigation Toolbar.<br /> You can install the Keyword Search extension to specify with search engine to use for the location bar and which search engine to use for the about:home page via the Options/Preferences windows of this extension, accessible via the about:addons page. * Keyword Search: https://addons.mozilla.org/firefox/addon/keyword-search/
ecg3500 0 oplossingen 1 antwoorden
    • FIX**

This makes keywords typed into URL bar always perform a Google search instead of what the addon search bar has currently selected.

type about:config into URL bar click "I'll be careful I promise" search for "keyword.URL" right click >modify >(change to) "https://www.google.com/#q="

DONE!

**FIX** This makes keywords typed into URL bar always perform a Google search instead of what the addon search bar has currently selected. type about:config into URL bar click "I'll be careful I promise" search for "keyword.URL" right click >modify >(change to) "https://www.google.com/#q=" DONE!
kobe 441 oplossingen 5048 antwoorden

Ecg3500, keyword.url requires a addon to work as stated by cor-el.

Ecg3500, keyword.url requires a addon to work as stated by cor-el.
Sh. Niew 0 oplossingen 1 antwoorden

for the latest Firefox, I would prefer Combine Your Firefox Search Bar and Address Bar . just make the toolbar clean...

for the latest Firefox, I would prefer [https://blog.mozilla.org/theden/2013/04/17/combine-your-firefox-search-bar-and-address-bar/ Combine Your Firefox Search Bar and Address Bar] . just make the toolbar clean...
lalilulelo 0 oplossingen 1 antwoorden

1. go to about:config

2. look for browser.search.defaultenginename

3. Change its value to "Google" without the quotation marks.

It should look like this

browser.search.defaultenginename default string Google

5. You're welcome.

1. go to about:config 2. look for browser.search.defaultenginename 3. Change its value to "Google" without the quotation marks. It should look like this browser.search.defaultenginename default string Google 5. You're welcome.