Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Missing Bookmark Icons

  • 9 antwoorden
  • 1 heeft dit probleem
  • 6 weergaven
  • Laatste antwoord van Buster

more options

Strangely some of the icons for my bookmarks have gone missing. They are all present on each tab but missing on the drop down list. I have tried finding the places.sqlite file in my profiles folder but it doesn't seem to exist. I am running v.84.0.2 (64 bit). Has anyone any idea why the icons are missing from one list and not missing from the tabs, I would have thought they would all be stored in the same place and come from the same 'pool' of data? Attached screenshots of tabs showing the icon and the drop down list with generic wireframe globe icon. Any help would be much appreciated.

Gekoppelde schermafbeeldingen

Alle antwoorden (9)

more options

4 days and absolutely no replies, helpful or otherwise. Great support.

Behulpzaam?

more options

As far as I can see icons are present in the dropdown list. As in my lists, some sites just don't seem to provide icons with bookmarks.

Behulpzaam?

more options

Hi Buster, bookmark icons are not always stored. In particular:

(1) If the bookmarked URL redirects immediately to a different URL, the icon is not stored.

You can tell because when you land on the page, the star icon in the address bar is no longer blue. To fix these, you need to update the URL, or bookmark the page again with the new address and delete the old bookmark.

(2) If the site instructs Firefox not to cache the icon.

This is more of a rare situation, but users have raised the example of Walmart. I created an extension that can selective override the "do not cache" instruction for sites you choose, if you want to take a look:

https://addons.mozilla.org/firefox/addon/cache-favicons-for-bookmarks/

Behulpzaam?

more options

By the way, site icons for bookmarks and history are stored in a different file, favicons.sqlite, and not in places.sqlite. If one of these databases is damaged, you often cannot save any new bookmarks. If you are running into that problem, run the "Verify Integrity" function to diagnose and try to repair the databases. That's here:

Open Firefox's Troubleshooting Information page using any of these methods:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Near the bottom, there is a section titled Places Database -- that's the file which stores history and bookmarks. Click the button labeled Verify Integrity. There may be a 10-15 second delay before results appear.

If all is well, the report that appears below the button should start with:

> Task: checkIntegrity
+ The places.sqlite database is sane
+ The favicons.sqlite database is sane

Does yours say that, or something else? You can select and copy the report, and then paste it into a reply for review and comment.

Behulpzaam?

more options

Many thanks for your reply jscher2000. I tried your first suggestion and added the extension which has not made any difference, the icon appears on the tab but not in the drop down list. I have verified the integrity of the database and can confirm that my report matches the example you stated. This is a copy of the report: > Task: checkIntegrity + The places.sqlite database is sane + The favicons.sqlite database is sane > Task: invalidateCaches + The caches have been invalidated > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: originFrecencyStats + Recalculated origin frecency stats > Task: vacuum + Initial database size is 10240KiB + The database has been vacuumed + Final database size is 10240KiB > Task: stats + Places.sqlite size is 10240KiB + Favicons.sqlite size is 5120KiB + pragma_user_version is 54 + pragma_page_size is 32768 + pragma_cache_size is -2048 + pragma_journal_mode is wal + pragma_synchronous is 1 + History can store a maximum of 107437 unique pages + Table moz_origins has 1467 records + Table moz_places has 10393 records + Table moz_historyvisits has 28302 records + Table moz_inputhistory has 19 records + Table moz_bookmarks has 493 records + Table moz_bookmarks_deleted has 0 records + Table moz_keywords has 0 records + Table sqlite_sequence has 1 records + Table moz_anno_attributes has 3 records + Table moz_annos has 325 records + Table moz_items_annos has 0 records + Table moz_meta has 8 records + Table sqlite_stat1 has 17 records + Index sqlite_autoindex_moz_origins_1 + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index moz_places_url_hashindex + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_places_originidindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_bookmarks_dateaddedindex + Index moz_places_guid_uniqueindex + Index moz_bookmarks_guid_uniqueindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex > Task: _refreshUI Just a reminder that the icon appears on the tab but not on the drop down list. When I click on the folder on my bookmarks toolbar the drop down list shows the bookmark icon I require as a wireframe globe, when I click on this bookmark it opens a new tab which has the correct icon attached. I am sorry my original post was not clear on this point but the attached screenshot shows the problem.

Behulpzaam?

more options

Hi Buster, when you use that bookmark and the page loads, is the star in the address bar filled in with blue color?

If not, see my #1 point earlier.

If yes, did you already try clicking the extension button next to the star to cache the favicon?

Behulpzaam?

more options

Hi jscher2000, When I load the page the star in the address bar is filled red. I have deleted the bookmark, typed the web address in the address bar manually and then bookmarked the page. When I load from this new bookmark the star is filled red. Thanks for your help with this, it's very much appreciated. I have attached another screenshot to illustrate after deletion and re-bookmarking to show the red star and I have also moved the folders to try and illustrate the appearance of the icon on the tab but missing from the drop-down.

Behulpzaam?

more options

Thanks, when I test with that site, I can't tell what is going wrong.

Firefox's Network Monitor (Ctrl+Shift+E) shows that it first tries to retrieve

https://www.two-sixties.co.uk/favicon.ico

but this fails (not the correct location). Then later it pulls from the address listed in the page

https://www.two-sixties.co.uk/mgoc260/html/favicon.ico

but I guess that one doesn't get saved. ??

You could file a bug:

https://bugzilla.mozilla.org/

Behulpzaam?

more options

Many thanks jscher2000, looks like that may be the only way to go. I realised my reference to red star is because I am not using the default theme so that was a mistake on my part but it doesn't alter the fact that it's still not behaving itself! Much appreciate your suggestions. Regards.

Behulpzaam?

Een vraag stellen

U moet zich aanmelden bij uw account om op berichten te antwoorden. Stel een nieuwe vraag als u nog geen account hebt.