X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

What happened to the address bar in update 65? It's awful. It use to only show my bookmarks or websites I physically typed in. Now it shows everything but that.

Geplaatst

What happened to the address bar in update 65? It's awful. It use to only show my most visited bookmarks(ie:facebook) or websites I physically typed in. Now it shows everything but that. It makes it super cluttered and overall awful. I have tried messing with the settings and nothing works. I feel like I need to downgrade and disable automatic updates or move to a new explorer all together.

What happened to the address bar in update 65? It's awful. It use to only show my most visited bookmarks(ie:facebook) or websites I physically typed in. Now it shows everything but that. It makes it super cluttered and overall awful. I have tried messing with the settings and nothing works. I feel like I need to downgrade and disable automatic updates or move to a new explorer all together.
Pj 42 oplossingen 869 antwoorden

ReneeMustang said

What happened to the address bar in update 65?


What are your Options settings?


~Pj

''ReneeMustang [[#question-1248272|said]]'' <blockquote> What happened to the address bar in update 65? </blockquote> What are your Options settings? ~Pj

Vraageigenaar

Pictured are my current settings. I have played with them before and had them all off. One on at a time, etc. Nothing worked for me.

Pictured are my current settings. I have played with them before and had them all off. One on at a time, etc. Nothing worked for me.

Vraageigenaar

Pj said

ReneeMustang said
What happened to the address bar in update 65?


What are your Options settings?


~Pj

Pj said

ReneeMustang said
What happened to the address bar in update 65?


What are your Options settings?


~Pj

Pictured are my current settings. I have played with them before and had them all off. One on at a time, etc. Nothing worked for me.

''Pj [[#answer-1192667|said]]'' <blockquote> ''ReneeMustang [[#question-1248272|said]]'' <blockquote> What happened to the address bar in update 65? </blockquote> What are your Options settings? ~Pj </blockquote> ''Pj [[#answer-1192667|said]]'' <blockquote> ''ReneeMustang [[#question-1248272|said]]'' <blockquote> What happened to the address bar in update 65? </blockquote> What are your Options settings? ~Pj </blockquote> Pictured are my current settings. I have played with them before and had them all off. One on at a time, etc. Nothing worked for me.
ShadowAD 0 oplossingen 2 antwoorden

Same here, it's now showing pages I went to from my web history, and I'm either not interested in them anymore, or only needed to visit them once. All I needed is my favourites like Email, Facebook and Ebay etc that I typed in manually and if I did type in another address I could highlight it with the down arrow and delete it, and it wouldn't show again. Until they change it back the way it was it's version 64.0b12 for me and no more updates. It's something I've always liked with this browser, and I'm sure it's not a big deal to change it back the way it was please.

Same here, it's now showing pages I went to from my web history, and I'm either not interested in them anymore, or only needed to visit them once. All I needed is my favourites like Email, Facebook and Ebay etc that I typed in manually and if I did type in another address I could highlight it with the down arrow and delete it, and it wouldn't show again. Until they change it back the way it was it's version 64.0b12 for me and no more updates. It's something I've always liked with this browser, and I'm sure it's not a big deal to change it back the way it was please.
Pj 42 oplossingen 869 antwoorden

ReneeMustang said

What happened to the address bar in update 65?

ReneeMustang said

Pictured are my current settings. I have played with them before and had them all off. One on at a time, etc. Nothing worked for me.

It's working for me (with FF 65). Your setting shows you don't have the 'suggestions' check-boxed. I do, and it's working for me. Try it again.


~Pj

''ReneeMustang [[#question-1248272|said]]'' <blockquote> What happened to the address bar in update 65? </blockquote> ''ReneeMustang [[#question-1248275|said]]'' <blockquote> Pictured are my current settings. I have played with them before and had them all off. One on at a time, etc. Nothing worked for me. </blockquote> It's working for me (with FF 65). Your setting shows you don't have the 'suggestions' check-boxed. I do, and it's working for me. Try it again. ~Pj

Vraageigenaar

Pj said

ReneeMustang said
What happened to the address bar in update 65?

ReneeMustang said

Pictured are my current settings. I have played with them before and had them all off. One on at a time, etc. Nothing worked for me.

It's working for me (with FF 65). Your setting shows you don't have the 'suggestions' check-boxed. I do, and it's working for me. Try it again.


~Pj

I tried that and it's not doing as I am expecting. Pictured is my address bar with that setting. What I am expecting to only see is facebook and gaiaonline. Nothing else there. I never typed anything else into the bar in this session. I simply went to my bookmarks and clicked on the bookmark for facebook and gaiaonline. Yet, I see all these other websites (some of which popped up into the bar simply by loading up firefox and/or going to my bookmark).

''Pj [[#answer-1194264|said]]'' <blockquote> ''ReneeMustang [[#question-1248272|said]]'' <blockquote> What happened to the address bar in update 65? </blockquote> ''ReneeMustang [[#question-1248275|said]]'' <blockquote> Pictured are my current settings. I have played with them before and had them all off. One on at a time, etc. Nothing worked for me. </blockquote> It's working for me (with FF 65). Your setting shows you don't have the 'suggestions' check-boxed. I do, and it's working for me. Try it again. ~Pj </blockquote> I tried that and it's not doing as I am expecting. Pictured is my address bar with that setting. What I am expecting to only see is facebook and gaiaonline. Nothing else there. I never typed anything else into the bar in this session. I simply went to my bookmarks and clicked on the bookmark for facebook and gaiaonline. Yet, I see all these other websites (some of which popped up into the bar simply by loading up firefox and/or going to my bookmark).

Vraageigenaar

ShadowAD said

Same here, it's now showing pages I went to from my web history, and I'm either not interested in them anymore, or only needed to visit them once. All I needed is my favourites like Email, Facebook and Ebay etc that I typed in manually and if I did type in another address I could highlight it with the down arrow and delete it, and it wouldn't show again. Until they change it back the way it was it's version 64.0b12 for me and no more updates. It's something I've always liked with this browser, and I'm sure it's not a big deal to change it back the way it was please.

I've tried highlighting and deleting the sites that popped up in my history(that showed up for no apparently reason) and as soon as I delete them and reopen the address bar, they're back. I'm about to do as you and downgrade and turn off automatic updates. I would love for them to change it back to how it was as well...

''ShadowAD [[#answer-1194195|said]]'' <blockquote> Same here, it's now showing pages I went to from my web history, and I'm either not interested in them anymore, or only needed to visit them once. All I needed is my favourites like Email, Facebook and Ebay etc that I typed in manually and if I did type in another address I could highlight it with the down arrow and delete it, and it wouldn't show again. Until they change it back the way it was it's version 64.0b12 for me and no more updates. It's something I've always liked with this browser, and I'm sure it's not a big deal to change it back the way it was please. </blockquote> I've tried highlighting and deleting the sites that popped up in my history(that showed up for no apparently reason) and as soon as I delete them and reopen the address bar, they're back. I'm about to do as you and downgrade and turn off automatic updates. I would love for them to change it back to how it was as well...
Pj 42 oplossingen 869 antwoorden

How about the 'Add Search Bar' setting and un-check these other settings? (See attached images)


~Pj

How about the ''''Add Search Bar'''' setting and un-check these other settings? (See attached images) ~Pj

Bewerkt door Pj op

Vraageigenaar

Pj said

How about the 'Add Search Bar' setting and un-check these other settings? (See attached images) ~Pj

Still no luck.

''Pj [[#answer-1196227|said]]'' <blockquote> How about the ''''Add Search Bar'''' setting and un-check these other settings? (See attached images) ~Pj </blockquote> Still no luck.
cor-el
  • Top 10 Contributor
  • Moderator
17526 oplossingen 158472 antwoorden

You can set keyword.enabled to false on the about:config page to disable searching via the address bar. You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page.

  • browser.urlbar.oneOffSearches = false

You can use code in userChrome.css remove all suggestions from the address bar drop down list.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

You can set <b>keyword.enabled</b> to false on the <b>about:config</b> page to disable searching via the address bar. You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page. * browser.urlbar.oneOffSearches = false You can use code in userChrome.css remove all suggestions from the address bar drop down list. Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* remove all items from the urlbar drop down */ #PopupAutoCompleteRichResult {display:none !important;} </nowiki></pre> ---- It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted. In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named <i>userChrome.css.txt</i>. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as". You need to close and restart Firefox when you create or modify the userChrome.css file.