Veelgestelde vragen - Add-on-technologie van Firefox wordt gemoderniseerd

Wat is een verouderde extensie?

Extensies die met raamwerken zijn gemaakt die niet compatibel zijn met Firefox 57 en hoger (zoals SDK of XUL) worden als ‘verouderde’ (‘legacy’) extensies beschouwd.

Hoe weet ik of ik verouderde extensies heb geïnstalleerd?

Om te zien of u niet-compatibele extensies hebt geïnstalleerd, gaat u naar de Add-onbeheerder (menu Extra > Add-ons, of typ ‘about:addons’ in een nieuw tabblad). Als u een verouderde extensie hebt, ziet u een melding boven in uw scherm, zoals deze:

Legacy extension warning

Klik op de koppeling ‘Verouderde extensies tonen’ om een lijst van verouderde extensies te zien die in uw browser zijn geïnstalleerd. Klik op ‘Een vervanging zoeken’ naast elke verouderde extensie voor een aanbevolen alternatief. U kunt meer lezen over deze functie in onze blog.

Als ik het label ‘verouderd’ zie, houdt dat dan in dat mijn extensie niet meer werkt als ik een upgrade naar 57+ uitvoer?

Ja, add-ons met het label ‘verouderd’ werken zeer waarschijnlijk niet meer als u een upgrade uitvoert. De meerderheid van de meest populaire extensies voor Firefox is echter compatibel met Firefox 57+. In sommige gevallen werken ontwikkelaars aan het bijwerken van hun extensies om deze compatibel met huidige versies van Firefox compatibel te maken. In deze gevallen wordt de extensie automatisch bijgewerkt zodra de compatibele versie beschikbaar is.

Als ik het label ‘verouderd’ zie, houdt dat dan in dat mijn extensie niet meer werkt?

Ja, extensies met het label ‘verouderd’ zullen niet werken met Firefox 57. In sommige gevallen dienen ontwikkelaars tot aan de deadline te werken om hun extensies compatibel te maken voor de vrijgavedatum van 14 november 2017. Andere extensies kunnen compatibel worden nadat de deadline is verstreken. In deze gevallen wordt de extensie automatisch bijgewerkt zodra de compatibele versie beschikbaar is.

Kunnen jullie vervangingen voor mijn verouderde extensies aanbevelen?

Ja! U kunt door onze collectie met aanbevolen extensies bladeren die uit populaire gebruikte extensies bestaat, of op addons.mozilla.org (AMO) naar compatibele extensies zoeken.

Als alternatief kunt u de extension finder gebruiken om de extensie die u wilt vervangen op te zoeken en aanbevolen vervangingen te vinden.

Ja! Ga naar de Add-onbeheerder (menu Extra > Add-ons, of typ about:addons in een nieuw tabblad) en selecteer ‘Verouderde extensies’. Klik naast elke verouderde extensie op ‘Een vervanging zoeken’ voor een aanbevolen alternatief. U kunt meer lezen over deze functie in onze blog.

We raden aan om op addons.mozilla.org (AMO) naar compatibele extensies te zoeken of de collectie met aanbevolen extensies te bekijken.

Als alternatief kunt u de extension finder gebruiken om de extensie die u wilt vervangen op te zoeken en aanbevolen vervangingen te vinden.

Er zijn geen aanbevolen vervangingen voor een van mijn verouderde extensies. Wat nu?

Als u geen passende vervanging vindt, ga dan naar ons forum en vraag de gemeenschap om suggesties.

Hoe kan ik extensies vinden die compatibel zijn met Firefox 57 en hoger?

U kunt op addons.mozilla.org naar compatibele extensies zoeken. De collectie met aanbevolen extensies bevat ook geweldige extensies die na Firefox 57 compatibel zullen zijn.

Wanneer stopt Firefox ESR met de ondersteuning van verouderde extensies?

Firefox Extended Support Release (ESR) versie 52 is de laatste versie die verouderde extensies ondersteunt. ESR 52 wordt vanaf 5 september 2018 niet meer ondersteund.

In oktober 2018 zullen alle verouderde add-ons op addons.mozilla.org (AMO) worden uitgeschakeld. Zodra dit is gebeurd, zullen gebruikers geen verouderde add-ons op AMO meer kunnen vinden.

Als u besluit om niet-ondersteunde versies van Firefox te installeren zodat u verouderde add-ons kunt gebruiken, maakt dit u kwetsbaar voor beveiligingsproblemen. We raden nadrukkelijk aan deze versies niet te gebruiken.

Stoppen mijn thema’s met werken in Firefox 57?

Als u een lichtgewicht thema gebruikt, zou u geen verstoring moeten zien. Als u een volledig thema gebruikt, zal dit vanaf Firefox 57 worden uitgeschakeld en niet meer werken. Als u een donker volledig thema gebruikt, is de optie Donker thema in de add-onbeheerder voor u wellicht een goede optie. Ga naar het tabblad Thema’s in about:addons en probeer het eens.

Wat is er met mijn volledige thema gebeurd?

Volledige thema’s werken niet met Firefox 57+ en zijn uitgeschakeld. Als u een donker volledig thema gebruikt, is de optie Donker thema in de add-onbeheerder voor u wellicht een goede optie. Ga naar het tabblad Thema’s in about:addons en probeer het eens. In de komende maanden worden verbeteringen aan thema’s aangebracht, dus zoek naar thema’s met extra functionaliteit die verder gaat dan een afbeeldingsoverlay in toekomstige versies.

Wat is er met mijn Flash-gerelateerde add-on gebeurd?

Vanaf de vrijgave van Firefox 55 wordt Adobe Flash niet meer standaard uitgevoerd, omdat Klikken-voor-activeren van Flash in de browser is ingebouwd. U kunt op alle of bepaalde websites kiezen hoe u wilt dat Flash zich gedraagt.

Enkele van de meest populaire Flash-extensies boden deze mogelijkheid voordat het onderdeel van de browser werd. Aangezien deze extensies nu als verouderd worden beschouwd, zullen ze waarschijnlijk niet meer door ontwikkelaars worden ondersteund en niet meer werken.

In sommige gevallen hebben we WebExtension-API’s voor aanvullende Flash-mogelijkheden (zoals Flash LSO-verwijdering) en verwachten we dat add-ons in de loop der tijd meer Flash-mogelijkheden bieden naar aanleiding van samenwerking om te ontdekken wat nodig is om voor gelijkwaardigheid van functies te zorgen.

// Deze aardige mensen hebben dit artikel helpen schrijven:Tonnes. U kunt ook helpen - lees hier hoe.

Was dit artikel nuttig? Een moment geduld…

Word vrijwilliger bij Mozilla Support