X
Tap here to go to the mobile version of the site.

Support Forum

How do I install Firefox 64-bit? Firefox automatically installs 32-bit on my computer and it's not working.

Posted

Ever since February (some kind of update happened), Firefox has basically died on my computer. I open it and only for a few moments does it work with any kind of speed, then it literally dies to a snails pace. It takes minutes even to scroll a screen or open a menu screen. And that's just being on the Mozilla site. Forget about trying to open any other significant websites. I have tried everything from reinstalling, resetting and disability plug-ins. I will say that the Firefox Icon at the bottom of my screen shows a security shield on it, which didn't use to be there. I really need help. I've been forced to use Chrome, which did work fine, but I can't stand it. SAVE ME PLEASE!!!!

Ever since February (some kind of update happened), Firefox has basically died on my computer. I open it and only for a few moments does it work with any kind of speed, then it literally dies to a snails pace. It takes minutes even to scroll a screen or open a menu screen. And that's just being on the Mozilla site. Forget about trying to open any other significant websites. I have tried everything from reinstalling, resetting and disability plug-ins. I will say that the Firefox Icon at the bottom of my screen shows a security shield on it, which didn't use to be there. I really need help. I've been forced to use Chrome, which did work fine, but I can't stand it. SAVE ME PLEASE!!!!

Chosen solution

I have solved the problem and this is SUPER IMPORTANT TO KNOW! I had to use Chrome to fix and I don't know how it would be done through Firefox directly. In the Chrome browser:

Type “about:plugins” (without quotation marks) into the address bar at the top of a Chrome browser window. Click “Details” at the upper-right corner of the page. Find the “Java(TM) (2 files)”. One file named: Java(TM) Platform SE 7 U21 and one file named: Java Deployment Toolkit 7.0.210.11 (see full description below). Go to the Java Deployment Toolkit file and click the corresponding "Disable" button. Once you click it, it will turn to "Enable". Now open Firefox and all game playing works perfectly and Firefox is back to normal!!!!

Name: Java Deployment Toolkit 7.0.210.11 Description: NPRuntime Script Plug-in Library for Java(TM) Deploy Version: 10.21.2.11 Location: C:\Windows\SysWOW64\npDeployJava1.dll Type: NPAPI

	 Enable

I can't believe I fixed this myself. I can't tell you how happy I am. I just did this, so I'll let you know if I run into any other problems. If anyone knows how to locate this plugin information through Firefox, please post, but once I tried to open something like Farmville, Firefox basically stopped working, so if it's going to be done from Firefox, do it before opening any other pages. Please share!

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.43 Safari/537.31

More Information

Andrew
  • Moderator
322 solutions 4067 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

'''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.''

Helpful Reply

I'm sorry it took me so long to get back to you about my Firefox problems, but I just re downloaded Firefox and opened it in Safe Mode and the terrible problems still exist. This is awful because I hate Chrome and love Firefox and can't use it. Every action is severally delayed to the point that I can't use it. Have you found anything about this problem. Is there something I need to get rid of in my computer or firewall to correct this problem. Chrome has no problems, so it's something with the Firefox software interfacing with my computer and I can't figure it out. HELP! Thanks.

I'm sorry it took me so long to get back to you about my Firefox problems, but I just re downloaded Firefox and opened it in Safe Mode and the terrible problems still exist. This is awful because I hate Chrome and love Firefox and can't use it. Every action is severally delayed to the point that I can't use it. Have you found anything about this problem. Is there something I need to get rid of in my computer or firewall to correct this problem. Chrome has no problems, so it's something with the Firefox software interfacing with my computer and I can't figure it out. HELP! Thanks.

Question owner

Okay, so since there was a concern about putting this response in reply to another question, I'm adding all my comments and current problems here.

The thing is is that both Chrome and Explorer work fine as far as speed goes, so it has to be something directly related to Firefox and how it interacts with our computers. I have had the same problem since the update they did in February and have been forced to use Chrome because I can't find any solutions with support. There has to be something that is either lingering in our computers from older versions that are blocking complete functionality now or it has effected our firewalls. I have completely removed Firefox and reinstalled several times with no improvement. Removed Firefox about a month ago and just installed the latest version today and have the exact same problem - so slow it isn't functional. Although most sites seem to be running a tiny bit faster until you click on a link within the page (the picture below shows what happens to my connection when something tries to load - it just turns gray and stalls). And sites like Facebook are supper slow and games like Farmville (or any games for that matter) don't work at all due to the lag.

And now there are constant prompts for scripts being busy or not running (other attached picture one of 4 I've gotten in 3 different sites). I sure hope one day these problems are fixed because I want to come back to Firefox as soon as they are.

Okay, so since there was a concern about putting this response in reply to another question, I'm adding all my comments and current problems here. The thing is is that both Chrome and Explorer work fine as far as speed goes, so it has to be something directly related to Firefox and how it interacts with our computers. I have had the same problem since the update they did in February and have been forced to use Chrome because I can't find any solutions with support. There has to be something that is either lingering in our computers from older versions that are blocking complete functionality now or it has effected our firewalls. I have completely removed Firefox and reinstalled several times with no improvement. Removed Firefox about a month ago and just installed the latest version today and have the exact same problem - so slow it isn't functional. Although most sites seem to be running a tiny bit faster until you click on a link within the page (the picture below shows what happens to my connection when something tries to load - it just turns gray and stalls). And sites like Facebook are supper slow and games like Farmville (or any games for that matter) don't work at all due to the lag. And now there are constant prompts for scripts being busy or not running (other attached picture one of 4 I've gotten in 3 different sites). I sure hope one day these problems are fixed because I want to come back to Firefox as soon as they are.

Modified by Drkstr

jscher2000
  • Top 10 Contributor
8792 solutions 71898 answers

Hi Drkstr, could you try the following quick test: create a new Firefox profile. In addition to bypassing current extensions and custom settings, it should have completely fresh settings databases and a fresh cache folder.

Close Firefox and start up in the Profile Manager using the Start menu:

Start > search box > firefox.exe -p {Enter}

This dialog allows you to create new profiles, deleted unwanted ones, and start up in a different one. Each profile has independent bookmarks, extensions, etc. All usually have the same plugins.

When creating your new profile, please accept the folder location suggested and do not point the new profile to any existing folder to avoid data loss. I recommend not deleting a profile without making a backup first.

Is performance any better in the new profile?

Hi Drkstr, could you try the following quick test: create a new Firefox profile. In addition to bypassing current extensions and custom settings, it should have completely fresh settings databases and a fresh cache folder. Close Firefox and start up in the Profile Manager using the Start menu: Start > search box > '''firefox.exe -p''' {Enter} This dialog allows you to create new profiles, deleted unwanted ones, and start up in a different one. Each profile has independent bookmarks, extensions, etc. All usually have the same plugins. When creating your new profile, please accept the folder location suggested and do not point the new profile to any existing folder to avoid data loss. I recommend not deleting a profile without making a backup first. Is performance any better in the new profile?

Question owner

My profile was just created today when I downloaded the new version. See attached picture.

My profile was just created today when I downloaded the new version. See attached picture.
jscher2000
  • Top 10 Contributor
8792 solutions 71898 answers

Oh, I assumed you retained your personal settings when you updated. If you removed all your settings and are running completely blank, then a new profile test isn't going to tell you anything.

Do you still have a shield on your Firefox shortcut, or on the task bar when Firefox is running?

Oh, I assumed you retained your personal settings when you updated. If you removed all your settings and are running completely blank, then a new profile test isn't going to tell you anything. Do you still have a shield on your Firefox shortcut, or on the task bar when Firefox is running?
cor-el
  • Top 10 Contributor
  • Moderator
17574 solutions 158974 answers

That is not the Firefox profile folder.

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

The "Application Data" folder in XP/Win2K and the "AppData" folder in Windows Vista and Windows 7 and later versions are hidden folders.

That is not the Firefox profile folder. *http://kb.mozillazine.org/Profile_folder_-_Firefox * C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\Profiles\&lt;profile&gt;\ The "Application Data" folder in XP/Win2K and the "AppData" folder in Windows Vista and Windows 7 and later versions are hidden folders. *http://kb.mozillazine.org/Show_hidden_files_and_folders

Question owner

When I removed Firefox the last time, I saved my bookmarks and then deleted everything so I removed everything. I was hoping that would fix things. And actually now that you mention it, the shield isn't on the icon now. That's a first since back in February, so something has changed. That's probably why there's some movement now on some sites.

I'll check the information posted by cor-el - thanks!

When I removed Firefox the last time, I saved my bookmarks and then deleted everything so I removed everything. I was hoping that would fix things. And actually now that you mention it, the shield isn't on the icon now. That's a first since back in February, so something has changed. That's probably why there's some movement now on some sites. I'll check the information posted by cor-el - thanks!

Question owner

I checked the AppData folder and my profile information all starts today, but I did find something interesting checking under Crash Reports/Pending and I must have over 200 listed. See sample below. I don't know if this means anything, but it doesn't seem normal. I also couldn't access http://kb.mozillazine.org/Profile_folder_-_Firefox - it kept trying to load and finally timed out.

I checked the AppData folder and my profile information all starts today, but I did find something interesting checking under Crash Reports/Pending and I must have over 200 listed. See sample below. I don't know if this means anything, but it doesn't seem normal. I also couldn't access http://kb.mozillazine.org/Profile_folder_-_Firefox - it kept trying to load and finally timed out.
jscher2000
  • Top 10 Contributor
8792 solutions 71898 answers

If you open the about:crashes page, you may be able to click through to the Mozilla crash server and see whether your reports are linked to a particular known bug. Often these reports are difficult to interpret, so you can paste links to them here and a volunteer can take a look.

If you open the '''about:crashes''' page, you may be able to click through to the Mozilla crash server and see whether your reports are linked to a particular known bug. Often these reports are difficult to interpret, so you can paste links to them here and a volunteer can take a look.
James
  • Top 25 Contributor
  • Moderator
1602 solutions 11331 answers

Post the links that have bp- at beginning in about:crashes

as for the kb.mozillazine.org I guess the server could have been slow or down at that moment as it happens sometimes. It loads now.

Also the Firefox version for Windows from www.mozilla.org installing as 32-bit, it is because it is only 32-bit as Mozilla does not have 64-bit releases yet for Windows. It normally works just fine on Win64.

Post the links that have '''bp-''' at beginning in about:crashes as for the kb.mozillazine.org I guess the server could have been slow or down at that moment as it happens sometimes. It loads now. Also the Firefox version for Windows from www.mozilla.org installing as 32-bit, it is because it is only 32-bit as Mozilla does not have 64-bit releases yet for Windows. It normally works just fine on Win64.

Modified by James

Tyler Downer
  • Top 25 Contributor
  • Moderator
1538 solutions 10734 answers

Sometimes with these sorts of issues we have to take a somewhat shotgun approach, try a few different things and hope that one takes.

First, scan for Malware on your machine (even if you have another anti-virus program, try these scanners, they catch other bugs that anti-virus programs don't). Troubleshoot Firefox issues caused by malware

Then, check for windows updates. Install any that you can find. You may need to check multiple times.

Update your graphics Driver Upgrade your graphics drivers to use hardware acceleration and WebGL

Sometimes with these sorts of issues we have to take a somewhat shotgun approach, try a few different things and hope that one takes. First, scan for Malware on your machine (even if you have another anti-virus program, try these scanners, they catch other bugs that anti-virus programs don't). [[Troubleshoot Firefox issues caused by malware]] Then, check for windows updates. Install any that you can find. You may need to check multiple times. Update your graphics Driver [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]
Eeri 0 solutions 3 answers

Hi, found this thread via google. i just built a new pc and installed windows ultimate 64 bit. first programs that i installed were antivirus and drivers, then firefox. ive been having the same issues and had to switch to chrome because it seems the longer its open/the more tabs i have open the worse the problem is.

The pc i built has an 4Ghz 8 core amd processor(Which i wouldnt buy again) and 16GB of ram.

This has got to be either a windows ultimate 64 bit problem or a hardware problem. no other problems can possibly exist.

Hi, found this thread via google. i just built a new pc and installed windows ultimate 64 bit. first programs that i installed were antivirus and drivers, then firefox. ive been having the same issues and had to switch to chrome because it seems the longer its open/the more tabs i have open the worse the problem is. The pc i built has an 4Ghz 8 core amd processor(Which i wouldnt buy again) and 16GB of ram. This has got to be either a windows ultimate 64 bit problem or a hardware problem. no other problems can possibly exist.
jscher2000
  • Top 10 Contributor
8792 solutions 71898 answers

Hi Eeri, did you notice the same slowdown in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Hi Eeri, did you notice the same slowdown in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?

Question owner

Hi, Eeri. It is not a Windows problem. I never had any problem at all with Firefox until there was an upgrade of Firefox in February and then, bam, everything stopped. It may be a problem between Firefox and Adobe though. There seems to be more problems with sites that require a lot of flash/shockwave interaction. Firefox is moving a bit faster on most site now (not sure why), but still can't access an gaming with it.

Hi, Eeri. It is not a Windows problem. I never had any problem at all with Firefox until there was an upgrade of Firefox in February and then, bam, everything stopped. It may be a problem between Firefox and Adobe though. There seems to be more problems with sites that require a lot of flash/shockwave interaction. Firefox is moving a bit faster on most site now (not sure why), but still can't access an gaming with it.

Question owner

Oh, and starting in the Safe Mode made on difference for me. FYI.

Oh, and starting in the Safe Mode made on difference for me. FYI.
jscher2000
  • Top 10 Contributor
8792 solutions 71898 answers

Hi Drkstr, Flash, hmmm. This is some standard guidance that addresses the most common issues. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Hi Drkstr, Flash, hmmm. This is some standard guidance that addresses the most common issues. I'm sure you've seen some of it before, but just in case: (1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them. (2) Disable hardware graphics acceleration in Firefox and in Flash (A) In Firefox, un-check the box here and restart: orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available" (B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues (3) Disable protected mode (Windows Vista/7/8) See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?]

Chosen Solution

I have solved the problem and this is SUPER IMPORTANT TO KNOW! I had to use Chrome to fix and I don't know how it would be done through Firefox directly. In the Chrome browser:

Type “about:plugins” (without quotation marks) into the address bar at the top of a Chrome browser window. Click “Details” at the upper-right corner of the page. Find the “Java(TM) (2 files)”. One file named: Java(TM) Platform SE 7 U21 and one file named: Java Deployment Toolkit 7.0.210.11 (see full description below). Go to the Java Deployment Toolkit file and click the corresponding "Disable" button. Once you click it, it will turn to "Enable". Now open Firefox and all game playing works perfectly and Firefox is back to normal!!!!

Name: Java Deployment Toolkit 7.0.210.11 Description: NPRuntime Script Plug-in Library for Java(TM) Deploy Version: 10.21.2.11 Location: C:\Windows\SysWOW64\npDeployJava1.dll Type: NPAPI

	 Enable

I can't believe I fixed this myself. I can't tell you how happy I am. I just did this, so I'll let you know if I run into any other problems. If anyone knows how to locate this plugin information through Firefox, please post, but once I tried to open something like Farmville, Firefox basically stopped working, so if it's going to be done from Firefox, do it before opening any other pages. Please share!

I have solved the problem and this is SUPER IMPORTANT TO KNOW! I had to use Chrome to fix and I don't know how it would be done through Firefox directly. In the Chrome browser: Type “about:plugins” (without quotation marks) into the address bar at the top of a Chrome browser window. Click “Details” at the upper-right corner of the page. Find the “Java(TM) (2 files)”. One file named: Java(TM) Platform SE 7 U21 and one file named: Java Deployment Toolkit 7.0.210.11 (see full description below). Go to the Java Deployment Toolkit file and click the corresponding "Disable" button. Once you click it, it will turn to "Enable". Now open Firefox and all game playing works perfectly and Firefox is back to normal!!!! Name: Java Deployment Toolkit 7.0.210.11 Description: NPRuntime Script Plug-in Library for Java(TM) Deploy Version: 10.21.2.11 Location: C:\Windows\SysWOW64\npDeployJava1.dll Type: NPAPI '''Enable''' I can't believe I fixed this myself. I can't tell you how happy I am. I just did this, so I'll let you know if I run into any other problems. If anyone knows how to locate this plugin information through Firefox, please post, but once I tried to open something like Farmville, Firefox basically stopped working, so if it's going to be done from Firefox, do it before opening any other pages. Please share!

Question owner

Eeri, please read my most recent post. I think this will fix your problem. I hope it works for you. Since you're using Chrome, you can follow the instructions I just posted. Please let me know if this works for you. I'm very excited! I figured this out because I was having constant shockwave crashing in Chrome and I was instructed to disable one of the Adobe Flash Player files. I thought that maybe there might be something similar with the 2 Firefox Java files (towards the bottom of the page). And it worked!!! Please let me know if this works for you.

Eeri, please read my most recent post. I think this will fix your problem. I hope it works for you. Since you're using Chrome, you can follow the instructions I just posted. Please let me know if this works for you. I'm very excited! I figured this out because I was having constant shockwave crashing in Chrome and I was instructed to disable one of the Adobe Flash Player files. I thought that maybe there might be something similar with the 2 Firefox Java files (towards the bottom of the page). And it worked!!! Please let me know if this works for you.
jscher2000
  • Top 10 Contributor
8792 solutions 71898 answers

Hi Drkstr, you wrote:

Type “about:plugins” (without quotation marks) into the address bar at the top of a Chrome browser window. ... If anyone knows how to locate this plugin information through Firefox, please post...

Firefox's about:plugins page is read only. To Enable/Disable plugins in Firefox use the Add-ons page (AKA about:addons):

orange Firefox button (or Tools menu) > Add-ons > Plugins category

Hi Drkstr, you wrote: <blockquote>Type “about:plugins” (without quotation marks) into the address bar at the top of a Chrome browser window. ... If anyone knows how to locate this plugin information through Firefox, please post...</blockquote> Firefox's about:plugins page is read only. To Enable/Disable plugins in Firefox use the Add-ons page (AKA about:addons): orange Firefox button (or Tools menu) > Add-ons > Plugins category