Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Latest Java update

  • 119 replies
  • 167 have this problem
  • Last reply by Mr. News

more options

Hi, My Firefox plug-in check is telling me that there is an update for Java, but when I visit the link it's still taking me to the old update (the Java 7 update 9). Also, according to the Java test page, Java 7u9 is still showing that it's the says I have the recommended version.

Is there an newer update somewhere?


Chosen solution

  • update*

It looks as though the issue has been fixed. When checked my plug-ins this evening, the 7u9 had corrected itself and is now displaying the actual update (7u10).

I've uninstalled the 7u9 completely and everything is checking out on FF! :)

Read this answer in context 👍 9

All Replies (20)

more options


Did you try JavaRa version 2.0 here - (click the "Download" link on the right side, then you can select version 2.0 or version 1.1.6 on the download page)

The JavaRa.def file in JavaRa 1.1.6 installed on my system, only has registry info through Java 1.6.22.

I have noticed with Java 7u10 that if you try to enable the Platform in Add-ons > Plugins, it is not recognized until you restart Firefox. We may be seeing a Java 7u11 sooner than Oracle planned.

Modified by TheOldFox

more options

@the_edmeister, & TheOldFox I'm going to try the JavaRa uninstall when I get home, I'll let you know if it works. But like the_edmeister said, it's as though the 7u10 update is missing it's Firefox plug-in detector.

more options

I used the 1.16 version - but I'll try the 2.0 version in a few minutes when a different download is finished (WTF is a 5MB cable connection good for when download websites can only delivered 101MB to 125MB download speeds. I wish that "legitimate" software companies would start offering torrent streams.) and I can log-out of this LUA and login to the Admin account.

After installation I switched to my regular user account and launched Firefox, and then due to your mention of restarting Firefox I did a Restart of Firefox, I think. Regardless, I started Firefox in the Admin account, closed it, and then switched to my regular LUA.

more options

[Sorry for repeating some of what I posted above, but there seems to be a lag in posts getting added to threads --- another problem is all we need, right, the-edmeister?]

the-edmeister and Alice_85:

JavaRa 1.1.16 JavaRa.def file only has updated registry entries through Java 6u22, hence, the-edmeister, it could not find Java 7u10 to uninstall it. JavaRa 2.0 JavaRa.def file is only updated through Java 7u6 (see Edit Addition below) and I can not get JavaRa 2.0 to initialize, so using JavaRa may not be a viable alternative for uninstalling Java. I have used JavaRa on only a couple of occasions in the past and it has always worked as expected.

I learned a few versions back to update Java only with the full JRE installer. In the past, I updated through the Java Control Panel (in Windows Control Panel), but recent updates that way would take away the Java Control Panel. For some users, using the Java Control Panel may not be an option if the Update tab is not showing, which requires the insertion of a new registry key.

I have both the Java(TM) Platform SE 7 U10 and Java Deployment Toolkit in Add-ons > Plugins.

I have noticed that enabling the Platform (I usually keep both disabled in the Firefox installation that I use for daily browsing) is not immediately recognized by Firefox and I must restart the browser for the then enabled Java Platform to be recognized. There could be a problem with both Java and Firefox and recent changes in both.

Oracle may be surprised to find that a Java 7u11 will need to be released sooner than planned, based on some of the posted problems on this forum today.

Edit Addition:

JavaRa 2.0 has a facility to update the definition file, whereas JavaRa 1.1.16 appears to not have that facility -

Modified by TheOldFox

more options

@TheOldFox, thanks for the info. I was confused anyway as to how to use the JavaRa programs.

Do you think I should try manually uninstalling both Java versions and then reinstalling the offline 7u10?

Also, how did you manage to get those plug-ins to show up in the update check? (Earlier in the thread I posted a screenshot of what my Firefox plug-in page shows.) Even though 7u10 is running, and everything is "green" (ie up-to-date), the 7u9 still shows up...because Java's test page didn't recognize Firefox's 7u10 update.

In a nutshell, I guess I just want to know of I can go about my usual online business with 7u9 & 7u10? All tests show I'm up to date. :)

more options

Thanks for coming up with the information about JavaRa 2.0 and the JavaRa.def update file to get the latest definitions.

At this point I am giving up on getting the Platform SE 7 U10 plugin. I don't know which version of Windows you are running, but IMO something is screwed up with the U10 installer on WinXP. Quite honestly I wouldn't even bother to have Java installed except for Open Office needing it. I rarely if ever use it in Firefox - NoScript blocks it from running until I activate it. I only attempted to update Java because the Plugin warning from Mozilla about an out of date plugin is starting to bug me big time.

more options

A win7 x64 user over here thinks a missing registry key was causing his problem with the plugin not showing.

more options

I think Windows Vista 32-bit must be having the same issue.

more options


  • See if you can uninstall Java 7u9 from Windows Control Panel > Add or Remove Programs (or Programs and Features)
  • You should not need to "do anything" to have the 2 Plugins show up. The 2 plugins should be in Firefox Add-on > Plugins also. That is where I looked for my previous response. See image below for Plugin Check results and Add-ons > Plugins results.


  • This is my XP SP3 system.
  • Open Office is the only reason that I have Java on my system, also.

Modified by TheOldFox

more options

@TheOldFox, Thank you for sticking with me through this. :)

When I uninstall 7u9 and then visit the Java test page, this is what I see: (Even when 7u10 has been installed and shows up in Safari and IE.) *please see photo 1*

{It's as though Firefox isn't picking up the plug-in.}

So I've reinstalled the 7u9 update (as prompted in screenshot #1). And I'm back to this on the Firefox plug-in check: *please see photo 2*

7u10 is working, at least according to the Java test page.

Modified by Alice_85

more options

WOW!! I am not sure what to say. I have never seen one version of Deployment Toolkit and a totally different version of Java Platform like that.

What shows in Add-ons > Plugins in Firefox? Be sure to look for disabled versions also -- they will be grayed-out, but you can click the Enable button to enable them, then restart Firefox and look again.

I know that there is a bug related to the "Next Generation Java Plugin" option (which is required in current Firefox versions) that is being discussed on the Java forums, that is being classified as a bug but the problem is not always reproducible and appears to affect only Windows 7 and enabling/disabling Java in the Java Control Panel. Apparently, as of yesterday, 12-11-2012, the developers have decided to put that on the list of things to correct in Java 7u12. Here is the link to the bug, it's technical and it is to be read only, no posting (see my suggestion below) -

First in Windows Control Panel, click on Java to open the Java Control Panel, click on the Advanced tab and be sure that the items outlined in red in the image below are checked, especially the one "Enable the next generation Java plugin". Exit and restart all browsers and test at Plugin Check and at the Java test page and look to see what is in Firefox Add-ons > Plugins. If there is still a problem, try the "Uninstall all Java..." below.

Uninstall all Java and reinstall:

  1. Uninstall any Java version in Windows Control Panel > Add or Remove Programs (or Programs and Features)
  2. Restart you computer
  3. Check all browsers to see if there is any evidence of any version of Java. Visit Plugin Check and the test page referred to earlier on the Java site with each and every browser that you have installed.
  4. If none of your browsers indicate that you have Java installed, then proceed, otherwise STOP and do none of the following
  5. Install the JRE that you downloaded for Java 7u10, then perform Step 3 above again.

I really do not know what caused this, but it appears to be a mess in your Firefox. Try the above and post back with your results.

OOPS - forgot to include the image. Here it is.

I am off to dinner and may not be back on the forum tonight, but I will receive an e-mail notification of any reply posted in this thread.

Modified by TheOldFox

more options

Thanks, I'm a bit scared now. o_O

Okay, so all the boxes from your screenshot were already marked, except for 'Microsoft Internet Explorer." {Under default Java for browsers.} Firefox is set as my default browser, should I switch it back to IE and try again?

I also looked at Disabled Add-Ons, but I couldn't find anything relating to Java that had been disabled...

The discussion they're having in the Java forums is way over my head. I'm a complete noob at all this technical stuff.

Please, take your time, enjoy dinner! I'm so thankful to have someone helping me with this. :) When you're ready, please let me know if (and how) I should set IE as my default browser.


  • edit* I figured out how to reset IE as my default browser but it won't allow me to check off the box (in the Java control screenshot you provided).

Modified by Alice_85

more options

I uninstalled all Java, and made sure it was absent from all browsers (it was). So I went to the Firefox plug-in check, it told me I needed to update, and I was taken to the 7u9 again.

As of now I'm back to where I was this morning, using Java update 9. I'll try installing the 7u10 again tomorrow...hopefully Java will have an easier method by then?

What should I do with that Java Deployment Toolkit? It's a remnant from whatever happened earlier (part of the 7u10 that didn't go through). Should I leave it disabled for now, until I can figure out how to get the actual 7u10 platform?

more options


I recommend that you do nothing else for now since this is a Java or FF problem. (I just opened an account to make that statement!).

I have fiddled around all day with this problem that is exactly like yours. However, when I noticed that FF required a Java update, I instead immediately opened the Java Control Panel in Windows Control Panel and updated to Java 7 Update 10. Using IE 9 I checked the version at Java Support and the display box showed Update 10. All good.

Then I opened FF and saw that FF had disabled Java 9, then I followed the link (as you did) to update to 10, and was only given the option of Update 9--which I installed.

Like you, I now have 2 versions (9&10) under Windows Programs. Now when I use Java Control Panel to check for the version, it displays I have Update 9 and not 10 as it displayed earlier when I first updated before using FF browser plug-in update!

I will wait for a few days before doing anything else unless someone finds a fix before then.

Win 7 HP x64

more options

1_FFF, Thank you.

  I'm sorry to hear that you're having problems, but I am relieved to know that I'm not the only one. :) Working on this for almost an entire day has scrambled my brain. 

I'll take your advice at leave things alone for now. (And I suggest that anyone who has tried to wrap their mind around this for hours on end- treat themselves to a pint of Guinness.) :D

more options

I have exactly the same problem. I followed the link and downloaded and installed Java 7_10, then rebooted and restarted FF. Got a message that "outdated" Java had been disabled (it was no longer listed in Add-Ons) for safety, and to download the latest version. So I followed the link and downloaded and installed Java 7_9 (which is what I was running before), and now everything is fine. The Java PLATFORM is the same as it ever was (SE 7 U9), it appears that all that sturm und drang was to update the "Java Deployment Toolkit" to v7.0.90.5 (from Just a circuitous and confusing procedure that is apparently not working for some folks.

more options

Whether I am using browsers IE9 or FF 17.0.1, when I go to, click on ‘Do I Have Java’, then click ‘Verify Java Version’, I get “You have the recommended Java installed (1.7.0_10)” [See Image]

Furthermore, within Windows Control Panel/Programs and Features where both Java Update 9 and 10 now reside, if I highlight either one of those and then click the support link displayed at the bottom of the program page, I am directed to the same ‘Do I Have Java’ page. Even though Version 9 displays in Programs and Features and I click on the support link for that version/update, the Java support site still shows that I have update 10 installed.

Therefore, regardless of what FF displays on the plug-in/add-on pages, when surfing with any browser we should be okay and actually using Java 7 Update 10—even though Java Update 9 is also installed. This still needs fixing…

more options

@ mrnews54,

Do you have both Java versions 9 & 10 listed within Windows Control Panel/Programs and Features (Uninstall or Change Programs area)?

more options

Safari (for Windows) is showing the 7u10 must be an FF plug-in issue.

more options

I suspect that the Java SE 7 U 10 update is for IE and maybe Safari, and not for Firefox or Opera. shows Java SE 7 U 9 as Latest Java Installed and I suspect the Mozilla Plugin Check page is wrong by saying that U 9 is out of date.

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6