Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Page loading

  • 12 replies
  • 1 has this problem
  • 26 views
  • Last reply by Gemwriter

more options

Hello. Suddenly, Firefox isn't loading/displaying web-page backgrounds. I uninstalled, downloaded and re-installed.

Chosen solution

Hi Peter, I can't tell whether you experimented with the setting cor-el mentioned, so let's review:

What is your setting for the "Override" selector in the Colors dialog (screenshot attached):

If you set that to Always, you will lose the page's background colors (like the magenta bar) and see ONLY your assigned text and background colors. However, that would not remove the background image, at least in my testing.

What if you switch the selector to "Never" to force Firefox to honor the rules in the page? Does that make any difference?

Read this answer in context 👍 0

All Replies (12)

more options

Is this with all websites/pages, some, a few?

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Thank you! Happens with all sites. Problem persists in Safe Mode. I delete cookies on a regular basis - at least at the end of every day, and sometimes more frequently. Just cleared to minimum (have to keep a few to log into a bank account - long present, so certain these are not involved - no diff. Flash is up to date, although Adobe is abandoning it very soon and recommending uninstall. I have it on two other browsers (Opera and Safari, both working fine). I block only cookies from unvisited sites. The weird thing is, this happened coincidentally with my web host company having a glitch that deactivated my website. That was quickly corrected. Just to make sure I deactivated a new extension Privacy Badger and restarted. Still the same. Just cleared the cache, still there. I hope this covers all instructions. Tnx

Helpful?

more options

Can we get a screenshot showing your full browser? see screenshot I know you said any site, but still provide a pic and link to the site?

Helpful?

more options

Make sure you haven't enabled a High Contrast theme in the OS settings.

Make sure you allow pages to choose their own colors.

  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.


Can you attach a screenshot?

Helpful?

more options

To all respondents, thank you. Didn't see option for individual replies.

The only color restriction I have is with the visited-link-color-picker extension, which has been operating correctly and for a long time before current issue. Link for screen shots is www.geminipress.com. Firefox vs Opera. Safari also works.

Helpful?

more options

I tried reply using Opera with screen shots, no luck. Now trying one at a time. Site link is www.geminipress.com Shots are jpegs Here is Opera

Helpful?

more options

Tried Opera to Reply with. Still no luck with screen shots (jpegs, using Grab) Default theme Now trying again from Opera using Preview window shot and .png

Helpful?

more options

Yeah... when you post links the moderators have to verify first and it takes time. I do like the topics covered on your site, but I am not able to replicate your issue(in Linux). see screenshot.

Modified by jonzn4SUSE

Helpful?

more options

Thanks. I don't have Linux, so can't relate. I think you'd have to try Firefox on same version Mac OS? Several things happened at once, but I think there was a FF update just prior to this anomaly. I don't track them, just download and don't think about it, knowing I'll restart at some point.

For a long time, I was having a wicked problem with FirefoxCP Web Content sucking huge chunks of %CPU, as shown in Activity Monitor. System would slow to a crawl, beachballs galore, which would settle down after restart (sometimes computer restart), but then gradually increase again. I usually have 10-15 tabs open. But it was no prob from the beginning. Then one day an update, and wham. I never posted a ticket, figuring it would be caught. After a time, it resolved and has been good. Right now, it's fluctuating widely. Here's a shot.

BUT - is there anywhere to go on this background issue? :-)

PS - I do a lot of research/writing and email issues once a week or so. If you want to be on my list, send a personal edress.

Helpful?

more options

Hello,

Problem in this thread not solved. I've waited a week since my last post, but there's been no reply. I'm not sure if that means there's no resolution known, or it's just taking a long time. I would like to ask that Admin be notified of this 'case,' and if they would say a word about it. I know it's probably rare - if it ever happened before :-) I don't want to have to switch browsers. Thank you. Peter

Helpful?

more options

Chosen Solution

Hi Peter, I can't tell whether you experimented with the setting cor-el mentioned, so let's review:

What is your setting for the "Override" selector in the Colors dialog (screenshot attached):

If you set that to Always, you will lose the page's background colors (like the magenta bar) and see ONLY your assigned text and background colors. However, that would not remove the background image, at least in my testing.

What if you switch the selector to "Never" to force Firefox to honor the rules in the page? Does that make any difference?

Helpful?

more options

That's it! Apologies, my bad. Since this occurred after working properly forever, and since the only color change I had recently made was setting the Visited Link extension, I didn't double check. How that got changed to Always will remain a mystery. I didn't touch it, had no reason to. Unless my advanced age has something to do with it :-) Many thanks, and apologies to cor-el and all responders. Peter

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.