Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spell check sometimes not working or is very delayed

  • 5 replies
  • 1 has this problem
  • 18 views
  • Last reply by FredMcD

more options

Spell check has long been a problem for me. It sometimes works, but most of the time it is not working, or is delayed by several minutes. The option to do spell checking is on. And the fact that it sometimes works indicates that the dictionary is present. This problems has been present for several releases. I am currently on 80.0.1

I know that before computers were common, a typist really strove to be accurate. But now you go for speed, and not accuracy at all. So, my messages tend to have a lot of errors. I cringe when I think of how many messages I typed before I realized that spell check was only occasionally working.

My work-around is to type what I need into my word processor, and then copy/paste into the web site where I want the text.

Chosen solution

It had been consistent across all sites.

However, the steps I have recently taken seems to have fixed it. It has been working perfectly all day today. Which one solved it is unknown. I have done the following;

  • Loaded another English dictionary.
  • Installed Grammarly, but didn't authorize it, then uninstalled it.
  • Changed the spellcheckdefault to option #2 (allow spellcheck for both single line and multi-line forms)

Anyway, thank you for replying, even if the true cause remains unknown, it is solved.

-Joe

Read this answer in context 👍 0

All Replies (5)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker


Grammarly for Firefox by Grammarly https://addons.mozilla.org/en-US/firefox/addon/grammarly-1/

Grammarly will help you communicate more effectively. As you type, Grammarly flags mistakes and helps you make sure your messages, documents, and social media posts are clear, mistake-free, and impactful.

Helpful?

more options

Thank you for your reply. But, it did not solve my problem. The spellcheckdefault setting was already set to 1, so it was on. And the spellchecker.dictionary was already working. As I said, it sometimes works... for example the word "spellcheckdefault" in the first line of this message has the wiggly red line, as it should.

I checked out the Grammarly extension. However, I was concerned about the information it wants permission to collect. A lot seems to be unnecessary for the functioning of the program, so I did not activate it.

I did change the spellcheckdefault setting to 2, which will cause the default spellchecking routine to check single line input boxes. Perhaps that will trigger some sort of change, which will cause the spell checking to work properly.

Helpful?

more options

I have heard that some website editors shut down the browser spellchecker. Have you noticed the problem only on certain websites?

Helpful?

more options

Chosen Solution

It had been consistent across all sites.

However, the steps I have recently taken seems to have fixed it. It has been working perfectly all day today. Which one solved it is unknown. I have done the following;

  • Loaded another English dictionary.
  • Installed Grammarly, but didn't authorize it, then uninstalled it.
  • Changed the spellcheckdefault to option #2 (allow spellcheck for both single line and multi-line forms)

Anyway, thank you for replying, even if the true cause remains unknown, it is solved.

-Joe

Helpful?

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.