Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Unable to Use GPU

  • 8 replies
  • 1 has this problem
  • 261 views
  • Last reply by vio

more options

I use a laptop with both an integrated graphics card and a dedicated graphics card (GTX 1060 Max-Q). Recently after reinstalling Windows, I found that Firefox refuses to use my dedicated graphics card. What's stranger about this is that when testing Chrome and Edge, Chrome has the same problem, but Edge seems to detect and use it the dedicated card just fine.

I used both https://alteredqualia.com/tmp/webgl-maxparams-test/ to test this, as well as monitoring GPU usage with GPU-Z to confirm that this was the case. I'm also using Firefox 80.0 at the time of this issue.

Is there something that could be preventing Firefox from accessing the GPU or something?

Chosen solution

Ok, I found the solution. Apparently Windows 10 has a place where you can select which graphics card your applications use. Setting Firefox to use dedicated graphics on my Nvidia Control Panel did nothing, but setting it on Windows "Graphics Settings" option did the trick.

Read this answer in context 👍 0

All Replies (8)

more options

Hi, did you add Firefox in the NVidia panel?

Helpful?

more options

Yes, I did. I figured that might've been the problem at first, but adding it didn't seem to do anything.

Helpful?

more options

Enter about:support in the URL bar and check the Graphics section.

Helpful?

more options

I put the whole graphics section in a pastebin:

https://pastebin.com/9h8nB1La

Helpful?

more options

Here, I put the Graphics section in a pastebin:

https://pastebin.com/9h8nB1La

Helpful?

more options

(note that this information is available as part of the System Details list as JSON)


Maybe check if there is an update available:

adapterDescription2: NVIDIA GeForce GTX 1060 with Max-Q Design
driverVendor2: 
driverVersion2: 26.21.14.4223
driverDate2: 1-31-2020
isGPU2Active: false
direct2DEnabled: true
{name: ADVANCED_LAYERS, description: Advanced Layers, status: blocked, log: [{type: default, status: available}, {type: env, status: blocked, message: Blocked from fallback candidate by WebRender usage}]},

Modified by cor-el

Helpful?

more options

I tried updating to the most recent driver on Nvidia's website (I previously used the driver provided by my laptop manufacturer). And I'm getting the exact same thing.

Here's the new pastebin:

https://pastebin.com/QsPbhYsJ

Helpful?

more options

Chosen Solution

Ok, I found the solution. Apparently Windows 10 has a place where you can select which graphics card your applications use. Setting Firefox to use dedicated graphics on my Nvidia Control Panel did nothing, but setting it on Windows "Graphics Settings" option did the trick.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.