Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to set cookies in Firefox browser

  • 9 replies
  • 1 has this problem
  • 1234 views
  • Last reply by vadval15

more options

Now the browser version Firefox Quantum Extended Support Release 68.4.1esr (32-bit) for Alt Linux is installed on my computer. Upon request by the POST method in the specified browser from the Apache server on the same computer loads a static web page with the following META tag in its header: <META HTTP-EQUIV="Set-Cookie" CONTENT="name=password; PATH=/"> After that, cookies must be created in the browser. Really they are created - in other browsers (Chrome and Opera), but for some reason they ceased to be created in the Firefox browser. What is the reason for this and is it possible to resume and track their creation in Firefox? I would be grateful for any answer on this question.

Chosen solution

Hi vadval15, it has become customary to set cookies using HTTP headers (or JavaScript) rather than meta tags. As of Firefox 68, you can no longer use the meta tags. See:

https://www.fxsitecompat.dev/en-CA/docs/2019/setting-cookies-with-meta-http-equiv-is-no-longer-allowed/

Read this answer in context 👍 1

All Replies (9)

more options

Hello Vadval15....


you go through these steps..


Click Tools > Options. Click Privacy in the top panel. Click the Cookies tab. Select the checkbox labeled 'Allow sites to set cookies.

Helpful?

more options

Thank you for the answer. I'm sorry, but I have a different menu in the Firefox browser. In my menu, the site has permission to create cookies, but for some reason it cannot create them.

Helpful?

more options

Hello...

  • Click the menu button. ...
  • Select the Privacy & Security panel and go to the Cookies and Site Data section.
  • Make sure Accept cookies and site data from websites (recommended) is selected.
  • Make sure Accept third-party cookies and site data is set to Always. ...
  • Click Exceptions….

Helpful?

more options

Thank you for your advice, but Firefox already has permission to accept cookies from my site, nevertheless they are not accepted anyway.

Modified by vadval15

Helpful?

more options

Hello vadval,

Please visit the link resolved the issues 

https://support.mozilla.org/en-US/kb/websites-say-cookies-are-blocked-unblock-them

I hope resolve your problem then reply back to me.

Regards, Arman

Helpful?

more options

Thank you very much for your advice. Please tell me where I can read cookies from a specific site in the Firefox browser.

Helpful?

more options

Preferences. Select the Privacy & Security panel and go to the Cookies and Site Data section. Make sure Accept cookies and site data from websites (recommended) is selected. Make sure Accept third-party cookies and site data is set to Always.

Helpful?

more options

Chosen Solution

Hi vadval15, it has become customary to set cookies using HTTP headers (or JavaScript) rather than meta tags. As of Firefox 68, you can no longer use the meta tags. See:

https://www.fxsitecompat.dev/en-CA/docs/2019/setting-cookies-with-meta-http-equiv-is-no-longer-allowed/

Helpful?

more options

Thank you from the bottom of my heart, Mr jscher2000, for solving this problem!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.