Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

remove Search with Amazon from address bar suggestions

  • 28 replies
  • 3 have this problem
  • 8235 views
  • Last reply by jscher2000

more options

Everytime I open the suggestions in the address bar Search with Google or Search with Amazon appear at the top. You cannot remove them by using the 'forget about this site' feature and if you change the browser.urlbar.openViewOnFocus to 'False' you don't get the suggestions. Can you tell me how to permanently remove Search with Google or Search with Amazon from the suggestions. Thank you.

Chosen solution

Hi gspotts, when you click in the address bar on Firefox 75+, before you start typing anything, the first 8 sites in your "Top Sites" on the built-in Firefox Home / new tab page drop down. So that is where the Amazon search shortcut is coming from.

If you use the built-in Firefox Home / new tab page, you can update your Top Sites list to be more useful. If you do not use that page, or if you use that page but do not use the Top Sites section, you can turn off Top Sites and Firefox will drop down your old list of "frequently/recently used sites" instead. (That was for Firefox 75-77 only)

To edit Top Sites:

Open the Firefox Home / new tab page. If you've changed your home page and new tab page, you can type or paste either of these special internal addresses in the address bar and press Enter to load them:

  • about:home
  • about:newtab

And then see the "Customize your Top Sites" section of this article for how to unpin or remove tiles from the Top Sites section: Customize items on your Firefox New Tab page.

If you turned off the Top Sites section of the page, you can turn that back on for editing purposes. See: Customize your New Tab page to hide or display content.

<center></center>

about:config Method

If the above method of individually unpinning/dismissing the shortcut from the new tab page isn't working, try this preference change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste improve and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts preference to switch the value from true to false


OBSOLETE

To switch the list by turning off Top Sites (Firefox 75-77 only):

Open the Options / Preferences page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Home.

Then on the right side, under Firefox Home Content uncheck the box for Top Sites.

Success? Let us know how you decide to proceed.

Read this answer in context 👍 1

All Replies (8)

more options

jscher2000, I don't think I'm going to attempt any of the suggestions in the fixing preferences article, at least not right now. I've closed the browser, let it rest for 20 minutes, nothing's changed. The last thing I'm seeing that I find noteworthy is that when I hover over the tiles, each of them link to simple, straightforward addresses (as seen in the tiny bar at bottom left of screen while hovering) such as: https://youtube.com www.imdb.com But this is what hovering over the amazon tile shows: https://www.amazon.com/?tag=admarketus-20&ref=pd_sl_a77559ED8D65ZZAA1220200802 Hmmm. Could that be making the difference? Thanks much for your time & attention.

more options

Oh my, while I was writing that last reply (and checking the other open new tab to verify the amazon address linked to that tile) the tile is gone! Will report back if that changes, but for now I am sooo happy! Thanks for bearing with, cor-el and especially jscher2000. And I hope you & yours are well & fine, safe & sound.

more options

I click unpin and nothing happens. It's a pinned amazon.com site. Incredibly frustrating. Started after last update I think. Firefox team please fix this. I'm losing faith in this browser.

more options

kgor.651 said

I click unpin and nothing happens. It's a pinned amazon.com site. Incredibly frustrating. Started after last update I think. Firefox team please fix this. I'm losing faith in this browser.

Does the pin icon go away but the tile just stays there anyway? In that case, try using "Dismiss". Is that an option on the menu for that tile?

more options

The truth is, sadly, Firefox do not allows to REMOVE Amazone, Google, Bing etc. but (if you can dig deep) allows only to HIDE. This happens from about Firefox 80-81 and later. Before that, you could remove those hidden extensions thru CCleaner but now, for some incomprehensibility reason, it's built in extensions and comes back at every Firefox startup.

I think Firefox takes some money to promote those sites and enforces those (extensions--add-ons) in Firefox built-in.

More, Firefox warning if default search engine is other than Google! [in Options->Search (or about:preferences#search)] " (i) An extension, DuckDuckGo Privacy Essentials, has set your default search engine."

Modified by AntonyMan

more options

Hi AntonyMan, I didn't think CCleaner could physically remove built-in search engine files because that would require editing a compressed program file. But either way, this thread is about a different issue: unwanted search engine shortcuts in the Top Sites section of the built-in Firefox Home / new tab page.

Are you having that problem?

If the usual method of individually unpinning/dismissing the shortcut from the new tab page isn't working, try this preference change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste improve and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts preference to switch the value from true to false


I think Firefox takes some money to promote those sites and enforces those (extensions--add-ons) in Firefox built-in.

Google pays to be the default in Firefox for most of the world (some countries have Baidu or Yandex as the default). This allows Firefox to be free to us users.

I don't know whether Amazon, Bing (Microsoft), eBay, or DuckDuckGo pay Mozilla to be bundled with Firefox; hopefully they are pitching in to support Firefox. (I assume Wikipedia doesn't pay, but I haven't tried to research it.)

More, Firefox warning if default search engine is other than Google! [in Options->Search (or about:preferences#search)] " (i) An extension, DuckDuckGo Privacy Essentials, has set your default search engine."

Yes, Firefox's Options/Preferences page tells you if an extension overrides your settings for either search engine or new tab page.

As you may know, you can search through DuckDuckGo using the built-in DuckDuckGo search engine extension without using the Privacy Essentials extension. The extension adds extra content blocking features.

more options

jscher2000 said

I didn't think CCleaner could physically remove built-in search engine files because that would require editing a compressed program file.

Maybe my bad English is to blame but, you answer irrelevant things, at the same time that I did not even ask question but just tried to explain. I said: Some back versions of Firefox allowed (thru CCleaner) hidden add-ons to be disabled, even if they were secretly activated again with each new release - now silently enabled each time Firefox starts.

But either way, this thread is about a different issue: unwanted search engine shortcuts in the Top Sites section of the built-in Firefox Home / new tab page.

Yes, I think it is part of main problem. Just, the Firefox, which I loved because used to paid attention on security and free and open source and blablabla, now became more and more intractable, closed and enforced. Another examble: It is more difficult to me to translate because: 1)ImTranslator does not work here as it does on ALL other pages and I have to have several windows open to translate instead of just right clicking on the paragraph as it does on ALL other pages than mozilla. 2)The same with many other extensions, like the "Dark Reader" extensions, here, I'm enforced to have bright white background! - contrariwise on ALL other pages that work perfect.

Google pays to be the default in Firefox for most of the world (some countries have Baidu or Yandex as the default). This allows Firefox to be free to us users.

It's ok, but it is totally different thing to allows to be default than - enforce to be default and do not even allows to disable or remove it.

I don't know whether Amazon, Bing (Microsoft), eBay, or DuckDuckGo pay Mozilla to be bundled with Firefox; hopefully they are pitching in to support Firefox. (I assume Wikipedia doesn't pay, but I haven't tried to research it.)

As you can see in about:support->Add-ons, the Amazon, Bing, Google etc. are Enabled (true) and not allowed to change.

I said above: More, Firefox warning if default search engine is other than Google! [in Options->Search (or about:preferences#search)] You answer: Yes, Firefox's Options/Preferences page tells you if an extension overrides your settings for either search engine or new tab page.

But, do not tell or warning as if an built-in extension overrides users settings for search engine or anything. And this looks like suspicious or and insidious.

As you may know, you can search through DuckDuckGo using the built-in DuckDuckGo search engine extension without using the Privacy Essentials extension. The extension adds extra content blocking features.

As you may do not know, like other extensions problems above, I had problem with this extension too. Firefox don't leave me to save changes to the page and I had to make duckgo log in every damn Firefox startup. I dig and I tried to set FF to not delete duckgo cookies and I search any settings I would set but nothing, I had to install duckgo Privacy Essentials to fix it.

So, thank you for your time, but I please you one more last favor: Please do not try to "wash" the problems with half meters and mostly do not try to put them under the carpet.

Modified by AntonyMan

more options

Hi AntonyMan, okay, I think I understand your comment better:

  • CCleaner can modify a Firefox file to hide built-in search engine extensions.
  • In older versions, Firefox did not detect this kind of change at startup, so it did not undo the change.
  • Now Firefox detects and undoes the change at startup.

I do not understand why that is a problem. You can uncheck search engines on the Options/Preferences page that you do not want to use.

  1. 1
  2. 2