Search Support

Firefox latest version is not able to play youtube videos at 1080p 60fps

  • 3 replies
  • 1 has this problem
  • 4 views
  • Last reply by Sebastian

more options

Firefox latest version is not able to play youtube videos at 1080p 60fps, while the old version Firefox 56.0 plays them correctly, without blocking images or flickering. The system is Windows 7 x64 updated with 8-core Intel processor and AMD HD RADEON 2gb DDR5 dual GPU video card

All Replies (3)

more options

clear the cache and cookies. disable your extensions and give it a try. sometimes it happens when the internet connection is not stable. check the network connection.

Helpful?

more options

It does not go, I had to reinstall Firefox 56.0, I have similar problem on Opera latest version, Firefox 76.0b4 Developer and Microsoft Edge, using these images tremble or block but the video contina because I hear the audio, I have already tried the suggested options. The PC is an 8 core intel xeon e5-2670 2.60ghz Mobo Intel DX-79SI sk2011, with 16gb DDR3 ECC 1866, Video card: AMD HD 5970 X2 GPU 2GB DDR5 drivers updated, OS Windows 7 x64 sp1, updated. This happens on other desktop PCs that I have, same software and OS, different platforms, cpu intel i7-990x and i7-980x 6 cores.

Helpful?

more options

Have you tried something like the Firefox add-on Enhancer for YouTube where you can set "Automatically play videos at my preferred quality" in the settings. Enhancer for Youtube

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.