X
Tap here to go to the mobile version of the site.

Support Forum

Nothing happens after choosing account in Google Account Picker page

Posted

I recently migrated from Chrome to Firefox, and have been facing problems during Google sign-in.

I have two Google accounts, A & B, and I use either one to register on most websites.

After migrating to Firefox, I'm facing a problem whenever I try logging into a site using my Google ID.

Here's what happens:

1. I click on the "Login with Google" button. 2. Since I have already signed in to Google using both accounts, I see both A and B in the Account Picker page. 3. I choose A. 4. The page changes to a loading screen, where I get a "One moment please..." message.

After this, the loading circle keeps rotating, but nothing happens.

I think it has something to do with content blocking, but since I'm quite new to Firefox, I'm not sure how to fix this.

I'd really appreciate any help.

Thanks in advance!

I recently migrated from Chrome to Firefox, and have been facing problems during Google sign-in. I have two Google accounts, A & B, and I use either one to register on most websites. After migrating to Firefox, I'm facing a problem whenever I try logging into a site using my Google ID. Here's what happens: 1. I click on the "Login with Google" button. 2. Since I have already signed in to Google using both accounts, I see both A and B in the Account Picker page. 3. I choose A. 4. The page changes to a loading screen, where I get a "One moment please..." message. After this, the loading circle keeps rotating, but nothing happens. I think it has something to do with content blocking, but since I'm quite new to Firefox, I'm not sure how to fix this. I'd really appreciate any help. Thanks in advance!

Chosen solution

While in theory there might be a way to stick the sites that need Google Authentication into the Google Container so they can share credentials, you probably need to get advice from the extension's author on that. I think it would be easier to remove Google Container and restart Firefox.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

Adblock Plus - free ad blocker Decentraleyes Evernote Web Clipper Google Container HTTPS Everywhere LastPass: Free Password Manager Popup blocker for FF: Poper Blocker Privacy Badger

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

jscher2000
  • Top 10 Contributor
8775 solutions 71729 answers

Hi gsmrn, when Firefox is blocking content, a "shield" icon should appear toward the left end of the toolbar next to the lock icon. To make a temporary exception for the current site, click the shield button to drop the site info panel, and use the button on the drop-down to make an exception. The page will need to reload.

If you do not see a shield icon, the issue could be one of your add-ons. Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Can you track down a block?

Hi gsmrn, when Firefox is blocking content, a "shield" icon should appear toward the left end of the toolbar next to the lock icon. To make a temporary exception for the current site, click the shield button to drop the site info panel, and use the button on the drop-down to make an exception. The page will need to reload. If you do not see a shield icon, the issue could be one of your add-ons. Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. Can you track down a block?
Was this helpful to you?
Quote

Question owner

Hi,

Thanks for replying. The account picker page opened in a small window, and this window didn't show me the plug-in icons. So I disabled all my extensions (except Google Container) and tried signing in, but I'm still facing the same problem.

As for the shield icon, there's none. I'm attaching a screenshot of the site info panel. Hope this helps.

I also tried changing the Content Blocking setting to "Custom" and disabled all the choices (screenshot attached). I reloaded the tabs and tried again. No luck.

I don't know how to track down a block, but if you can tell me how, I'll be able to do it.

Once again, thanks for helping!

Hi, Thanks for replying. The account picker page opened in a small window, and this window didn't show me the plug-in icons. So I disabled all my extensions (except Google Container) and tried signing in, but I'm still facing the same problem. As for the shield icon, there's none. I'm attaching a screenshot of the site info panel. Hope this helps. I also tried changing the Content Blocking setting to "Custom" and disabled all the choices (screenshot attached). I reloaded the tabs and tried again. No luck. I don't know how to track down a block, but if you can tell me how, I'll be able to do it. Once again, thanks for helping!

Modified by gsmrn

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8775 solutions 71729 answers

Hi gsmrn, oh, I thought the Google auth appeared in a little overlay, so I wasn't expecting a popup window. To get your add-on buttons to show up there, set Firefox to always show the full toolbar in popup windows using the following change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste open_f and pause while the list is filtered

(3) Double-click the dom.disable_window_open_feature.toolbar preference to switch the value from false to true, which prevents sites from hiding the main toolbar in popup windows

Then when you pop the window again, you'll have access to any relevant add-on buttons for content blocking extensions. (Some may slide onto the "overflow" menu -- the » icon.)

Hi gsmrn, oh, I thought the Google auth appeared in a little overlay, so I wasn't expecting a popup window. To get your add-on buttons to show up there, set Firefox to always show the full toolbar in popup windows using the following change: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''open_f''' and pause while the list is filtered (3) Double-click the '''dom.disable_window_open_feature.toolbar''' preference to switch the value from false to true, which prevents sites from hiding the main toolbar in popup windows Then when you pop the window again, you'll have access to any relevant add-on buttons for content blocking extensions. (Some may slide onto the "overflow" menu -- the » icon.)
Was this helpful to you?
Quote

Question owner

Hello jscher2000,

Thanks for your reply.

I enabled the full toolbar in the popup window using your instructions, and then tried disabling and enabling each of my extensions. I also tried disabling ALL my extensions and trying. However, nothing helped...

Hello jscher2000, Thanks for your reply. I enabled the full toolbar in the popup window using your instructions, and then tried disabling and enabling each of my extensions. I also tried disabling ALL my extensions and trying. However, nothing helped...
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8775 solutions 71729 answers

Sorry, I just noticed you mentioned having an extension named Google Container. That extension might cause a problem because everything Google is isolated in a separate container, making the site you want to log into unable to receive the hand-off from Google. Have you tested with that extension disabled?

Sorry, I just noticed you mentioned having an extension named '''Google Container'''. That extension might cause a problem because everything Google is isolated in a separate container, making the site you want to log into unable to receive the hand-off from Google. Have you tested with that extension disabled?
Was this helpful to you?
Quote

Question owner

Hi there,

I tried disabling the extension as well as re-opening the website I'm trying to login to in the Google Container (right-click on the tab, Re-open in Container > Google). Nothing worked..

Hi there, I tried disabling the extension as well as re-opening the website I'm trying to login to in the Google Container (right-click on the tab, Re-open in Container > Google). Nothing worked..
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8775 solutions 71729 answers

Chosen Solution

While in theory there might be a way to stick the sites that need Google Authentication into the Google Container so they can share credentials, you probably need to get advice from the extension's author on that. I think it would be easier to remove Google Container and restart Firefox.

While in theory there might be a way to stick the sites that need Google Authentication into the Google Container so they can share credentials, you probably need to get advice from the extension's author on that. I think it would be easier to remove Google Container and restart Firefox.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.