Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is your "help" page so .. lousey?

  • 1 reply
  • 1 has this problem
  • 12 views
  • Last reply by James

more options

Responses DO NOT HAVE A .. THING to do with the query!!! "Firefox prevented this site from asking you to install software on your computer." The answer is NOT in "Preferences". nhn

Modified by James

All Replies (1)

more options

https://support.mozilla.org/en-US/kb/unable-install-add-ons-extensions-or-themes#firefox:mac:fx49

The oldest version of Firefox the article is for is Firefox 49.0 as Firefox 48.0 is rather old and EOL now.

As you may know Firefox 49.0 and later requires OSX 10.9 or later. Also Firefox 45.9.0esr was actually the most up to date with security fixes for OSX 10.5, 10.7, 10.8 and not Fx 48.0.2.

Do please watch your language as this is a community.

Modified by James