Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mozilla acts as dead

  • 14 replies
  • 1 has this problem
  • 3 views
  • Last reply by Shadow110

more options

Hi. The last couple weeks mozilla stoped working while before was working perfectly and i explain. When I open mozilla and write an address it doesn' t load (just a white screen and not loading at all and so the refresh button is unactive and nothing works indicating loading like spining circle). Even when trying to open preferences it seems like trying to load with the circle spining but nothing happens and it doesn' t stop . I tried refresh, start with deactivated additives(sorry but i don t know the exact word) and unistall and again installing as mentioned but nothing. Thanks in advance.

All Replies (14)

more options

Hello,

what do you use the browser version?

Best regards, David-Walczysko Volunteer supporter

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Hi again. My version is 59.0.2 I tried whatever FredMcD but unfortunatelly still the same. Any other suggestions are welcome and if you need i can send the troubleshooting informations. Thank you all for your time...

more options

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network.

[56+] Type about:preferences#general<enter> in the address bar. Look for Network. +++++++++++++++++++++ Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first try No Proxy. If there is a problem, then try System Proxy.

more options

Just tried the above but when typing about:preferences#advanced it starts like loading(with the balls spinning in the bar) but nothing is happening. The same as I have mentioned before with just preferences. Only about:support opens..

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


If the above does not help,

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

more options

Unfortunatelly still the same although I tried everything you said. I have uploaded a screenshot that might help. After installation mozilla saws the small tab in the left which I cannot open and when I open a new tab it is still dead..

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

Still there..nothing happened even in secure mode...

more options

I called for more help.

more options

Thank you.. Waiting for more help.

more options

Hi, see if a different browser runs normally. Either way, try disabling your anti-virus/security program since a part of it may be interfering with Firefox. If it runs with it disabled, look at its settings and turn off anything browser related. If no browser runs, something on your PC is causing it - possibly malware, so see below for malware removal.

If Firefox still won't run but another browser does, close it, and try creating a new Profile Profile Manager - Create, remove or switch Firefox profiles


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Note that not all removal programs will detect all malware, so you may need to run several or all of them.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us. Thank you!

more options

Unfortunatelly nothing helped although I have run all the antimalware programs. I guess there is nothing else to do and I have to quit? Thanks for your time and suggestions..

more options

Hi, you can try this, should have been suggested long ago : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 60.0.1 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.