X
Tap here to go to the mobile version of the site.

Support Forum

Firefox console or firebug crashes browser localy

Posted

Environment: OSX v10.12.1 Firefox 49.0.2 (but problem showed up in 49.0) Firebug 2.0.18 (but problem occurs also for ff build-in console)

I work localy using npm and gulp, I am not an front-end technologies expert but I think gulp runs web localy. Everything work fine until I turn on firebug (or console Cmd+alt+K) then firefox crashes (using memory is like 9Gb). It happens only for localy page (gulp) and it happens every time. It started when I updated ff to ver 49.0. My co-workers working on ff also have this problem.

Environment: OSX v10.12.1 Firefox 49.0.2 (but problem showed up in 49.0) Firebug 2.0.18 (but problem occurs also for ff build-in console) I work localy using npm and gulp, I am not an front-end technologies expert but I think gulp runs web localy. Everything work fine until I turn on firebug (or console Cmd+alt+K) then firefox crashes (using memory is like 9Gb). It happens only for localy page (gulp) and it happens every time. It started when I updated ff to ver 49.0. My co-workers working on ff also have this problem.

Chosen solution

It seems that firefox 50.0 fixes the issue.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 15.020.20042
  • Version 5.41.3.0
  • Displays Java applet content, or a placeholder if Java is not installed.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

FredMcD
  • Top 10 Contributor
4398 solutions 61692 answers

For now, disable Firebug. Also contact its support.

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)

aboutcrashesFx29
For now, disable Firebug. Also contact its support. In the address bar, type '''about:crashes'''<enter>.''' Note:''' If any reports do not have '''BP''' in front of the numbers/letters, click it to submit them. '''The crash report is several pages of data.''' '''We need the report numbers to see the whole report.''' Using your mouse, '''mark''' the most '''resent 7 - 10''' crash reports, and '''copy''' them. Now go to the reply box below and '''paste''' them in. (Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.) ;[[Image:aboutcrashesFx29|width=500]]

Question owner

On the 'about:crashes' last report has date '24.09.2016 09:10' but the issue I have e.g. today. Maybe I did not make a precise, sorry, in my case crashes doesn't mean that browser turns off, crashes takes few sec (10 -20 sec) after that browser with firebug works fine. (this happen every time when I turn on firebug).

On the 'about:crashes' last report has date '24.09.2016 09:10' but the issue I have e.g. today. Maybe I did not make a precise, sorry, in my case crashes doesn't mean that browser turns off, crashes takes few sec (10 -20 sec) after that browser with firebug works fine. (this happen every time when I turn on firebug).

Modified by semafor

FredMcD
  • Top 10 Contributor
4398 solutions 61692 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

Unfortunately yes, problem still exists. Of course in this mode problem shows up after turn on Web console not firebug.

Unfortunately yes, problem still exists. Of course in this mode problem shows up after turn on Web console not firebug.
FredMcD
  • Top 10 Contributor
4398 solutions 61692 answers

Helpful Reply

I called for more help.

I called for more help.

Chosen Solution

It seems that firefox 50.0 fixes the issue.

It seems that firefox 50.0 fixes the issue.
FredMcD
  • Top 10 Contributor
4398 solutions 61692 answers

That's good to hear. Please flag your last post as Solved Problem so others will know.

That's good to hear. Please flag your last post as '''Solved Problem''' so others will know.