Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I want to play a game called Tanki online on mozilla however when i go on it tells me to download adobe flash player, i go on the game and it says same thing

  • 4 replies
  • 2 have this problem
  • 5 views
  • Last reply by FredMcD

more options

I want to play a game called tanki online on Mozilla but when i try and enter the game its says that i need adobe flash player 10.0.22.87 or higher. it shows a link that directs me to the download and i download without a problem, then when i go back on it, it says the same thing that i have to download it again. I have tried restarting my device. The first timeni tried downloading it and playing the game it worked but then 2 days later it said that i have to download. i hope you can help. thanks

All Replies (4)

more options

After the download, you need to run the installer.

more options

Will I find the installer in my downloads?

more options

I had the same problem. The problem went away after I updated my FF to the latest version. Currently I am on 42.0 and flash works.

You could give this a try and see if that fixes the problem.

more options

If you downloaded a file, it should be in your Downloads Folder. If you are not sure, press <Control> J to open the Download Manager. Find the entry, right click on it.