Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to remove entries from the new auto-complete ?

  • 4 replies
  • 1 has this problem
  • 951 views
  • Last reply by FredMcD

more options

Firefox 33 came with a new auto-complete for forms. Unfortunately I cannot seem to delete the auto-complete suggestions once they have been stored. This is necessary functionality for things like mis-spelled words, where you want to get rid of the old (bad) auto-complete entry, or where username was changed on a form, etc. With the older versions, you could just press delete key on highlighted auto-complete suggestion and it would be removed, but this functionality does not work with the new auto-complete. The only workaround I have been able to find so far is to clear the browser history for the last 1 hour, but that wipes out good history as well as the error.

Chosen solution

It looks like the formhistory.sqlite file is the problem

Deleting the file restores the original functionality

Read this answer in context 👍 0

All Replies (4)

more options

There are two things you can do.

  • 1

Type about:preferences#privacy <Enter> in the address bar. The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Form and Search History, and set the others as you wish.


  • 2

Whenever one of the bad entries shows up == STOP == Using the arrow keys, highlight that entry, and press Delete.

more options

Hello,

Can you try Firefox Safe Mode and see if you have the same problem there? Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Chosen Solution

It looks like the formhistory.sqlite file is the problem

Deleting the file restores the original functionality

more options

Great Work.