Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox UI is slow when typing or selecting text (after 33.0 update)

more options

After the 33.0 update, I noticed that typing or backspacing in any field on a webpage or even in the Firefox address bar is slow to echo, about a 1 second lag. Also, selecting typed text (to delete it, etc.) by a quick click-drag doesn't select the whole area, yet when I click in the dialog to deselect, the portion that wasn't showing as selected at first, becomes selected for a moment before the whole string selection hilite disappears.

This makes the browser very cumbersome to use.

This appears to be new to 33.0. I tried resetting Firefox, but that didn't fix the problem. No issue in IE 11.0, so I don't think its malware. I also keep all s/w up-to-date, and run avast/zonealarm for security. I've never had a malware infection on this machine. Win7 Home Premium 64-bit, 8GB RAM. Resource utilization is low, so no out-of-control processes.

I did apply the latest Microsoft "Patch Tuesday" updates on 10/15, the same day that I updated Firefox. This may complicate the diagnosis. But again, IE wasn't affected, so how is the Firefox UI different for basic keyboard/display I/O?

If there's an easy way to "downgrade" to the prior 32.0.3 revision, I could try that to confirm. Please help!

Modified by mozgbl37

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

Read this answer in context 👍 0

All Replies (8)

more options

@hairycactus:

Your last post got me thinking regarding the default state of layers.offmainthreadcomposition.enabled. Retracing my steps, I realize I never looked at this before cor-el mentioned it here. It appears from my posts that I probably updated to 33.0.1 before first looking at it. I also have noticed that the "whats new" is not clear on which [minor] rev certain "new" items appeared, so I looked at these pages for 32.0.3 thru 33.0.2. OMTC being enabled by default is indeed mentioned on the pages for 33.0, 33.0.1, and 33.0.2, but not for 32.0.3.

So I conclude that this change of default starting with 33.0 is what caused the lag problem to appear (with h/w accel already ON). Bugzilla's discussion of the blocklisting was unclear to me about what driver versions were blocked with what releases--that looks like a work in progress. So I believe that my hardware/OS/driver combo wasn't blocked, or not the right parameters were blocked, when the OMTC default was changed, thus exposing the lag problem.

An aside here for someone--does a block silently override the displayed about:config parameters, or does it change the appearance (i.e. default, or force value) of parameter values in about:config?

You also asked about my driver being Dell or generic, as reported by Catalyst Control Center. My Driver Packaging Version was reported as:

   8.69-091211a-093684C-Dell

so I suppose it is customized in some manner. I don't think I'll risk updating to either a Dell driver for a more recent machine, or a generic driver, unless I run into more problems. Thanks for your suggestions, though.

@all: Recent posts 34-38 in Bugzilla 1089183 indicate that the lag problem may have to do with screen updates (cursor blink), so if we're lucky, maybe there will be a fix that would allow OMTC to be re-enabled for those of us stuck with old drivers. Here's hoping.

more options

1) @ mozgbl37: So did you try adjusting the cursor blink rate ? Any effect on the lag in FF 33.0.2 ? For my case in FF 33.0, I also experienced severe lag in page scrolling & tab switching (with just 2 tabs open). Not sure how cursor blink rate might be implicated in these though.

Thanks for reviewing the release notes for FF 32.0.3 – 33.0.2. I didn't have browser lag trouble before updating to FF 33.0 (OTMC = enabled by default for the first time apparently).

I'd just browsed the release notes for the immediate prior versions (29.0, 29.0.1, 32.0.1, 32.0.2) ... OTMC is also not mentioned at all. I assume it is disabled by default, as is the case for FF 32.0.3 (which I'm using).

Interestingly though, based on my current trials in FF 32.0.3, HWA = on (default) + OMTC = disabled (default) or enabled (trial) has no apparent positive or negative effect. Either way, there is neither lag nor any discernible positive impact on browser performance.


2) Separately, I noticed that the following is listed as 'Fixed' in FF 32.0.1, 32.0.2, 32.0.3: "Stability issues for computers with multiple graphics cards".

Since dual-GPU systems are blacklisted, does the above fix still apply in FF 33.0 onwards ? If not, in conjunction with a possible OTMC issue with older graphics drivers, I suppose that's why FF 33.0 is not merely slow, but rendered unusable in my (double-whammy) case.


3) Checking my crash reports (which seem to be all flash related), there are:-

  • 5 items for 2010 (Nov – Dec)
  • 3 items for 2011 (Jan-Feb; zero crash between Mar 2011 & Mar 2012)
  • 1500 items (Apr 2012 – Aug/Sep 2014)

I didn't change my graphics card or graphics driver during the aforementioned period. Although FF was crashing periodically (due to non-responsive Adobe flash), the browser doesn't lag like FF 33.0.

more options

More FF 33.0 users reporting odd text-related lag/ problems & proposed workarounds (either turning HWA off or running in Safe Mode) that sound identical or very similar to those already discussed here.

If anyone has a MozillaZine account, one can perhaps enquire what GPU & drivers the said users have.

(OT: Why can't Mozilla let public users have a single registered account that works in all Mozilla public channels ?)

more options

@hairycactus:

1) Your test of 32.0.3 with h/w accel ON and OMTC enabled ==> no lag invalidates my theory that simply enabling OMTC exposed a latent problem. There must have been something else that changed at 33.0.

Unfortunately, I don't have the time to do a regression test myself, nor to investigate the correlation to blink rate. I've already spent more time on this than I can afford, and need to get back to "real" work. Geez, why is it always that way?! :-) Thankfully, the OMTC disable workaround works for me, and that will have to do for now.

Good luck with your "double-trouble" setup. I wish that manufacturers that *must* have a custom driver would bother to update them <grr>!

more options

Toshiba notebook: I updated the graphics driver using http://support.amd.com/en-us/download/auto-detect-tool (instead of using the toshiba website or the windows 7 search for updates) . => is ok.

ATI Mobility Radeon HD 4500/5100 Series driver 8.970.100.1100 (before: 8.653.0.0) driver date: 4-29-2013

hardware acceleration ON gfx.direct2d.disabled = false layers.prefer-d3d9 = false layers.offmainthreadcomposition.enabled = true

Modified by bigst

more options

Okay i'm not the brightest one with computers but this lag is kinda pissing me off. Is there a solution to the problem with the "layers.offmainthreadcomposition.enabled = false" that is dummy proof? i.e. could someone offer me a walkthrough. I'm trying to find the preferences page but as I browse the options, I can't find anything. Also, since i'm Dutch and my browser settings are Dutch, it doesn;t make finding an option any easier.

more options

Sounds like you are safest using the menu:

Use the traditional (upper left) menu "Tools", or open the new-style menu (right end of address/toolbar); now click "Options". Click the "Advanced" section, then the "General" tab; in the "Browsing" section, uncheck "Use hardware acceleration when available". Click "OK", then for good measure, close Firefox, then reopen it.

This solved the lag problem for me, and hasn't slowed the browser down noticeably on sites I typically visit.

more options

Thanks a lot! this seems to have solved the problem.

  1. 1
  2. 2