Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 30.0 / Win7Pro. "new tab" opens in Yahoo - not Google. Now have "untrusted" certificate issues. Please help! Thank you in advance.

  • 1 reply
  • 2 have this problem
  • 3 views
  • Last reply by jscher2000

more options

Google.com is my home page; new searches open in Google ok; "new tab" is redirected to Yahoo search page; tried help/restart with ad-ons disabled, now my computer says EVERY web site is "untrusted" ....

All Replies (1)

more options

(1) Certificate Issue

Did you use Firefox's Reset feature, and then the certificate errors started after that?

For one of those pages, could you expand the "Technical Details" section and look at the specific error description and post it here?

(2) New tab takeover

The most likely cause for this change is a bad add-on that rode along with some free software.

I suggest starting here:

Open Windows Control Panel, Uninstall a Program. Click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here.

Then, in Firefox, open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible).

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Finally, you can use the following "one step" extension to set your new tab page back to the normal Firefox thumbnail page, set your home page to the built-in Firefox home page, and set your search back to Google: https://addons.mozilla.org/firefox/addon/searchreset/

Or if you want to just change the new tab page, here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter the desired value:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?