Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox installer extracts, but does not install

  • 10 replies
  • 13 have this problem
  • Paskiausią atsakymą parašė ribbony

more options

I was happily using Firefox & though it bombproof. Yesterday I tried to update, the update went through the process right until the end and then said something along these lines: *****installation interrupted****

So far I have tried these things: Offline installer, it just extracts then does nothing. Safe mode, then try the installer, same thing. Tried to uninstall firefox and delete anything on the computer that was firefox related. Tried rebooting of course. Kept trying the installer several times, also tried version 26. Run glaries & Iobit registry and system cleaners. Tried some solutions mentioned on this forum such as the "temp" folder tweeks. Still no progress.

I really really like Firefox and do not want to have to use IE.

Please help :)

All Replies (10)

more options
  1. Doing an update doesn't involve installation. Firefox has an update system which can be triggered via Help > About Firefox
  2. Try using the full installation package from here:

more options

Thanks for the reply.

After the installer failed, I did download the full offline install exe, the same as the one on your link. It did not work and is the one that I keep trying to use.

I usually use the internal updater in Firefox, but I also download an offline install package as I install it on a computer that is on a very limited data connection.

So, I have not moved forward as yet. The problem is still there.

Something is stopping the installer putting files into the Temp folder, as when I look in there after the unpacking, there is a new folder but it is empty.

Modified by ribbony

more options

I also noticed that Thunderbird will not install as well as Firefox, yet other programs such a Glaries utilities will install.

I will just about try anything, except a complete reinstall of windows. I would shift to Google Chrome before doing that :(

more options

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

I just tried that using F8 with networking, I had previously been doing just plain F8.

It made no difference, still will not install.

more options

Do a malware check with several malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Crikey !

Thats a lot of AV & SW programs. OK, will do it latter when I go to the library where they have a fast wifi connection for all that downloading & updating.

Will let you know the results.

The AV program I use is Bitdefender Internet Security.

more options

Another question:

Seen there has been some similar issues where Adobe programs have impacted on the installations of Firefox. Is it wort trying to uninstall all the Adobe software that I have:

Adobe Flash Player 10

Adobe Flash Player 12 plugin

Adobe Air


Modified by ribbony

more options

I wonder why you have two Flash plugins... I only have one.

more options

AaaaHa. I might have solved the problem.

Here is what I did:

I right clicked on the "firefox setup 27.0.1.exe file". extracted the contents into a new folder. the setup.exe file in the root would not open, so I copied that with a different name into the same folder. That renamed file would open and install firefox !

My guess is that that is something (malware probably) is not allowing me to run any file called "setup.exe", I tried another file of that name in another folder for a totally different program and it also would not open.

A program may have tagged "setup.exe" and stopped it from working as it has labelled it a do not let operate, perhaps the AV or Iobit, etc ?

A program called "autoreactivator.exe" was occasionally going haywire in the task manager, it was opening mutiple copies of itself then closing them a second ot two apart. Not sure if it was relevant, but mention it for reference.

I will post more latter if I can narrow down the cause.

Modified by ribbony