Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Solved: version 7 worse than version 6. gone back to version 5. Experimenting with Chrome.

  • 3 replies
  • 12 have this problem
  • 5 views
  • Paskiausią atsakymą parašė cdrmisc01

more options

Solution: Backed up all bookmarks first. Used Revo for clean uninstall INCLUDING all personal information. Prior uninstall left personal information intact. Installed V7 and backup bookmarks and prior addons. Assume V6 and V7 don't upgrade well. Had I not considered KeyScrambler a necessary addon, I would be using Chrome now since it appears to also work extremely well with numerous addons.



I just loaded V7 and tested it to see if it repaired problems I had with V6. It did not. My test sites are landsend.com and tigerdirect.com. They either don't load or only load partially, then they just freeze. Clicking 'reload' does not help , they freeze again. Other sites operate very slowly like my internet connection is about 5% of what it actually is. V5 works fine and so have other prior versions. Somebody really messed this up.

My caches are clean. I use sandboxie and clean everything after each session close automatically. CCleaner is also used daily to keep bits outside of sandboxie clean. XP SP 3 2GB with all updates. The same problems exist if I run firefox outside of sandboxie, therefore sandboxie is not an issue.

the V7 memory feedback reporting ability was selected but there does not appear to be a way to actually use it.

Your feedback page also has issues. When I click the send button, nothing happens. Thus my need to contact you like this.

9-29-2011 update: Tried clean uninstall using Revo, then V7 reload and encountered same deficiencies. Upgraded back to V5 and problems went away, again. Experimenting with Chrome and experiencing no problems. Many addons available identical to Firefox addons. Sandboxie provides excellent support. Safe start with all addons disabled had no effect on V7 problems.

Solution: Backed up all bookmarks first. Used Revo for clean uninstall INCLUDING all personal information. Prior uninstall left personal information intact. Installed V7 and backup bookmarks and prior addons. Assume V6 and V7 don't upgrade well. Had I not considered KeyScrambler a necessary addon, I would be using Chrome now since it appears to also work extremely well with numerous addons. ----------------------------------------------------------------------- I just loaded V7 and tested it to see if it repaired problems I had with V6. It did not. My test sites are landsend.com and tigerdirect.com. They either don't load or only load partially, then they just freeze. Clicking 'reload' does not help , they freeze again. Other sites operate very slowly like my internet connection is about 5% of what it actually is. V5 works fine and so have other prior versions. Somebody really messed this up. My caches are clean. I use sandboxie and clean everything after each session close automatically. CCleaner is also used daily to keep bits outside of sandboxie clean. XP SP 3 2GB with all updates. The same problems exist if I run firefox outside of sandboxie, therefore sandboxie is not an issue. the V7 memory feedback reporting ability was selected but there does not appear to be a way to actually use it. Your feedback page also has issues. When I click the send button, nothing happens. Thus my need to contact you like this. 9-29-2011 update: Tried clean uninstall using Revo, then V7 reload and encountered same deficiencies. Upgraded back to V5 and problems went away, again. Experimenting with Chrome and experiencing no problems. Many addons available identical to Firefox addons. Sandboxie provides excellent support. Safe start with all addons disabled had no effect on V7 problems.

Modified by cdrmisc01

All Replies (3)

more options

If you mean the Sad or Happy face feedback page, it's actually a good thing that you went here because otherwise none would have responded. :)

Your sites load completely fine for me using 6.0.2 - have you tried this on another computer, or with a new Firefox profile? It could be either some strange setting or an add-on that interferes, but testing with a new profile (or another computer) would make that easy to figure out.

more options

Your Sites load fine with me using V7. Sounds like an internet connection problem unrelated to Firefox. Have you tried pinging these sites from a command line?

Modified by johneilbeck

more options

Yes, I also have a laptop with windows 7 and FF v7 works well. So did V6. My desktop running XP SP3 has the issues.

I appreciate your reply but I don't want to become a volunteer employee for mozilla by spending hours on my PC getting their program to work. My PC has been configured in the way it is for years without problems with FF until V6 came along. Mozilla messed up. I like FF add on so I am not anxious to invest a lot of time in finding another browser and configuring it as FF is. But I will if mozilla can't get with the program.

I just want to upgrade and go, just like I always have in the past. I won't spend hours just trying things. I have better things to do with my life.

Plus, many others reported similar problems with various sites with V6.

AS I stated, V5 and prior versions work well. I reloaded V5 so I can experience a stable system.

Modified by cdrmisc01