Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot type in address and connect because screen says: "Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

  • 10 replies
  • 1 has this problem
  • 71 views
  • Paskiausią atsakymą parašė wdb154

more options

How can I get around a message: "Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

   "This problem can sometimes be caused by disabling or refusing to accept cookies."

My bookmarks work, but not typing in.

How can I get around a message: "Firefox has detected that the server is redirecting the request for this address in a way that will never complete. "This problem can sometimes be caused by disabling or refusing to accept cookies." My bookmarks work, but not typing in.

Chosen solution

Hi Bill, are you intending that your searches be done on Yahoo? If not, you could investigate why you are getting an error from Yahoo search rather than getting a page from your intended search site.

First, is your default search engine set to your intended site on the Settings page? See: Change your default search settings in Firefox.

If that keeps changing to Yahoo (or an unknown "partner" of Yahoo), or if that is being ignored, a common reason would be an add-on hijacking your searches. Here's how:

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions Yahoo, or search, or which looks suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

What if this list is blank/missing/inaccessible?

Sometimes bad add-ons interfere with using the Add-ons page to remove them. So to disable all your add-ons temporarily while you clean up, you can restart Firefox in its Safe/Troubleshoot Mode. Here's how:

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Can you regain control of your searches?

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (10)

more options

It's strange that the identical address could work if it's a bookmark but not through the address bar. I can't think of an explanation for that, unless Firefox is sending the address to a search site. Does the address bar show that the error is on the site you expect to see there, or on a different site?

more options

I took a bookmark, copied it and pasted in search and did not get the problem. I will now try typing that same address in ans see what happens.

more options

Okay, reopened Mozilla and typed in that bookmark name, hit enter, and got the old "redirecting notice." I am totally illiterate as this so bear with me..

more options

http://kb.mozillazine.org/The_page_isn't_redirecting_properly Not Redirecting properly = cookies


https://support.mozilla.org/en-US/kb/websites-say-cookies-are-blocked-unblock-them


Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

wdb154 said

Okay, reopened Mozilla and typed in that bookmark name, hit enter, and got the old "redirecting notice."

As an example, let's say you type mozilla.org in the address bar and submit that. If you get the error message, what is the address showing in the address bar at that point?

more options

I cannot get to any of the sites which were set forth in jscher2000. Going to try pasting into Chrome to get to them

more options

jscher2000

   Sorry I had to leave the discussion. I am back. 
  Review: I type in something I want to find -- example "North Dakota" W hen the screen comes up it says: 	                 "The page is not redirecting properly. Firefox has detected that the server is redirecting the request for this action in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies."
   The search bar says                           https://search.yahoo.com/yhs/search?hspart=trp&hsimp=yhs-001&grd=1&type=Y143_F163_201897_102620&p=north+dakota
   Settings on Mozilla say it is my default browser
   Mozilla also doe not have any proxy settings.

Does any of that help? If you are still there, thanks. Bill

more options

I see I did not understand your earlier comment. entered mozilla.org no error notice and got https://www.mozilla.org/en-US/

more options

Chosen Solution

Hi Bill, are you intending that your searches be done on Yahoo? If not, you could investigate why you are getting an error from Yahoo search rather than getting a page from your intended search site.

First, is your default search engine set to your intended site on the Settings page? See: Change your default search settings in Firefox.

If that keeps changing to Yahoo (or an unknown "partner" of Yahoo), or if that is being ignored, a common reason would be an add-on hijacking your searches. Here's how:

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions Yahoo, or search, or which looks suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

What if this list is blank/missing/inaccessible?

Sometimes bad add-ons interfere with using the Add-ons page to remove them. So to disable all your add-ons temporarily while you clean up, you can restart Firefox in its Safe/Troubleshoot Mode. Here's how:

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Can you regain control of your searches?

more options

jscher2000 --- THANK YOU! I am 80, and have a hard time negotiating any part of the web. But your last note did it. Problem gone. Thanks again. Bill Bontrager