Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opens all URLs except Google. It throws up Error 404.

  • 3 replies
  • 16 have this problem
  • 45 views
  • Paskiausią atsakymą parašė cor-el

more options

"Google 404. That's an error. The requested URL/cgi-bin/redirect.ha was not found on this server. That's all we know."

I can open all other sites, Facebook, CNN, my bank, credit cards, etc. But Google will not load. I get the above message every time.

"Google 404. That's an error. The requested URL/cgi-bin/redirect.ha was not found on this server. That's all we know." I can open all other sites, Facebook, CNN, my bank, credit cards, etc. But Google will not load. I get the above message every time.

Chosen solution

Opps, sorry about the confusion. I totally missed that.

Try to disable IPv6 (check for other possible causes as well).

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
Skaityti atsakymą kartu su kontekstu 👍 3

All Replies (3)

more options

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

I forgot to mention that I am using a Mac and that Google will open in Safari, but not in Firefox.

more options

Chosen Solution

Opps, sorry about the confusion. I totally missed that.

Try to disable IPv6 (check for other possible causes as well).

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Modified by cor-el