Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mulongo oyo etiyamaki na archive. Tuna motuna mosusu soki osengeli na lisalisi

Netflix videos won't play smoothly. (on a Mac with an external Monitor)

  • 4 biyano
  • 15 eza na bankokoso oyo
  • 1631 views
  • Eyano yasuka ya scottmartin

more options

Netflix videos don't seem to play correctly. I'm using a clean installation of Firefox 25 and Silverlight has been reinstalled and is working. However, every time I try to play a movie on Netflix it plays back choppy. I'm running on a late 2008 15 MacBook Pro hooked up to an external monitor. I'm visually impaired so unhooking the monitor is not an option, and the videos play just fine in Safari, Chrome, and Opera.

Thanks for any help, Scott

All Replies (4)

more options

Have you tried clearing your cache and cookies in Firefox?

To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Hope this helps! If you continue to have issues please report back.

Thank you.

more options

I mentioned in my original post that it was a clean install, so I didn't have any history or left over settings. However, I did give your suggestion a try, and I'm still experiencing the problem. I'm honestly baffled by this.

Thanks, Scott

more options

Oh yeah good point. Yeah that is really weird! Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

If that doesn't fix it then I'm lost as to why it's doing this. If you want to you can also contact Netflix here: https://help.netflix.com/help

more options

Thank you for the help, but unfortunately I'm still experiencing the problem. I try coming back to Firefox every time there is a major update hoping that it will work this time. I just can't seem to narrow down what is causing it.

Thanks, Scott