Firefox에서 Java, Silverlight, Adobe Acrobat 등의 플러그인이 동작하지 않는 이유

2017년 3월 7일 Firefox 버전 52부터 NPAPI 플러그인은 Adobe Flash Player를 제외하고 더 이상 지원되지 않습니다. 컴퓨터에 설치되어 있더라도 Java, Microsoft Silverlight, Adobe Acrobat과 같은 플러그인들은 더 이상 Firefox에서 작동하지 않습니다.

Flash 지원 종료: Adobe와 다른 브라우저들과 마찬가지로, Firefox는 Flash 지원을 2020년 연말에 종료할 것 입니다종료하였습니다. 추가 정보가 필요하다면 Adobe Flash에 대한 지원 종료를 참조하십시오.

참고: Widevine CDMOpenH264 Video Codec는 NPAPI 플러그인이 아니기 때문에 계속 지원합니다.

지난 몇 년간 Firefox는 다양한 웹API들을 운영해왔습니다. 그렇기 때문에 웹사이트들은 플러그인 없이도 같은 내용을 제공할 수 있을 것이며 사용자는 대부분의 사이트에서 별다른 공지없이 이전과 같은 사용자경험을 즐길수 있습니다.

Firefox가 이런 변경을 한 이유가 무엇인가요?

인터넷은 정적인 페이지 뿐만아니라 동영상, 음악, 게임과 같은 동적인 웹사이트들로 가득 차 있습니다. 특히 Flash와 같은 NPAPI 플러그인들은 페이지를 상호작용이 가능하도록 만들어왔지만, 동시에 브라우저를 느리게 만들고, 보안을 약화시켰으며 브라우저의 충돌 가능성을 증가 시켰습니다.

지난 몇 년간, Firefox는 이러한 플러그인들을 대체하기 위하여 많은 노력을 해왔으며, 그 결과가 Web API입니다. Web API는 사용자의 인터넷 보안과 안정성, 성능하락없이 NPAPI 플러그인의 기능을 대체할 수 있도록 만들어졌습니다.

이전에는 이러한 Web API가 준비되지 않았지만, Firefox는 플러그인의 로드를 클릭하여 활성화하는 방식으로 전환하기 시작했습니다.

현재는 많은 사이트들이 Web API를 채택하였고, 여러분들이 즐겨찾는 대부분의 페이지들은 낡고 안전하지 않은 플러그인의 사용없이 즐길 수 있습니다. Firefox는 Google Chrome이나 Microsoft Edge와 같은 다른 최신 브라우저들과 함께 NPAPI 플러그인에 대한 지원을 중단하고 있습니다.

오래된 버전의 Firefox를 사용하는 경우에는 어떻게 합니까?

가능하다면 Firefox를 최신 버전으로 업데이트하는 것을 권장합니다.

Firefox의 모든 업데이트에는 인터넷에서 보안을 유지하는데 도움이 되는 개선 사항을 포함하여 중요한 수정 및 개선 사항이 포함되어 있습니다. Firefox를 포함하여 오래된 버전의 브라우저를 사용하는 것은 개인 데이터는 물론 컴퓨터까지 위험에 빠뜨립니다.

Firefox는 추가 플러그인이 필요한 기능을 지원하도록 확장되었습니다. 또한 플러그인은 자동으로 최신 상태로 유지되며 보안 강화를 위해 차단 목록을 통해 관리됩니다. 따라서 Firefox를 최신 버전으로 업데이트 하는 것만으로 모든 것을 최신 상태로 유지할 수 있습니다.

이 문서가 도움이 되셨습니까?

잠시만 기다려 주십시오...

문서 작성 및 변경에 도움 주신 분들

Illustration of hands

도움 주기

전문 지식을 성장시키고 다른 사람들과 공유세요. 질문에 답하고 지식 기반을 개선할 수 있습니다.

자세히 살펴보기