X
Tap here to go to the mobile version of the site.

Support Forum

How to enable an old version of flash

Posted

I'm running Ubuntu 12.04, firefox 25 on a older machine with socket A CPU. It does not support SSE2, thus Flash 11.2 is not an option. I installed 11.1.r102, but Firefox won't let me used it because it detects it's an old version. Chromium works fine though.

So how do I force Firefox to use the version of flash I want it to use??

I'm running Ubuntu 12.04, firefox 25 on a older machine with socket A CPU. It does not support SSE2, thus Flash 11.2 is not an option. I installed 11.1.r102, but Firefox won't let me used it because it detects it's an old version. Chromium works fine though. So how do I force Firefox to use the version of flash I want it to use??

Additional System Details

Installed Plug-ins

  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The Totem 3.0.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • Shockwave Flash 11.1 r102

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

AliceWyman
  • Moderator
240 solutions 2597 answers

Mozilla's Blocklist prevents older Flash versions from running. See

...which links to

  • Bug 854550 - CTP request: Flash<=11.1* for Linux, excluding 10.3.183.*

Are you still able to activate the outdated Flash plugin when you're on a page that requires the plugin? Read Why do I have to click to activate plugins? for details on how to do that.

Note: You may need to go to the Firefox (Tools) Add-ons -> Plugins list and change the Flash plugin from "Never activate" to "Ask to activate".

If that doesn't work then you could delete (or rename) the blocklist.xml file located in the Firefox profile folder and then set extensions.blocklist.enabled to false in about:config . Ref:

Mozilla's Blocklist prevents older Flash versions from running. See *https://addons.mozilla.org/en-US/firefox/blocked/p332 ''Adobe Flash for Linux 11.0 to 11.1.* (click-to-play) has been blocked for your protection'' ...which links to *[https://bugzilla.mozilla.org/show_bug.cgi?id=854550 ''Bug 854550''] ''- CTP request: Flash<=11.1* for Linux, excluding 10.3.183.*'' Are you still able to activate the outdated Flash plugin when you're on a page that requires the plugin? Read [[Why do I have to click to activate plugins?]] for details on how to do that. '''Note:''' You may need to go to the Firefox (Tools) Add-ons -> Plugins list and change the Flash plugin from "Never activate" to "Ask to activate". If that doesn't work then you could delete (or rename) the '''blocklist.xml''' file located in the Firefox [[Profiles|profile folder]] and then set '''extensions.blocklist.enabled''' to '''false''' in about:config . Ref: *http://kb.mozillazine.org/Extensions.blocklist.enabled *http://kb.mozillazine.org/Blocklist.xml *http://kb.mozillazine.org/About:config

Modified by AliceWyman