Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot open https://mail.yahoo.com

  • 8 replies
  • 2 have this problem
  • 87 views
  • Last reply by FredMcD

more options

When browsing to mail.yahoo.com I get the following error: Secure Connection Failed

An error occurred during a connection to www.sportsmansoutdoorsuperstore.com. PR_CONNECT_ABORTED_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.
When browsing to mail.yahoo.com I get the following error: Secure Connection Failed An error occurred during a connection to www.sportsmansoutdoorsuperstore.com. PR_CONNECT_ABORTED_ERROR The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.

All Replies (8)

more options

That is weird, because there's no obvious connection between Yahoo Mail and the sporting goods store. Or at least I can't think of one.

Connection Settings

Could you make the following updates to your Firefox connection settings to see whether they make any difference -- on the Settings page (either):

  • "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click to open the Connection Settings.

(1) Proxy

Select "No proxy"

(2) DNS

At the bottom of the dialog, check whether you have DNS over HTTPS enabled. If not, check the box for DNS over HTTPS.

If it has been changed, set your provider to Cloudflare (default).

Then click OK to save the change(s).

Any difference?

Malware Scans

In case this interception is occurring at a system level, you could run some malware scanning/cleaning tools other Firefox users have found helpful. Those are listed in the following support article: Troubleshoot Firefox issues caused by malware.

more options

My bad. I have several sites giving the asme error, one of which is the sportssuper store. The actual error is: Secure Connection Failed

An error occurred during a connection to mail.yahoo.com. PR_CONNECT_ABORTED_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

No Proxy was already set, and DNS over HTTPS was checked and Cloudflare selected.

When I clicked on the Malware link above and then selected https://www.malwarebytes.com/products/malwarebytes_free/ to scan for malware, the attached image is my result.

more options

You may need to download the scanners using a different browser for now.

more options
more options

https://appuals.com/pr-connect-reset-error/ The PR_CONNECT_RESET_ERROR issue is encountered when the user tries to use Mozilla Firefox to connect to a website server with the HTTPS protocol but the request gets denied. This error message essentially means that the peer or some middlebox in between (most likely a firewall) is terminating the connection forcibly.

more options

Chosen Solution

more options

Thanks FredMcD, this fixed it from the first link you provided:

IPv6

Firefox supports IPv6 by default, which may cause connection problems on certain systems. To disable IPv6 in Firefox:

   Type about:config in the address bar and press Enter.
   A warning page may appear. Click Accept the Risk and Continue to go to the about:config page.
   In the Search field, enter network.dns.disableIPv6.
   In the list of preferences, click the Toggle Fx71aboutconfig-ToggleButton button next to network.dns.disableIPv6 to set its value to true.
more options

Glad to help. Safe Surfing.