Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Can’t Open This Page To protect your security, www.youtube.com will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

  • 7 replies
  • 1 has this problem
  • 26 views
  • Last reply by cor-el

more options

My web page (HTML) has one embedded video (my own, uploaded to YouTube). The embedding code line is ...

  • <iframe title="YouTube video player" width="480" height="390" src="https://youtu.be/pj3d3fOlr-A" frameborder="0" allowfullscreen></iframe>

  • and the error/warning I get when I open my page isL

    Firefox Can’t Open This Page To protect your security, www.youtube.com will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

    How do I fix this issue, please? Thank you Regards Fred James

    Attached screenshots

    All Replies (7)

    more options

    Try this embed code:

    <iframe width="480" height="390" src="https://www.youtube.com/embed/pj3d3fOlr-A" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

    Modified by cor-el

    Helpful?

    more options

    Sorry ... did not work for me ... it changed the size of the place for the embedded video, but still have the same error. Regards Fred James

    Helpful?

    more options

    Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

    You can also attach a screenshot that shows the iframe code in the Inspector.

    It works for me as you can see in the screenshot (I used the Inspector to inject the code in that reply).

    Helpful?

    more options

    If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

    Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for related messages about blocked content.

    Helpful?

    more options

    You can try these steps in case of issues with webpages:

    You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

    • hold down the Shift key and left-click the Reload button
    • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
    • press "Command + Shift + R" (Mac)

    Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

    "Remove the Cookies" for websites that cause problems:

    • Settings -> Privacy & Security
      Cookies and Site Data: "Manage Data"

    "Clear the Cache":

    • Settings -> Privacy & Security
      Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

    Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

    • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
    • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

    Helpful?

    more options

    To your first reply: Inspector shows code for error, but I have added a screen shot of the section of code in question

    To your second reply: Can you confirm that the embedded video works properly for you when viewing my page (fredjame.net), please?

    I am currently testing on Firefox 78.11.0esr (64-bit), IceApe 2.49.4, and Chromium 89.0.4389.128

    Firefox and IceApe are both Mozilla and act the same, while on Chromium the embed is a gray area with a sad faced page icon in the middle and the message "www.youtube.com refused to connect" appears when the mouse travels across the gray area.

    Helpful?

    more options

    The video doesn't work with the code you posted above. You need to change the src="https://youtu.be/pj3d3fOlr-A" as that wants to embed the YouTube website on the page you need to replace the iframe code on the page with the iframe code I posted above with src="https://www.youtube.com/embed/pj3d3fOlr-A" to make it possible to embed the YouTube player on a webpage.

    Helpful?

    Ask a question

    You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.