X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 67.0 (64 bit) can no longer create a desktop shortcut to a website

Posted

Until I updated the browser this morning I would normally:

    Click the icon on the left of the address bar (where the URL is shown).
    While still holding the mouse button down, move the pointer to the desktop, then release the mouse button. The       shortcut will be created.

This no longer works. Any suggestions. Using Windows 7.

Until I updated the browser this morning I would normally: Click the icon on the left of the address bar (where the URL is shown). While still holding the mouse button down, move the pointer to the desktop, then release the mouse button. The shortcut will be created. This no longer works. Any suggestions. Using Windows 7.

Chosen solution

Thanks to each of you for your suggestions. I had disabled add-ons, tried key combos and still had the issue. Interestingly two reboots and a day later everything works as it should. Go figure!

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

FredMcD
  • Top 10 Contributor
4222 solutions 58926 answers

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157293 answers
Does it make a difference if you hold Ctrl or Shift ? See also: * QuickCut https://addons.mozilla.org/firefox/addon/quickcut/ * https://support.mozilla.org/en-US/kb/create-desktop-shortcut-website
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8634 solutions 70616 answers

I'm sure it's no consolation, but when I drag the "i-in-a-circle" icon on Windows 10, it is still working the same as previous versions (the mouse pointer doesn't show in the screenshot, unfortunately):

I'm sure it's no consolation, but when I drag the "i-in-a-circle" icon on Windows 10, it is still working the same as previous versions (the mouse pointer doesn't show in the screenshot, unfortunately): <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-24-14-20-15-e5e290.png">
Was this helpful to you?
Quote

Chosen Solution

Thanks to each of you for your suggestions. I had disabled add-ons, tried key combos and still had the issue. Interestingly two reboots and a day later everything works as it should. Go figure!

Thanks to each of you for your suggestions. I had disabled add-ons, tried key combos and still had the issue. Interestingly two reboots and a day later everything works as it should. Go figure!
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4222 solutions 58926 answers

As long as the problem is gone. Please flag your last post as Solved Problem so others will know.

As long as the problem is gone. Please flag your last post as '''Solved Problem''' so others will know.
Was this helpful to you?
Quote

Question owner

Problem solved, Thank you.

Problem solved, Thank you.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.