Search Support

This thread was closed and archived. Please ask a new question if you need help.

HOW DO I TURN OFF SSL CERTIFICATES.

  • 4 replies
  • 14 have this problem
  • 346 views
  • Last reply by cor-el

more options

It's NO LONGER in the Options menu. EVERY PAGE I try to get to is freaking out over certificates.

TELL ME HOW TO TURN IT OFF NOW THAT YOU REMOVED THE OPTION TO.

All Replies (4)

more options

You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"
  • Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate"
  • Click the "View" button and inspect the certificate and check who is the issuer.

You can see more details like the intermediate certificates that are used in the Details tab.

Who is the issuer of the certificate?

Can you attach a screenshot of the certificate viewer?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options

I don't think it was ever an option in Firefox to completely ignore invalid SSL certificates on all sites...

The steps in cor-el's reply will help you distinguish between possible causes of this problem, which can range from Firefox not being set up to work with your security software (Kaspersky, avast, BitDefender, ESET) to a malware infection.

Also, could you have used Firefox's Refresh feature recently? That may happen if Firefox reports that it is starting/running slowly and you can speed it up by restoring some default settings. If you click that button, your old Firefox settings folder (profile folder) is moved to the desktop and saved in an Old Firefox Data folder. Do you see anything like that?


Two Adobe-related notes:

(1) Your Adobe Acrobat (PDF reader) plugin is out-of-date. To update that plugin, I suggest going to the Help menu in your Adobe software (Adobe Reader, Adobe Acrobat) and using Check for Updates. This should bring you up to version 11.0.11, which is the latest in the 11 series.

(2) You either do not have the Flash player plugin or it is set to "Never Activate". If you need an updated version, you can use this page, choosing the one for "plugin-based browsers": https://www.adobe.com/products/flashplayer/distribution3.html

more options

tmfultz said

It's NO LONGER in the Options menu. EVERY PAGE I try to get to is freaking out over certificates. TELL ME HOW TO TURN IT OFF NOW THAT YOU REMOVED THE OPTION TO.

Me too. This sucks

more options

There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate.

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate.


Hi. Could you please start a new thread for your question?

Then you can provide more information like your operating system and installed extensions and installed plugins.


locking due to age