Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Ebay running very slow in Firefox

  • 4 fhreagra
  • 2 leis an bhfadhb seo
  • 1 view
  • Freagra is déanaí ó XMG

more options

Since probably 3 or 4 weeks ago Ebay through Firefox has been terribly slow. I have selected the option not to track in the address bar and still the same problem. I run ebay through MS Edge and runs perfectly. Happens to me in 3 out of 4 computers. Only in 1 works ok, very strange...

Speed connection in all of them is at least 200mb/s

Thanks.

Since probably 3 or 4 weeks ago Ebay through Firefox has been terribly slow. I have selected the option not to track in the address bar and still the same problem. I run ebay through MS Edge and runs perfectly. Happens to me in 3 out of 4 computers. Only in 1 works ok, very strange... Speed connection in all of them is at least 200mb/s Thanks.

Réiteach roghnaithe

Thank you very much, found there were 2 ad blockers working in the affected computer. SW accelerator was not the problem.

Read this answer in context 👍 0

All Replies (4)

more options

I'm on ebay site or in the app everyday and have no issues. see screenshot You will need to provide proof of the issue. What is slow, getting to the site and or navigating?

Did you try Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search104

Did you clear your browser cache? https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox

more options

Thank you for your answer, problem is navigating. I have tried safe mode and have no problem when in it. I have also cleared cache files and when I restart out of safe mode I go into the same problem. Weird but that is what I am experiencing.

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

more options

Réiteach Roghnaithe

Thank you very much, found there were 2 ad blockers working in the affected computer. SW accelerator was not the problem.