Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google.com Results screen looks totally different in Firefox on this machine only

  • 11 freagra
  • 3 leis an bhfadhb seo
  • 44 views
  • Freagra is déanaí ó cor-el

more options

Hi, when I go to google.com and search for a result it looks totally different than normal. (See picture). It should look like the 2nd Picture. I have restored from multiple backups yet it still shows up like the first picture? on other machines when I use firefox I dont have this issue and I dont have the issue if I use another browser to call up something from google.

Any help someone could give would be appreciated. Thank you

Hi, when I go to google.com and search for a result it looks totally different than normal. (See picture). It should look like the 2nd Picture. I have restored from multiple backups yet it still shows up like the first picture? on other machines when I use firefox I dont have this issue and I dont have the issue if I use another browser to call up something from google. Any help someone could give would be appreciated. Thank you
Attached screenshots

Réiteach roghnaithe

TyDraniu said

You have to change the User Agent to Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

In case you need the steps for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste general.useragent.override and pause while the list is filtered

Firefox should show a bar with the preference name, Boolean Number String, and a + button

(3) Click String, then click the + button

Firefox should open an editing field

(4) Paste the above suggested Windows 7 string into the field

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:96.0) Gecko/20100101 Firefox/96.0

Then press Enter or click the blue check mark button to save the change.

(5) In the search box in the page, type or paste general.oscpu.override and pause while the list is filtered

Firefox should show a bar with the preference name, Boolean Number String, and a + button

(6) Click String, then click the + button

Firefox should open an editing field

(7) Paste the above Firefox 55 on Windows 7 string into the field:

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Then press Enter or click the blue check mark button to save the change.

Does that fool Google?

Read this answer in context 👍 2

All Replies (11)

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Hi thanks for your help. that did not work. what I cant understand is that I went back to old backup when I never had this problem and its still the same way. And in Safe mode I get the same problem? Any other suggestions? Thanks.

Helpful?

more options

I think it's the mobile layout, but I'm not sure why you're getting it. Could you try:

(1) Clear Firefox's Cache

See: How to clear the Firefox cache (just the Cached Web Content, not all Site Data)

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on Google.com, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try loading a Google search in a new tab. Any improvement?

Helpful?

more options

Hi thanks jscher, No that did not work. to tell you what I have done I have actually restored from old backups the whole system, even uninstalled Firefox and reinstalled it. Cleared Cache many times and even formatted the hard drive and then restored from a backup from many sources.

I also tried to use firefox in safe mode and I got the same error.

I mean I guess you would say then the backups had some virus on them? No I have used them before with no problems I have had to restore to this drive a few times before.

I am pretty much out of ideas? Any help or anyone who has had a problem like this? Thanks in advance

Helpful?

more options

You have to change the User Agent to Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Helpful?

more options

Réiteach Roghnaithe

TyDraniu said

You have to change the User Agent to Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

In case you need the steps for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste general.useragent.override and pause while the list is filtered

Firefox should show a bar with the preference name, Boolean Number String, and a + button

(3) Click String, then click the + button

Firefox should open an editing field

(4) Paste the above suggested Windows 7 string into the field

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:96.0) Gecko/20100101 Firefox/96.0

Then press Enter or click the blue check mark button to save the change.

(5) In the search box in the page, type or paste general.oscpu.override and pause while the list is filtered

Firefox should show a bar with the preference name, Boolean Number String, and a + button

(6) Click String, then click the + button

Firefox should open an editing field

(7) Paste the above Firefox 55 on Windows 7 string into the field:

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Then press Enter or click the blue check mark button to save the change.

Does that fool Google?

Helpful?

more options

DUDE!!! you are the MAN!! IT WORKED!!! I had to add the general.useragent.override then the rest and BOOM it worked!! Totally surprised. but what could I have done that would have made this missing while going back to numerous backups of my system when it did work correctly?

Hey but I am not going to look a gift horse in the mouth (now that my google is working correctly I am going to see where that expression came from :) ) thank you very much for your time.

Regards, Vaughn

Helpful?

more options

Hi Vaughn, credit goes to TyDraniu for figuring out the hack you needed. I just wrote out the missing steps.

The preference wasn't missing -- your Firefox didn't need it because it presumably was telling the truth about itself (Firefox 52 on Windows XP). You only need to create an override if you need sites to think you run something else. I don't know why Google doesn't want to give the full results page experience to Windows XP users any more. It is for them to know and us to... stop worrying about, I guess.

Helpful?

more options

Hi Understood. one of those mysterious things. Apologies, TyDraniu thank you again for you answer and solutions , Again Thanks JS for helping with the steps.

Its just amazing you think you know about code and computers and then you find out just how much you really don't know. Never ending learning.

Thanks again guys. Appreciate it.!

Helpful?

more options

I had this exact same problem too.

Firefox ESR 52.9.1 used on Win XP.

I typed in what you said, and it's working again now.

Yes!^_^

Thanks, and I really appreciate your solution.

Helpful?

more options

See also:

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.